summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-09-28 23:59:12 +0200
committerDavid Seifert <soap@gentoo.org>2016-09-28 23:59:43 +0200
commit9cda6ca2c69cd22183d1e10f197ccdb13c3b10c1 (patch)
tree0379da3377f0949037c7317c9465f4d9d87bacbc /net-misc/sslh
parentwww-client/google-chrome-beta: automated update (diff)
downloadgentoo-9cda6ca2c69cd22183d1e10f197ccdb13c3b10c1.tar.gz
gentoo-9cda6ca2c69cd22183d1e10f197ccdb13c3b10c1.tar.bz2
gentoo-9cda6ca2c69cd22183d1e10f197ccdb13c3b10c1.zip
net-misc/sslh: Explicitly build using GNU99 C variant
Gentoo-bug: 595426 * Build using -std=gnu99 due to within-for-loop initializers and __USE_XOPEN2K macro for struct addrinfo. Package-Manager: portage-2.3.1
Diffstat (limited to 'net-misc/sslh')
-rw-r--r--net-misc/sslh/sslh-1.18-r1.ebuild9
1 files changed, 8 insertions, 1 deletions
diff --git a/net-misc/sslh/sslh-1.18-r1.ebuild b/net-misc/sslh/sslh-1.18-r1.ebuild
index 15c62e02d404..cfff780590b9 100644
--- a/net-misc/sslh/sslh-1.18-r1.ebuild
+++ b/net-misc/sslh/sslh-1.18-r1.ebuild
@@ -5,7 +5,7 @@
EAPI=6
MY_P="${PN}-v${PV}"
-inherit systemd toolchain-funcs
+inherit flag-o-matic systemd toolchain-funcs
DESCRIPTION="Port multiplexer - accept both HTTPS and SSH connections on the same port"
HOMEPAGE="http://www.rutschle.net/tech/sslh.shtml"
@@ -33,6 +33,13 @@ PATCHES=(
)
src_compile() {
+ # On older versions of GCC, the default gnu89 variant
+ # will reject within-for-loop initializers, bug #595426
+ # Furthermore, we need to use the gnu variant (gnu99) instead
+ # of the ISO (c99) variant, as we want the __USE_XOPEN2K macro
+ # to be defined.
+ append-cflags -std=gnu99
+
emake \
CC="$(tc-getCC)" \
USELIBCAP=$(usev caps) \