summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-12-14 22:47:48 -0500
committerMike Frysinger <vapier@gentoo.org>2015-12-14 22:48:05 -0500
commit6a58b258d4077ae3f17fd08b7f867f8e308b6ada (patch)
tree5ed637ac823f3a215e4316a3e384be6ff2f1d5bb /net-misc
parentmedia-gfx/simple-scan: add missing USE-dependency on libgusb, bug #568066 (diff)
downloadgentoo-6a58b258d4077ae3f17fd08b7f867f8e308b6ada.tar.gz
gentoo-6a58b258d4077ae3f17fd08b7f867f8e308b6ada.tar.bz2
gentoo-6a58b258d4077ae3f17fd08b7f867f8e308b6ada.zip
net-misc/sslh: fix parallel build failure w/version.h usage
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/sslh/files/sslh-1.17-version-deps.patch13
-rw-r--r--net-misc/sslh/sslh-1.17.ebuild6
2 files changed, 18 insertions, 1 deletions
diff --git a/net-misc/sslh/files/sslh-1.17-version-deps.patch b/net-misc/sslh/files/sslh-1.17-version-deps.patch
new file mode 100644
index 000000000000..c05b87ab46ac
--- /dev/null
+++ b/net-misc/sslh/files/sslh-1.17-version-deps.patch
@@ -0,0 +1,13 @@
+make sure the files using version.h depend on it being generated first
+
+--- a/Makefile
++++ b/Makefile
+@@ -39,7 +39,7 @@
+
+ all: sslh $(MAN) echosrv
+
+-.c.o: *.h
++.c.o: *.h version.h
+ $(CC) $(CFLAGS) $(CPPFLAGS) -c $<
+
+ version.h:
diff --git a/net-misc/sslh/sslh-1.17.ebuild b/net-misc/sslh/sslh-1.17.ebuild
index b6a3380c59f0..8f458c22844f 100644
--- a/net-misc/sslh/sslh-1.17.ebuild
+++ b/net-misc/sslh/sslh-1.17.ebuild
@@ -5,7 +5,7 @@
EAPI=5
MY_P="${PN}-v${PV}"
-inherit toolchain-funcs
+inherit toolchain-funcs eutils
DESCRIPTION="Port multiplexer - accept both HTTPS and SSH connections on the same port"
HOMEPAGE="http://www.rutschle.net/tech/sslh.shtml"
@@ -25,6 +25,10 @@ RESTRICT="test"
S=${WORKDIR}/${MY_P}
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-version-deps.patch
+}
+
src_compile() {
emake \
CC="$(tc-getCC)" \