summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdam Feldman <NP-Hardass@gentoo.org>2020-04-23 21:07:45 -0400
committerAdam Feldman <NP-Hardass@gentoo.org>2020-04-23 21:07:45 -0400
commit7d4fc6f94c43910bcf50559b2c27aac4e2402430 (patch)
tree8ef8a6f54c76474d27127772adc94476febe0802 /net-misc
parentnet-misc/vde: Swap out Mandriva patch for upstream backport (diff)
downloadgentoo-7d4fc6f94c43910bcf50559b2c27aac4e2402430.tar.gz
gentoo-7d4fc6f94c43910bcf50559b2c27aac4e2402430.tar.bz2
gentoo-7d4fc6f94c43910bcf50559b2c27aac4e2402430.zip
net-misc/vde: Bump to latest source in git
Package-Manager: Portage-2.3.96, Repoman-2.3.21 Signed-off-by: Adam Feldman <NP-Hardass@gentoo.org>
Diffstat (limited to 'net-misc')
-rw-r--r--net-misc/vde/Manifest1
-rw-r--r--net-misc/vde/vde-2.3.2_p20191011.ebuild87
-rw-r--r--net-misc/vde/vde-9999.ebuild87
3 files changed, 175 insertions, 0 deletions
diff --git a/net-misc/vde/Manifest b/net-misc/vde/Manifest
index 3893bb286a57..8c5ef64fd5de 100644
--- a/net-misc/vde/Manifest
+++ b/net-misc/vde/Manifest
@@ -1 +1,2 @@
+DIST vde-2.3.2_p20191011.tar.gz 381468 BLAKE2B 6d25df2a4cf89a0159875eac1c2c3a27e6b6856f24494ee2e181ab8d8a2fa9c3350b9c7b9b9474cbcbd8afd50fc61fd167a5cc18398b771d05178c5c3a402f73 SHA512 0e9f9f28a8ef0acd765307908dfd9ab9462f67df21b06be5b48ed1795900be546e28e1869528ee8e5a6d7eb6e6fa91ded116b826a501e13ec7f1562f1b84f971
DIST vde2-2.3.2.tar.bz2 600527 BLAKE2B 6c4900578b992eff914136f29395a822bc52945906d291eee78b3bf7cb806bbf4d8ebeec2080daa10923e98b648d071ce1f846214143e4dce749da9be8b48990 SHA512 51be75fde5a526b988060f25322a8b20289b1677db2e3aa6dbee55875c1d7af564f9d8d201a0a4a1a842471cce06f29fcd83e55a5ff7acfdc36a8349cb2f3cc6
diff --git a/net-misc/vde/vde-2.3.2_p20191011.ebuild b/net-misc/vde/vde-2.3.2_p20191011.ebuild
new file mode 100644
index 000000000000..b8bb5681a369
--- /dev/null
+++ b/net-misc/vde/vde-2.3.2_p20191011.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/virtualsqaure/MY_PN"
+ KEYWORDS=""
+elif [[ ${PV} = *_p* ]]; then
+ inherit autotools
+ MY_PN="vde-2"
+ COMMIT="c7b36a57831a9067c8619c3e17a03e595623b3eb"
+ SRC_URI="https://github.com/virtualsquare/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+ S="${WORKDIR}/${MY_PN}-${COMMIT}"
+else
+ MY_P="${PN}2-${PV}"
+ SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
+HOMEPAGE="https://virtualsquare.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+#IUSE="pcap selinux ssl libressl static-libs"
+# upstream switched to wolfssl
+IUSE="pcap selinux static-libs"
+
+COMMON_DEPS="pcap? ( net-libs/libpcap )"
+# upstream switched to wolfssl
+# ssl? (
+# !libressl? ( dev-libs/openssl:0= )
+# libressl? ( dev-libs/libressl:0= )
+# )"
+DEPEND="${COMMON_DEPS}"
+RDEPEND="${COMMON_DEPS}
+ acct-group/qemu
+ selinux? ( sec-policy/selinux-vde )"
+
+# upstream switched to wolfssl
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] || [[ ${PV} == *_p* ]]; then
+ eautoreconf
+ fi
+# upstream switched to wolfssl
+# has_version ">=dev-libs/openssl-1.1.0" && \
+# eapply "${FILESDIR}/${PN}-2.3.2-openssl-1.1.patch"
+}
+
+src_configure() {
+ filter-flags -O0 -Os
+# upstream switched to wolfssl
+# $(use_enable ssl cryptcab) \
+ econf \
+ --disable-python \
+ --disable-cryptcab \
+ $(use_enable pcap) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ # https://github.com/virtualsquare/vde-2/issues/6
+ emake -j1
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+
+ newinitd "${FILESDIR}"/vde.init-r1 vde
+ newconfd "${FILESDIR}"/vde.conf-r1 vde
+}
+
+pkg_postinst() {
+ einfo "To start vde automatically add it to the default runlevel:"
+ einfo "# rc-update add vde default"
+ einfo "You need to setup tap0 in /etc/conf.d/net"
+ einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+}
diff --git a/net-misc/vde/vde-9999.ebuild b/net-misc/vde/vde-9999.ebuild
new file mode 100644
index 000000000000..b8bb5681a369
--- /dev/null
+++ b/net-misc/vde/vde-9999.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit flag-o-matic
+
+if [[ ${PV} == 9999 ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/virtualsqaure/MY_PN"
+ KEYWORDS=""
+elif [[ ${PV} = *_p* ]]; then
+ inherit autotools
+ MY_PN="vde-2"
+ COMMIT="c7b36a57831a9067c8619c3e17a03e595623b3eb"
+ SRC_URI="https://github.com/virtualsquare/${MY_PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+
+ S="${WORKDIR}/${MY_PN}-${COMMIT}"
+else
+ MY_P="${PN}2-${PV}"
+ SRC_URI="mirror://sourceforge/vde/${MY_P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Virtual distributed ethernet emulator for emulators like qemu, bochs, and uml"
+HOMEPAGE="https://virtualsquare.org"
+
+LICENSE="GPL-2"
+SLOT="0"
+#IUSE="pcap selinux ssl libressl static-libs"
+# upstream switched to wolfssl
+IUSE="pcap selinux static-libs"
+
+COMMON_DEPS="pcap? ( net-libs/libpcap )"
+# upstream switched to wolfssl
+# ssl? (
+# !libressl? ( dev-libs/openssl:0= )
+# libressl? ( dev-libs/libressl:0= )
+# )"
+DEPEND="${COMMON_DEPS}"
+RDEPEND="${COMMON_DEPS}
+ acct-group/qemu
+ selinux? ( sec-policy/selinux-vde )"
+
+# upstream switched to wolfssl
+src_prepare() {
+ default
+ if [[ ${PV} == 9999 ]] || [[ ${PV} == *_p* ]]; then
+ eautoreconf
+ fi
+# upstream switched to wolfssl
+# has_version ">=dev-libs/openssl-1.1.0" && \
+# eapply "${FILESDIR}/${PN}-2.3.2-openssl-1.1.patch"
+}
+
+src_configure() {
+ filter-flags -O0 -Os
+# upstream switched to wolfssl
+# $(use_enable ssl cryptcab) \
+ econf \
+ --disable-python \
+ --disable-cryptcab \
+ $(use_enable pcap) \
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ # https://github.com/virtualsquare/vde-2/issues/6
+ emake -j1
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+
+ newinitd "${FILESDIR}"/vde.init-r1 vde
+ newconfd "${FILESDIR}"/vde.conf-r1 vde
+}
+
+pkg_postinst() {
+ einfo "To start vde automatically add it to the default runlevel:"
+ einfo "# rc-update add vde default"
+ einfo "You need to setup tap0 in /etc/conf.d/net"
+ einfo "To use it as an user be sure to set a group in /etc/conf.d/vde"
+}