summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-nds/ypserv
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-nds/ypserv')
-rw-r--r--net-nds/ypserv/Manifest1
-rw-r--r--net-nds/ypserv/files/rpc.yppasswdd-r122
-rw-r--r--net-nds/ypserv/files/rpc.yppasswdd.confd7
-rw-r--r--net-nds/ypserv/files/rpc.ypxfrd22
-rw-r--r--net-nds/ypserv/files/rpc.ypxfrd-2.2322
-rw-r--r--net-nds/ypserv/files/rpc.ypxfrd.confd3
-rwxr-xr-xnet-nds/ypserv/files/ypserv23
-rw-r--r--net-nds/ypserv/files/ypserv.confd4
-rw-r--r--net-nds/ypserv/metadata.xml7
-rw-r--r--net-nds/ypserv/ypserv-2.26.ebuild77
10 files changed, 188 insertions, 0 deletions
diff --git a/net-nds/ypserv/Manifest b/net-nds/ypserv/Manifest
new file mode 100644
index 000000000000..56f0088fcbfe
--- /dev/null
+++ b/net-nds/ypserv/Manifest
@@ -0,0 +1 @@
+DIST ypserv-2.26.tar.bz2 196037 RMD160 dd2050a64324c3a362a51f4a9b0d330be26c944d SHA1 55757c2303559300dfde8d707f64b6df2b1f0652 SHA256 ba71e4fa9659ebc32325eacb3daa0803332e9ca17e0d0779730ba0e2ece298f8
diff --git a/net-nds/ypserv/files/rpc.yppasswdd-r1 b/net-nds/ypserv/files/rpc.yppasswdd-r1
new file mode 100644
index 000000000000..7e7c36a3b837
--- /dev/null
+++ b/net-nds/ypserv/files/rpc.yppasswdd-r1
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net portmap ypserv
+}
+
+start() {
+ ebegin "Starting rpc.yppasswdd"
+ YOPTS=""
+ if [ -n "${YPPASSWDD_OPTS}" ]; then YOPTS="-- ${YPPASSWDD_OPTS}"; fi
+ start-stop-daemon --start --quiet --exec /usr/sbin/rpc.yppasswdd ${YOPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rpc.yppasswdd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rpc.yppasswdd
+ eend $?
+}
diff --git a/net-nds/ypserv/files/rpc.yppasswdd.confd b/net-nds/ypserv/files/rpc.yppasswdd.confd
new file mode 100644
index 000000000000..0d6673630776
--- /dev/null
+++ b/net-nds/ypserv/files/rpc.yppasswdd.confd
@@ -0,0 +1,7 @@
+# -e chsh allows changing shell through ypchsh,
+# -e chfn allows changing GECOS ("finger") information through ypchfn,
+# -D <dir> allows specification of directory with yp/NIS sources
+# if other than /etc.
+#YPPASSWDD_OPTS="-e chsh -e chfn -D /var/yp/source"
+
+
diff --git a/net-nds/ypserv/files/rpc.ypxfrd b/net-nds/ypserv/files/rpc.ypxfrd
new file mode 100644
index 000000000000..573b010ea923
--- /dev/null
+++ b/net-nds/ypserv/files/rpc.ypxfrd
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net portmap ypserv
+}
+
+start() {
+ ebegin "Starting rpc.ypxfrd"
+ YOPTS=""
+ if [ -n "${YPXFRD_OPTS}" ]; then YOPTS="-- ${YPXFRD_OPTS}"; fi
+ start-stop-daemon --start --quiet --exec /usr/sbin/rpc.ypxfrd ${YOPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rpc.ypxfrd"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rpc.ypxfrd
+ eend $?
+}
diff --git a/net-nds/ypserv/files/rpc.ypxfrd-2.23 b/net-nds/ypserv/files/rpc.ypxfrd-2.23
new file mode 100644
index 000000000000..ae1f92e1b3d4
--- /dev/null
+++ b/net-nds/ypserv/files/rpc.ypxfrd-2.23
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net portmap ypserv
+}
+
+start() {
+ ebegin "Starting rpc.ypxfrd"
+ YOPTS=""
+ if [ -n "${YPXFRD_OPTS}" ]; then YOPTS="-- ${YPXFRD_OPTS}"; fi
+ start-stop-daemon --start --quiet --pidfile /var/run/ypxfrd.pid --exec /usr/sbin/rpc.ypxfrd ${YOPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping rpc.ypxfrd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/ypxfrd.pid --exec /usr/sbin/rpc.ypxfrd
+ eend $?
+}
diff --git a/net-nds/ypserv/files/rpc.ypxfrd.confd b/net-nds/ypserv/files/rpc.ypxfrd.confd
new file mode 100644
index 000000000000..73cfc47e7154
--- /dev/null
+++ b/net-nds/ypserv/files/rpc.ypxfrd.confd
@@ -0,0 +1,3 @@
+# Command line options to pass to rpc.ypxfrd
+# eg: you can pass --port <number> to use a non-standard port
+YPXFRD_OPTS=""
diff --git a/net-nds/ypserv/files/ypserv b/net-nds/ypserv/files/ypserv
new file mode 100755
index 000000000000..a0dd95c6b217
--- /dev/null
+++ b/net-nds/ypserv/files/ypserv
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need net portmap
+ use domainname
+}
+
+start() {
+ ebegin "Starting NIS Server"
+ YOPTS=""
+ if [ -n "${YPSERV_OPTS}" ]; then YOPTS="-- ${YPSERV_OPTS}"; fi
+ start-stop-daemon --start --quiet --exec /usr/sbin/ypserv ${YOPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping NIS Server"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/ypserv
+ eend $?
+}
diff --git a/net-nds/ypserv/files/ypserv.confd b/net-nds/ypserv/files/ypserv.confd
new file mode 100644
index 000000000000..0ae9756dc81b
--- /dev/null
+++ b/net-nds/ypserv/files/ypserv.confd
@@ -0,0 +1,4 @@
+# Config file for /etc/init.d/ypserv
+
+# Command line options to pass to ypserv:
+YPSERV_OPTS=""
diff --git a/net-nds/ypserv/metadata.xml b/net-nds/ypserv/metadata.xml
new file mode 100644
index 000000000000..ff62877c67ae
--- /dev/null
+++ b/net-nds/ypserv/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-nds/ypserv/ypserv-2.26.ebuild b/net-nds/ypserv/ypserv-2.26.ebuild
new file mode 100644
index 000000000000..8eaa6422feb3
--- /dev/null
+++ b/net-nds/ypserv/ypserv-2.26.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit autotools
+
+DESCRIPTION="Network Information Service server"
+HOMEPAGE="http://www.linux-nis.org/nis/"
+SRC_URI="mirror://kernel/linux/utils/net/NIS/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 x86"
+IUSE="slp"
+
+DEPEND=">=sys-libs/gdbm-1.8.0
+ slp? ( net-libs/openslp )"
+RDEPEND="${DEPEND}
+ || ( net-nds/rpcbind net-nds/portmap )"
+
+src_prepare() {
+ # The configure script does not provide a command-line flag to control usage
+ # of slp. Use a brutal method in case we need to disable it.
+ if ! use slp; then
+ sed -i -e 's/USE_SLP=1/USE_SLP=0/g' configure.in || die
+ eautoreconf
+ fi
+}
+
+src_install() {
+ default
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+
+ insinto /etc
+ doins etc/ypserv.conf etc/netgroup etc/netmasks
+ insinto /var/yp
+ newins etc/securenets securenets.default
+
+ newconfd "${FILESDIR}/ypserv.confd" ypserv
+ newconfd "${FILESDIR}/rpc.yppasswdd.confd" rpc.yppasswdd
+ newconfd "${FILESDIR}/rpc.ypxfrd.confd" rpc.ypxfrd
+
+ newinitd "${FILESDIR}/ypserv" ypserv
+ newinitd "${FILESDIR}/rpc.yppasswdd-r1" rpc.yppasswdd
+ newinitd "${FILESDIR}/rpc.ypxfrd-2.23" rpc.ypxfrd
+
+ echo "CONFIG_PROTECT=\"/var/yp/Makefile\"" > "${T}"/10ypserv
+ doenvd "${T}"/10ypserv
+}
+
+pkg_preinst() {
+ # This ebuilds installs an env file which CONFIG_PROTECTs /var/yp/Makefile,
+ # but if the user is migrating from older ypserv, this won't take effect
+ # immediately. Keep the older setup with Makefile.dist file and ask the user
+ # to migrate.
+ if [ -f "${ROOT}/var/yp/Makefile.dist" ]; then
+ mv "${D}/var/yp/Makefile" "${D}/var/yp/Makefile.dist" \
+ || die "mv failed"
+ cp "${ROOT}/var/yp/Makefile" "${D}/var/yp/Makefile" \
+ || die "cp failed"
+ elog "Please remove ${ROOT}/var/yp/Makefile.dist after making sure that"
+ elog "${ROOT}/var/yp/Makefile looks fine to you. It is now"
+ elog "CONFIG_PROTECTed, so further changes should be managed with"
+ elog "usual config management tools like etc-update or dispatch-conf."
+ fi
+}
+
+pkg_postinst() {
+ einfo "To complete setup, you will need to edit /var/yp/securenets,"
+ einfo "/etc/conf.d/ypserv, /etc/ypserv.conf, /etc/conf.d/rpc.yppasswdd"
+ einfo "and possibly /var/yp/Makefile."
+
+ einfo "To start the services at boot, you need to enable ypserv and optionally"
+ einfo "the rpc.yppasswdd and/or rpc.ypxfrd services"
+}