summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-15 20:46:15 +0100
committerIan Delaney <idella4@gentoo.org>2016-03-16 14:46:16 +0800
commitecbe12dd198f3ccc5733a9c04cb525a1704ad275 (patch)
tree8e2a93d062f33c9efe27bd88c6e65ae01717d3f0 /net-p2p/airdcpp-webclient
parentapp-editors/gummi: bump live ebuild to EAPI 6 (diff)
downloadgentoo-ecbe12dd198f3ccc5733a9c04cb525a1704ad275.tar.gz
gentoo-ecbe12dd198f3ccc5733a9c04cb525a1704ad275.tar.bz2
gentoo-ecbe12dd198f3ccc5733a9c04cb525a1704ad275.zip
net-p2p/airdcpp-webclient: bump to 1.0.1
Package-Manager: portage-2.2.27 Closes: https://github.com/gentoo/gentoo/pull/1063
Diffstat (limited to 'net-p2p/airdcpp-webclient')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 6733eb915fcf..d45bf2469639 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-0.16.5.tar.gz 702187 SHA256 d153621ce390ee5d434a63d8af5d46b4b54638984de35ee8340ca63f27f61e16 SHA512 decc359aa569de8d3ae117a7f9ce38d9234564401072a776271ce7dff1e24022ad8d01fbf9cf4cc5238778c3c0cb7031b33e2e8d6a1014034ef507a8c29a6f7b WHIRLPOOL 3c71a391dd3e7a5defa5ec8a3abf580b5850abade28b763ad2548f0cc6df5345002c3a07e7e9db33abdedbd60740b62fc27fb0f8af5022353ac35cb826437e18
DIST airdcpp-webclient-1.0.0.tar.gz 705277 SHA256 46c19884e220f39924a59c98d09743f2e9017a11bc81f7f95f5419798627813b SHA512 5a8523f15f6ee598d9b5dde502a80831ab8bb7c36c2fa60abb88232619c1e0f64ee3a2d08f1f90ec1a8af6ee0571733f353514522975614fc036d9f6655610ac WHIRLPOOL ef9aad1bc02fdcf66355ceea9302bacb79a69561b507963cec59bfb9f423d17316edcbccb1edba596e0acd93971eaf6f45661f5f90b3d16b007ed42b39e67535
+DIST airdcpp-webclient-1.0.1.tar.gz 705436 SHA256 865cb00afa63076ebc1e9f8136380452f8b4d264b8381814cd209acb48525c6c SHA512 5312758d80741434941d43b1312689a25cb96f2e50ca4392074e356dc619d6949fd4ba8a6830ddb0ceb194d2f5a6616eb3b2e772d71efaeb1c49a53fcc5eb541 WHIRLPOOL 804ef5af06aa406511e10b22e320c031d59777d8f5e4ce1dfb02ea03559558741ff5ed6659c6a9175d6f4e1d9e87e0d564a01c9d23d0cba36bf1cf428d018e83
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.1.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.1.ebuild
new file mode 100644
index 000000000000..9c383243f1bd
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-1.0.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://github.com/airdcpp-web/airdcpp-webclient"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost
+ dev-libs/geoip
+ dev-libs/leveldb
+ dev-libs/openssl:0=
+ net-libs/miniupnpc
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp )
+ tbb? ( dev-cpp/tbb )
+"
+DEPEND="
+ dev-lang/python:*
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DLIB_INSTALL_DIR=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+ cmake-utils_src_install
+}
+
+pkg_setup() {
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}