summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2017-06-10 13:40:20 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-24 07:36:26 +0200
commit6a014f15595971edd3b1cc957bb65c8122a8da02 (patch)
treeea7461c19686996433737e9666a1fe8a52107a93 /net-p2p
parentapp-admin/webapp-config: Removes configparser blocker from 1.55 (diff)
downloadgentoo-6a014f15595971edd3b1cc957bb65c8122a8da02.tar.gz
gentoo-6a014f15595971edd3b1cc957bb65c8122a8da02.tar.bz2
gentoo-6a014f15595971edd3b1cc957bb65c8122a8da02.zip
net-p2p/airdcpp-webclient: bump to 2.1.0, add Python 3.6, minor changes
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/airdcpp-webclient/Manifest1
-rw-r--r--net-p2p/airdcpp-webclient/airdcpp-webclient-2.1.0.ebuild68
-rw-r--r--net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.1.0-disable-automagic.patch40
3 files changed, 109 insertions, 0 deletions
diff --git a/net-p2p/airdcpp-webclient/Manifest b/net-p2p/airdcpp-webclient/Manifest
index 80f155d9f184..e223aa66ff5d 100644
--- a/net-p2p/airdcpp-webclient/Manifest
+++ b/net-p2p/airdcpp-webclient/Manifest
@@ -1,2 +1,3 @@
DIST airdcpp-webclient-1.4.1.tar.gz 743631 SHA256 9acb61366c91a7aaa03cae58e9aee28ccac05ffe9dff0ec947836fa81967f27f SHA512 7b973251574cb5b49942efa868cef9f689fcf8d804be632ad17c445be98ab55ca9973c5fe9dce052d542006d47a7850af7d236953010c2c0e3158c54e448afe1 WHIRLPOOL e43ccfddc50dbdd0ce8a3cd5b00fc4c844ed69051967d67cca9c9c72b073227d1d20ac510d34b07161c231c7c7d69b945d60872d8756a0ef2c91dfe4a843fe06
DIST airdcpp-webclient-2.0.1.tar.gz 843348 SHA256 312466c20b6c3125b6bf88b26f23618f67546722bb0372089537c5a88cc3460b SHA512 2c31712816a59560f248f42b3ad3ffe5d2f76a64860bf515a537b79dda5a579bac17d5d8ba46d9d57554a0b93b9384696a299b2f2096e05c62ea4b97e42d06bc WHIRLPOOL e78d998d8398eb705599ed0f249242d460586288c5649b810606321334a7ea66bd2cb9f119789eec19038e1e3d9ce376a93e96bd18fe15bba10d7a80c97ee580
+DIST airdcpp-webclient-2.1.0.tar.gz 844435 SHA256 a8d8a33e3974d23009359709da0bee85e8983e3ea1fe78f21a867078f93b81fa SHA512 755555d30183e772ad5d2e38a813f548e3322ca034b759200f289a834ae21b64f56102f57a13832a837e8a11324efe74a860e941a0f28a02d1f843aed92a328f WHIRLPOOL 5a0a61bcf0ad1de1706786fc2080aeba0ae634386957876a20d1ca638d3fc8b724f5c866d59588f4958a6010fc192d474f1cfe7ff04d4403106ba631b800739b
diff --git a/net-p2p/airdcpp-webclient/airdcpp-webclient-2.1.0.ebuild b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.1.0.ebuild
new file mode 100644
index 000000000000..cee109040c4f
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/airdcpp-webclient-2.1.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy{,3} )
+
+inherit cmake-utils python-any-r1 user
+
+DESCRIPTION="Cross-platform Direct Connect client"
+HOMEPAGE="https://airdcpp-web.github.io/"
+SRC_URI="https://github.com/airdcpp-web/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="nat-pmp +tbb +webui"
+
+RDEPEND="
+ app-arch/bzip2
+ dev-cpp/websocketpp
+ dev-libs/boost:=
+ dev-libs/geoip
+ dev-libs/leveldb:=
+ dev-libs/openssl:0=[-bindist]
+ net-libs/miniupnpc:=
+ sys-libs/zlib
+ virtual/libiconv
+ nat-pmp? ( net-libs/libnatpmp:= )
+ tbb? ( dev-cpp/tbb:= )
+"
+DEPEND="
+ virtual/pkgconfig
+ ${PYTHON_DEPS}
+ ${RDEPEND}
+"
+PDEPEND="webui? ( www-apps/airdcpp-webui )"
+
+# https://github.com/airdcpp-web/airdcpp-webclient/pull/248
+PATCHES=( "${FILESDIR}/${P}-disable-automagic.patch" )
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+ enewgroup airdcppd
+ enewuser airdcppd -1 -1 /var/lib/airdcppd airdcppd
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_WEB_UI=OFF
+ -DENABLE_NATPMP=$(usex nat-pmp)
+ -DENABLE_TBB=$(usex tbb)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ newconfd "${FILESDIR}/airdcppd.confd" airdcppd
+ newinitd "${FILESDIR}/airdcppd.initd" airdcppd
+ keepdir /var/lib/airdcppd
+ fowners airdcppd:airdcppd /var/lib/airdcppd
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ elog "Run 'airdcppd --configure' to set up ports and authentication"
+ fi
+}
diff --git a/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.1.0-disable-automagic.patch b/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.1.0-disable-automagic.patch
new file mode 100644
index 000000000000..4e8360e69677
--- /dev/null
+++ b/net-p2p/airdcpp-webclient/files/airdcpp-webclient-2.1.0-disable-automagic.patch
@@ -0,0 +1,40 @@
+commit 8ca829a832db304769ac0d107471ab23d4ce3cce
+Author: Louis Sautier <sautier.louis@gmail.com>
+Date: Wed Jun 21 23:10:03 2017 +0200
+
+ Add options to disable libnatpnp and tbb support
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4d8a49c7..826fce3b 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -47,6 +47,10 @@ endif()
+
+
+ # OPTIONS
++OPTION(ENABLE_NATPMP "Enable support for the NAT-PMP protocol via libnatpmp"
++ ON)
++OPTION(ENABLE_TBB "Enable support of the TBB library to improve performance"
++ ON)
+
+ # 1.x had a different default value
+ unset(INSTALL_RUNTIME_PATH CACHE)
+@@ -99,12 +103,16 @@ find_package (OpenSSL REQUIRED)
+ find_package (Threads REQUIRED)
+ find_package (Iconv REQUIRED)
+ find_package (Miniupnpc REQUIRED)
+-find_package (LibNatpmp)
++if(ENABLE_NATPMP)
++ find_package (LibNatpmp)
++endif()
+ find_package (Git)
+ find_package (LevelDB REQUIRED)
+ find_package (websocketpp REQUIRED)
+ find_package (Backtrace)
+-find_package (TBB)
++if(ENABLE_TBB)
++ find_package (TBB)
++endif()
+
+ if (NOT BUILD_SHARED_LIBS)
+ # Shared LevelDB libraries are linked against Snappy already