summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-01-23 13:37:38 +0100
committerManuel Rüger <mrueg@gentoo.org>2016-01-23 13:37:38 +0100
commit17c8acc26ddd6477e326cee076634a86c130a514 (patch)
treeefe5825b2c824944fc9e61a8e131cf64522b9171 /net-print/cups-filters
parentx11-drivers/xf86-video-r128: Remove old (diff)
downloadgentoo-17c8acc26ddd6477e326cee076634a86c130a514.tar.gz
gentoo-17c8acc26ddd6477e326cee076634a86c130a514.tar.bz2
gentoo-17c8acc26ddd6477e326cee076634a86c130a514.zip
net-print/cups-filters: Version bump
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-print/cups-filters')
-rw-r--r--net-print/cups-filters/Manifest1
-rw-r--r--net-print/cups-filters/cups-filters-1.8.1.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/net-print/cups-filters/Manifest b/net-print/cups-filters/Manifest
index bc14e43007f3..91b6d7941aa2 100644
--- a/net-print/cups-filters/Manifest
+++ b/net-print/cups-filters/Manifest
@@ -2,3 +2,4 @@ DIST cups-filters-1.0.71.tar.xz 1339116 SHA256 3180aa209c383402822e568ccef8e1ca4
DIST cups-filters-1.4.0.tar.xz 1373724 SHA256 0aa63f82a3feb5c46136b917722ee1565b4c1e2e533db4716f62d31e29c6579a SHA512 c1f8b45ef79747405cbe114fc35f14cf30d3a7f13753bbfb524cb2ce7c7e4f10a4af8cd1df978a231c119d0e893efed946b25183f8898253b5be72ed9c926963 WHIRLPOOL ebce525e81f2ce6b040b154111e71df49f341337073795a156ac20b502352f2711034a651e1910cde7266de2177f02dabcf9efd86ab1d2afc57140dd4a697d9e
DIST cups-filters-1.5.0.tar.xz 1375588 SHA256 f22a8864e8d5b693795605a31345c08cc68f85120ebde9a0aa7bc27639815932 SHA512 81574f8368aaef61aeee4369caa394f2c8cdc717b03687d8a17c7927892f07cff68f1efb8d674757cb97001b55fd58fa5c14784a510ce9d31e385b1a73cd18c7 WHIRLPOOL 4201d08a2bb76d349a6b9f7220eb48dea86bb81c0cedbe8dcb8796c49ce26f67f6a7c49677b4fc7b6f865eb20e3c806746f565668e9f9e1e3935630621d032cd
DIST cups-filters-1.6.0.tar.xz 1377952 SHA256 39e53db81df7aa951507c72ced52b9b0e9e4294c3f83e8b717fb42c03a557c97 SHA512 dd7671dbb13588829337e4ae4d533dc6c1e17f75ca240a6d43bb0a30a2453fffa9a1541d7b041024a6d4cbb939790802a8c3947cd319590fa37c7ce237232b9d WHIRLPOOL 297ec0aeebd336a583f410099711cd6449b7b765fb29099b1ba5fd2d6a4c5dd7fd2824eb7aa26ca59070d7b866a68966d609729a3f58c07e1e13011af7e7e33e
+DIST cups-filters-1.8.1.tar.xz 1372152 SHA256 4e7d8953f910b7a992471d641590964c20f26da5d94c10de932dde4f5c03e91e SHA512 9b254dbcc90df335b8162495f5c2846f77c8006128458e54753877d0b5e6b1d696ae28378b4b9a8275626d7f537651e1cb55aac67588ee5fa319898912dd9e08 WHIRLPOOL 7a41fdeed84ee1f0f18aa201633ce5e77040499bf7a2ac5cf324f45876ca2a8072ddf5b947d8ac6526839bcd15c351324d556967d4e303d6b96aaf5bd44c2ed3
diff --git a/net-print/cups-filters/cups-filters-1.8.1.ebuild b/net-print/cups-filters/cups-filters-1.8.1.ebuild
new file mode 100644
index 000000000000..a46c8794f3ab
--- /dev/null
+++ b/net-print/cups-filters/cups-filters-1.8.1.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+GENTOO_DEPEND_ON_PERL=no
+
+inherit base eutils perl-module autotools systemd
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit bzr
+ EBZR_REPO_URI="http://bzr.linuxfoundation.org/openprinting/cups-filters"
+ KEYWORDS=""
+else
+ SRC_URI="http://www.openprinting.org/download/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-fbsd ~m68k-mint"
+fi
+DESCRIPTION="Cups PDF filters"
+HOMEPAGE="http://www.linuxfoundation.org/collaborate/workgroups/openprinting/pdfasstandardprintjobformat"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+IUSE="dbus +foomatic jpeg perl png static-libs tiff zeroconf"
+
+RDEPEND="
+ >=app-text/ghostscript-gpl-9.09
+ app-text/poppler:=[cxx,jpeg?,lcms,tiff?,xpdf-headers(+)]
+ >=app-text/qpdf-3.0.2:=
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/lcms:2
+ >=net-print/cups-1.7.3
+ !<=net-print/cups-1.5.9999
+ sys-devel/bc
+ sys-libs/zlib
+ dbus? ( sys-apps/dbus )
+ foomatic? ( !net-print/foomatic-filters )
+ jpeg? ( virtual/jpeg:0 )
+ perl? ( dev-lang/perl:= )
+ png? ( media-libs/libpng:0= )
+ tiff? ( media-libs/tiff:0 )
+ zeroconf? ( net-dns/avahi[dbus] )
+"
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+"
+
+src_prepare() {
+ base_src_prepare
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_enable dbus) \
+ $(use_enable zeroconf avahi) \
+ $(use_enable static-libs static) \
+ --with-fontdir="fonts/conf.avail" \
+ --with-pdftops=pdftops \
+ --enable-imagefilters \
+ $(use_with jpeg) \
+ $(use_with png) \
+ $(use_with tiff) \
+ --with-rcdir=no \
+ --with-browseremoteprotocols=DNSSD,CUPS \
+ --without-php
+}
+
+src_compile() {
+ MAKEOPTS=-j1 default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_configure
+ perl-module_src_compile
+ popd > /dev/null
+ fi
+}
+
+src_install() {
+ default
+
+ if use perl; then
+ pushd "${S}/scripting/perl" > /dev/null
+ perl-module_src_install
+ perl_delete_localpod
+ popd > /dev/null
+ fi
+
+ # workaround: some printer drivers still require pstoraster and pstopxl, bug #383831
+ dosym /usr/libexec/cups/filter/gstoraster /usr/libexec/cups/filter/pstoraster
+ dosym /usr/libexec/cups/filter/gstopxl /usr/libexec/cups/filter/pstopxl
+
+ prune_libtool_files --all
+
+ cp "${FILESDIR}"/cups-browsed.init.d "${T}"/cups-browsed || die
+
+ if ! use zeroconf ; then
+ sed -i -e 's:need cupsd avahi-daemon:need cupsd:g' "${T}"/cups-browsed || die
+ sed -i -e 's:cups\.service avahi-daemon\.service:cups.service:g' "${S}"/utils/cups-browsed.service || die
+ fi
+
+ if ! use foomatic ; then
+ # this needs an upstream solution / configure switch
+ rm -v "${ED}/usr/bin/foomatic-rip" || die
+ rm -v "${ED}/usr/libexec/cups/filter/foomatic-rip" || die
+ rm -v "${ED}/usr/share/man/man1/foomatic-rip.1" || die
+ fi
+
+ doinitd "${T}"/cups-browsed
+ systemd_dounit "${S}/utils/cups-browsed.service"
+}
+
+pkg_postinst() {
+ if ! use foomatic ; then
+ ewarn "You are disabling the foomatic code in cups-filters. Please do that ONLY if absolutely."
+ ewarn "necessary. net-print/foomatic-filters as replacement is deprecated and unmaintained."
+ fi
+}