summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2016-01-22 20:55:34 +0300
committerAndrew Savchenko <bircoph@gentoo.org>2016-01-22 21:04:21 +0300
commit6ddaf34615d366c87f059bcda4768fea74b30376 (patch)
treeb4728426bca78e0b9633b4549ac2eefd21f6dd53 /net-proxy/privoxy
parentapp-admin/consul: version bump to 0.6.3 (diff)
downloadgentoo-6ddaf34615d366c87f059bcda4768fea74b30376.tar.gz
gentoo-6ddaf34615d366c87f059bcda4768fea74b30376.tar.bz2
gentoo-6ddaf34615d366c87f059bcda4768fea74b30376.zip
net-proxy/privoxy: version bump
See security bug 572584. Package-Manager: portage-2.2.27 Signed-off-by: Andrew Savchenko <bircoph@gentoo.org>
Diffstat (limited to 'net-proxy/privoxy')
-rw-r--r--net-proxy/privoxy/Manifest1
-rw-r--r--net-proxy/privoxy/privoxy-3.0.24.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/net-proxy/privoxy/Manifest b/net-proxy/privoxy/Manifest
index 9b273e38ead2..f7e02c37977d 100644
--- a/net-proxy/privoxy/Manifest
+++ b/net-proxy/privoxy/Manifest
@@ -1 +1,2 @@
DIST privoxy-3.0.23-stable-src.tar.gz 1715099 SHA256 80b1a172d0518a9f95cde83d18dc62b9c7f117b9ada77bdcd3d310107f28f964 SHA512 487513f4f6f8c868b537132599d0f573384a0b7ed2b3c6778b163d61f94a419e1594d4e0bff286051902bfca292d68c5eeef215955f072c1744bef50db279c25 WHIRLPOOL 68f3ce6dd86a95bb515af2dfe4f166263800f8ff71fb266cb7d8630888f30c93194634b74c5d491a5687afc5842428bd23811ef71ee9358f1cd7ec5ad1ce11a4
+DIST privoxy-3.0.24-stable-src.tar.gz 1728265 SHA256 a381f6dc78f08de0d4a2342d47a5949a6608073ada34b933137184f3ca9fb012 SHA512 4002df09613f06b337d3d56034443ac1481bc99dbd063857a3b02d6c2cec62b1d0cdf23a6396daba74e2be5b899d85e967dacb8e875f15e0824f00038b212705 WHIRLPOOL 4d23baad88bdc0c1cfad48440d464e5ec40208a317653b0c2e6a8bbd8a831d441576ddd41e82cddde73e7f9d3e954afdd654d1a163b1123379699d7b40159d96
diff --git a/net-proxy/privoxy/privoxy-3.0.24.ebuild b/net-proxy/privoxy/privoxy-3.0.24.ebuild
new file mode 100644
index 000000000000..4c7bb7e2e5f2
--- /dev/null
+++ b/net-proxy/privoxy/privoxy-3.0.24.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit eutils toolchain-funcs autotools systemd user
+
+[ "${PV##*_}" = "beta" ] &&
+ PRIVOXY_STATUS="beta" ||
+ PRIVOXY_STATUS="stable"
+
+HOMEPAGE="http://www.privoxy.org http://sourceforge.net/projects/ijbswa/"
+DESCRIPTION="A web proxy with advanced filtering capabilities for protecting privacy against Internet junk"
+SRC_URI="mirror://sourceforge/ijbswa/${P%_*}-${PRIVOXY_STATUS}-src.tar.gz"
+
+IUSE="+acl editor external-filters +fast-redirects +force graceful-termination
++image-blocking ipv6 lfs png-images selinux +stats +threads toggle
+whitelists +zlib"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+LICENSE="GPL-2"
+
+DEPEND="dev-libs/libpcre
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-privoxy )"
+
+REQUIRED_USE="toggle? ( editor )"
+
+S="${WORKDIR}/${P%_*}-${PRIVOXY_STATUS}"
+
+pkg_setup() {
+ enewgroup privoxy
+ enewuser privoxy -1 -1 /etc/privoxy privoxy
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-3.0.19-gentoo.patch
+ # autoreconf needs to be called even if we don't modify any autotools source files
+ # See main makefile
+ eautoreconf
+}
+
+src_configure() {
+
+ econf \
+ $(use_enable acl acl-support) \
+ $(use_enable editor) \
+ $(use_enable fast-redirects) \
+ $(use_enable force) \
+ $(use_enable graceful-termination) \
+ $(use_enable image-blocking) \
+ $(use_enable ipv6 ipv6-support) \
+ $(use_enable lfs large-file-support) \
+ $(use_enable png-images no-gifs) \
+ $(use_enable stats) \
+ $(use_enable threads pthread) \
+ $(use_enable toggle) \
+ $(use_enable whitelists trust-files) \
+ $(use_enable zlib) \
+ $(usex zlib --enable-compression "") \
+ --enable-dynamic-pcre \
+ --with-user=privoxy \
+ --with-group=privoxy \
+ --sysconfdir=/etc/privoxy \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install () {
+ default
+
+ newinitd "${FILESDIR}/privoxy.initd" privoxy
+ systemd_dounit "${FILESDIR}"/${PN}.service
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/privoxy.logrotate" privoxy
+
+ diropts -m 0750 -g privoxy -o privoxy
+ keepdir /var/log/privoxy
+}