summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /perl-core/Digest-SHA
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'perl-core/Digest-SHA')
-rw-r--r--perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild24
-rw-r--r--perl-core/Digest-SHA/Manifest1
-rw-r--r--perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch16
-rw-r--r--perl-core/Digest-SHA/metadata.xml9
4 files changed, 50 insertions, 0 deletions
diff --git a/perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild b/perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild
new file mode 100644
index 000000000000..da3daacb174c
--- /dev/null
+++ b/perl-core/Digest-SHA/Digest-SHA-5.880.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=MSHELOR
+MODULE_VERSION=5.88
+inherit perl-module
+
+DESCRIPTION="Perl extension for SHA-1/224/256/384/512"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="test? (
+ dev-perl/Test-Pod
+ dev-perl/Test-Pod-Coverage
+)"
+
+PATCHES=( "${FILESDIR}/${P}-CFLAGS.patch" )
+
+SRC_TEST="do"
diff --git a/perl-core/Digest-SHA/Manifest b/perl-core/Digest-SHA/Manifest
new file mode 100644
index 000000000000..009163c2cba0
--- /dev/null
+++ b/perl-core/Digest-SHA/Manifest
@@ -0,0 +1 @@
+DIST Digest-SHA-5.88.tar.gz 42494 SHA256 e74d9afbbc9779dab4647a2ecb6f9832143474e030eac763248d62d5c49f0d7e SHA512 7d29c6048c8c894d7b3b76c2edaee27c8aec82708690a69bb4e13d4fe121559da8a68b7b128c57540145975e9910f2a1cdfc21155158e78a6f921f4ab3847188 WHIRLPOOL 6fcecb9d73299d21095c4a0ada0867edc36341f61f437494d4afd20a5bdef651a875be0062e82a405c2b791445e2dab168d96e0c2100296935e568b09fb81ac2
diff --git a/perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch b/perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch
new file mode 100644
index 000000000000..e2a8d096d22e
--- /dev/null
+++ b/perl-core/Digest-SHA/files/Digest-SHA-5.880.0-CFLAGS.patch
@@ -0,0 +1,16 @@
+diff -ruN Digest-SHA-5.88.orig/Makefile.PL Digest-SHA-5.88/Makefile.PL
+--- Digest-SHA-5.88.orig/Makefile.PL 2014-03-09 11:36:39.000000000 +0100
++++ Digest-SHA-5.88/Makefile.PL 2014-11-29 00:52:48.089987473 +0100
+@@ -27,12 +27,6 @@
+ }
+ }
+
+- # Enhance performance on Intel when using gcc
+-
+-if ($Config{archname} =~ /^i[3456]86/ && $Config{ccname} eq 'gcc') {
+- push(@extra, OPTIMIZE => '-O1 -fomit-frame-pointer');
+-}
+-
+ my %att = (
+ 'NAME' => 'Digest::SHA',
+ 'VERSION_FROM' => $PM,
diff --git a/perl-core/Digest-SHA/metadata.xml b/perl-core/Digest-SHA/metadata.xml
new file mode 100644
index 000000000000..910736553634
--- /dev/null
+++ b/perl-core/Digest-SHA/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Digest-SHA</remote-id>
+ <remote-id type="cpan-module">Digest::SHA</remote-id>
+ </upstream>
+</pkgmetadata>