summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /perl-core/Math-BigInt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'perl-core/Math-BigInt')
-rw-r--r--perl-core/Math-BigInt/Manifest1
-rw-r--r--perl-core/Math-BigInt/Math-BigInt-1.999.300.ebuild24
-rw-r--r--perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch21
-rw-r--r--perl-core/Math-BigInt/metadata.xml12
4 files changed, 58 insertions, 0 deletions
diff --git a/perl-core/Math-BigInt/Manifest b/perl-core/Math-BigInt/Manifest
new file mode 100644
index 000000000000..c981014e85a5
--- /dev/null
+++ b/perl-core/Math-BigInt/Manifest
@@ -0,0 +1 @@
+DIST Math-BigInt-1.9993.tar.gz 215143 SHA256 d937c0d1afbb3ddd9b666177faf56471b6c2d1917863db5879d04a2d1a69bf7e SHA512 23ae7d11094f6bf5df45a2c3a01a7d9895b244156b8f48497edbfee4de0e56588e59abb4b1fa8808f2e221bd63eae175cd13987c7dc93867b8f969fbf54b6f15 WHIRLPOOL 70d9899003d1b547b066170fb397d03cfddd0edfdeb9beadf4998ee59f4b18fcbce480bf371ef2f3d35ec86f30b883fcdf2a70765cf239b0f73320766c8048e0
diff --git a/perl-core/Math-BigInt/Math-BigInt-1.999.300.ebuild b/perl-core/Math-BigInt/Math-BigInt-1.999.300.ebuild
new file mode 100644
index 000000000000..83c1a5ef722b
--- /dev/null
+++ b/perl-core/Math-BigInt/Math-BigInt-1.999.300.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=PJACKLAM
+MODULE_VERSION=1.9993
+inherit perl-module eutils
+
+DESCRIPTION="Arbitrary size floating point math package"
+
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ~s390 ~sh sparc x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=virtual/perl-Scalar-List-Utils-1.140.0"
+DEPEND="${RDEPEND}"
+
+PDEPEND=">=virtual/perl-Math-BigInt-FastCalc-0.270.0
+ >=virtual/perl-bignum-0.220.0
+ >=virtual/perl-Math-BigRat-0.260.200"
+
+SRC_TEST="do"
diff --git a/perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch b/perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch
new file mode 100644
index 000000000000..d62e86995bfa
--- /dev/null
+++ b/perl-core/Math-BigInt/files/Math-BigInt-1.997.0-overload.patch
@@ -0,0 +1,21 @@
+diff -u Math-BigInt-1.997/lib/Math/BigInt.pm Math-BigInt-1.997-r1/lib/Math/BigInt.pm
+--- Math-BigInt-1.997/lib/Math/BigInt.pm 2011-09-03 02:26:41.000000000 -0400
++++ Math-BigInt-1.997-r1/lib/Math/BigInt.pm 2012-07-17 20:32:26.630203065 -0400
+@@ -40,6 +40,9 @@
+ # Thus inheritance of overload operators becomes possible and transparent for
+ # our subclasses without the need to repeat the entire overload section there.
+
++# https://github.com/ilmari/perl/commit/5e0688b6067afdfb59fdfa9923e658ed40c9f246
++# We register ops that are not registerable yet, so suppress warnings
++{ no warnings;
+ use overload
+ '=' => sub { $_[0]->copy(); },
+
+@@ -151,6 +154,7 @@
+ '""' => sub { $_[0]->bstr(); },
+ '0+' => sub { $_[0]->numify(); }
+ ;
++} # no warnings scope
+
+ ##############################################################################
+ # global constants, flags and accessory
diff --git a/perl-core/Math-BigInt/metadata.xml b/perl-core/Math-BigInt/metadata.xml
new file mode 100644
index 000000000000..62f2a74a972c
--- /dev/null
+++ b/perl-core/Math-BigInt/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Math-BigInt</remote-id>
+ <remote-id type="cpan-module">Math::BigFloat</remote-id>
+ <remote-id type="cpan-module">Math::BigInt</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::Calc</remote-id>
+ <remote-id type="cpan-module">Math::BigInt::CalcEmu</remote-id>
+ </upstream>
+</pkgmetadata>