summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-astronomy/casacore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-astronomy/casacore')
-rw-r--r--sci-astronomy/casacore/Manifest1
-rw-r--r--sci-astronomy/casacore/casacore-1.5.0-r1.ebuild72
-rw-r--r--sci-astronomy/casacore/files/1.3.0-implicits.patch166
-rw-r--r--sci-astronomy/casacore/files/1.3.0-libdir.patch196
-rw-r--r--sci-astronomy/casacore/files/1.5.0-gcc47.patch22
-rw-r--r--sci-astronomy/casacore/files/1.5.0-gcc48.patch11
-rw-r--r--sci-astronomy/casacore/files/1.5.0-sysdep.patch17
-rw-r--r--sci-astronomy/casacore/metadata.xml16
8 files changed, 501 insertions, 0 deletions
diff --git a/sci-astronomy/casacore/Manifest b/sci-astronomy/casacore/Manifest
new file mode 100644
index 000000000000..204609ba9a0b
--- /dev/null
+++ b/sci-astronomy/casacore/Manifest
@@ -0,0 +1 @@
+DIST casacore-1.5.0.tar.bz2 6327906 SHA256 95ec894b5721ee2391c0d79fc45528c431edb2c6b335ad67fe0b6afabf0c70cb SHA512 a3e108f525775ec5022005ce73810a6bc8eb0a6abcbcaed96f2af3ba7911a3675872708ea53afbfb8a143312709a336aabca21cf1fea0396cc4adc56ba08f3f1 WHIRLPOOL c0aa888a9123ec5b7a5e0eedc8c5fe88241c6e7a9f9d138361e68b0f2da17a8a6275250a07eaa7ac55d2a7c17145478ca1668ae8ce11fb17def61e86afb534b8
diff --git a/sci-astronomy/casacore/casacore-1.5.0-r1.ebuild b/sci-astronomy/casacore/casacore-1.5.0-r1.ebuild
new file mode 100644
index 000000000000..1ff76f8621db
--- /dev/null
+++ b/sci-astronomy/casacore/casacore-1.5.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils eutils toolchain-funcs fortran-2
+
+DESCRIPTION="Core libraries for the Common Astronomy Software Applications"
+HOMEPAGE="http://code.google.com/p/casacore/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+#KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+# de-keyworded until casa-data catches up
+KEYWORDS=""
+SLOT="0"
+IUSE="+data doc fftw hdf5 openmp threads test"
+
+RDEPEND="
+ sci-libs/cfitsio:0=
+ sci-astronomy/wcslib:0=
+ sys-libs/readline:0=
+ virtual/blas
+ virtual/lapack
+ data? ( sci-astronomy/casa-data )
+ fftw? ( sci-libs/fftw:3.0= )
+ hdf5? ( sci-libs/hdf5:0= )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+ test? ( sci-astronomy/casa-data )"
+
+PATCHES=(
+ "${FILESDIR}"/1.3.0-implicits.patch
+ "${FILESDIR}"/1.3.0-libdir.patch
+ "${FILESDIR}"/1.5.0-sysdep.patch
+ "${FILESDIR}"/1.5.0-gcc47.patch
+ "${FILESDIR}"/1.5.0-gcc48.patch
+)
+
+pkg_setup() {
+ if use openmp && [[ $(tc-getCC)$ == *gcc* ]] && ! tc-has-openmp; then
+ ewarn "You are using gcc but without OpenMP capabilities"
+ die "Need an OpenMP capable compiler"
+ fi
+ fortran-2_pkg_setup
+}
+
+src_configure() {
+ has_version sci-libs/hdf5[mpi] && export CXX=mpicxx
+ local mycmakeargs=(
+ -DENABLE_SHARED=ON
+ -DDATA_DIR="${EPREFIX}/usr/share/casa/data"
+ $(cmake-utils_use_build test TESTING)
+ $(cmake-utils_use_use fftw FFTW3)
+ $(cmake-utils_use_use hdf5 HDF5)
+ $(cmake-utils_use_use threads THREADS)
+ $(cmake-utils_use_use openmp OPENMP)
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ use doc && doxygen doxygen.cfg
+}
+
+src_install(){
+ cmake-utils_src_install
+ use doc && dohtml -r doc/html/*
+}
diff --git a/sci-astronomy/casacore/files/1.3.0-implicits.patch b/sci-astronomy/casacore/files/1.3.0-implicits.patch
new file mode 100644
index 000000000000..0ff631a90b6f
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.3.0-implicits.patch
@@ -0,0 +1,166 @@
+diff -Nur casacore-1.3.0.orig/casa/HDF5/HDF5DataSet.cc casacore-1.3.0/casa/HDF5/HDF5DataSet.cc
+--- casacore-1.3.0.orig/casa/HDF5/HDF5DataSet.cc 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/casa/HDF5/HDF5DataSet.cc 2011-05-16 17:29:12.000000000 +0100
+@@ -174,7 +174,7 @@
+ H5Pset_chunk(itsPLid, rank, cs.storage());
+ // Create the data set.
+ setHid (H5Dcreate(parentHid, name.chars(), itsDataType.getHidFile(),
+- itsDSid, NULL, itsPLid, NULL));
++ itsDSid, 0, itsPLid, 0));
+ if (! isValid()) {
+ throw HDF5Error("Data set array " + name + " could not be created");
+ }
+@@ -185,7 +185,7 @@
+ itsParent = &parentHid;
+ setName (name);
+ // Open the dataset.
+- setHid (H5Dopen(parentHid, name.chars(), NULL));
++ setHid (H5Dopen(parentHid, name.chars(), 0));
+ if (! isValid()) {
+ throw HDF5Error("Data set array " + name + " does not exist");
+ }
+@@ -271,7 +271,7 @@
+
+ DataType HDF5DataSet::getDataType (hid_t parentHid, const String& name)
+ {
+- hid_t id = H5Dopen(parentHid, name.chars(), NULL);
++ hid_t id = H5Dopen(parentHid, name.chars(), 0);
+ if (id < 0) {
+ throw HDF5Error("Data set array " + name + " does not exist");
+ }
+diff -Nur casacore-1.3.0.orig/casa/HDF5/test/tHDF5.cc casacore-1.3.0/casa/HDF5/test/tHDF5.cc
+--- casacore-1.3.0.orig/casa/HDF5/test/tHDF5.cc 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/casa/HDF5/test/tHDF5.cc 2011-05-16 17:29:12.000000000 +0100
+@@ -126,7 +126,7 @@
+ H5Pset_chunk (plId, rank, chunkShp);
+ // Create the data set.
+ setId = H5Dcreate (fileId, "dataset", typeIdFile,
+- dsId, NULL, plId, NULL);
++ dsId, 0, plId, 0);
+ check (setId, "Failed to create dataset");
+ }
+
+@@ -136,7 +136,7 @@
+ typeIdFile = H5Tcopy (H5T_NATIVE_FLOAT);
+ typeIdMem = H5Tcopy (typeIdFile);
+ // Open the dataset.
+- setId = H5Dopen (fileId, "dataset", NULL);
++ setId = H5Dopen (fileId, "dataset", 0);
+ check (setId, "Failed to open dataset");
+ // Get the data space (for the shape).
+ dsId = H5Dget_space(setId);
+diff -Nur casacore-1.3.0.orig/mirlib/bug.c casacore-1.3.0/mirlib/bug.c
+--- casacore-1.3.0.orig/mirlib/bug.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/bug.c 2011-05-16 17:29:12.000000000 +0100
+@@ -12,6 +12,7 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
++void habort_c();
+
+ static char *errmsg_c();
+ void bug_c();
+diff -Nur casacore-1.3.0.orig/mirlib/dio.c casacore-1.3.0/mirlib/dio.c
+--- casacore-1.3.0.orig/mirlib/dio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/dio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -45,6 +45,7 @@
+ extern int errno;
+ #endif
+ #include <errno.h>
++void bug_c();
+
+ #define MAXPATH 128
+
+diff -Nur casacore-1.3.0.orig/mirlib/hio.c casacore-1.3.0/mirlib/hio.c
+--- casacore-1.3.0.orig/mirlib/hio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/hio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -36,7 +36,7 @@
+
+ #include <stdlib.h>
+ #include <string.h>
+-
++#include "sysdep.h"
+ #include "hio.h"
+
+ #define private static
+diff -Nur casacore-1.3.0.orig/mirlib/maskio.c casacore-1.3.0/mirlib/maskio.c
+--- casacore-1.3.0.orig/mirlib/maskio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/maskio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-
++void bug_c();
++void bugno_c();
+
+ private void mkfill();
+ void mkflush_c();
+diff -Nur casacore-1.3.0.orig/mirlib/scrio.c casacore-1.3.0/mirlib/scrio.c
+--- casacore-1.3.0.orig/mirlib/scrio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/scrio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -9,6 +9,8 @@
+ /************************************************************************/
+
+ #include "io.h"
++void bug_c();
++void bugno_c();
+
+ /* char *sprintf(); */
+ #include <stdio.h>
+@@ -100,7 +102,7 @@
+ /************************************************************************/
+ void scrwrite_c(handle,buffer,offset,length)
+ int handle,offset,length;
+-float *buffer;
++Const float *buffer;
+ /**scrwrite -- Write real data to the scratch file. */
+ /*:scratch-i/o */
+ /*+ FORTRAN call sequence:
+diff -Nur casacore-1.3.0.orig/mirlib/sysdep.h casacore-1.3.0/mirlib/sysdep.h
+--- casacore-1.3.0.orig/mirlib/sysdep.h 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/sysdep.h 2011-05-16 17:41:07.000000000 +0100
+@@ -131,5 +131,13 @@
+ # define unpackd_c(a,b,c) memcpy((char *)(b),(a),sizeof(double)*(c))
+ # define pack32_c(a,b,c) memcpy((b),(char *)(a),sizeof(int)*(c))
+ # define unpack32_c(a,b,c) memcpy((char *)(b),(a),sizeof(int)*(c))
++#else
++void pack32_c(int* in, char* out, int n);
++void unpack32_c(char* in, int* out,int n);
++void packr_c(float* in, char* out, int n);
++void unpackr_c(char* in, float* out, int n);
++void packd_c(double* in, char* out, int n);
++void unpackd_c(char* in, double* out, int n);
+ #endif
++
+ #endif
+diff -Nur casacore-1.3.0.orig/mirlib/xyio.c casacore-1.3.0/mirlib/xyio.c
+--- casacore-1.3.0.orig/mirlib/xyio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/xyio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -37,7 +37,7 @@
+ #define Strcpy (void)strcpy
+ void bug_c(),bugno_c();
+ void rdhdi_c(),wrhdi_c();
+-void mkclose_c(),mkwrite_c();
++void mkclose_c(),mkwrite_c(),mkflush_c();
+ char *mkopen_c();
+ int mkread_c();
+ static void xymkopen_c();
+diff -Nur casacore-1.3.0.orig/mirlib/xyzio.c casacore-1.3.0/mirlib/xyzio.c
+--- casacore-1.3.0.orig/mirlib/xyzio.c 2011-05-16 02:24:06.000000000 +0100
++++ casacore-1.3.0/mirlib/xyzio.c 2011-05-16 17:29:12.000000000 +0100
+@@ -55,6 +55,14 @@
+ #include <string.h>
+ #include <stdlib.h>
+ void bug_c();
++void bugno_c();
++char *mkopen_c(int tno, char* name, char* status);
++void mkclose_c(char *handle);
++int mkread_c(char* handle, int mode, int* flags, int offset, int n, int nsize);
++void mkwrite_c(char* handle, int mode, int* flags, int offset, int n, int nsize);
++void mkflush_c(char* handle);
++int limprint(char *string, int lower[], int upper[]);
++int ferr(char* string, char arg );
+ #define check(x) if(x)bugno_c('f',x)
+
+
diff --git a/sci-astronomy/casacore/files/1.3.0-libdir.patch b/sci-astronomy/casacore/files/1.3.0-libdir.patch
new file mode 100644
index 000000000000..e0243985aa28
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.3.0-libdir.patch
@@ -0,0 +1,196 @@
+diff -Nur casacore-1.3.0.orig/casa/CMakeLists.txt casacore-1.3.0/casa/CMakeLists.txt
+--- casacore-1.3.0.orig/casa/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/casa/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -209,8 +209,8 @@
+
+ install (
+ TARGETS casa_casa
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/components/CMakeLists.txt casacore-1.3.0/components/CMakeLists.txt
+--- casacore-1.3.0.orig/components/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/components/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -30,8 +30,8 @@
+ install (
+ TARGETS casa_components
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/coordinates/CMakeLists.txt casacore-1.3.0/coordinates/CMakeLists.txt
+--- casacore-1.3.0.orig/coordinates/CMakeLists.txt 2011-05-17 06:03:05.000000000 +0100
++++ casacore-1.3.0/coordinates/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -25,8 +25,8 @@
+
+ install (TARGETS casa_coordinates
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/derivedmscal/CMakeLists.txt casacore-1.3.0/derivedmscal/CMakeLists.txt
+--- casacore-1.3.0.orig/derivedmscal/CMakeLists.txt 2011-05-17 06:03:05.000000000 +0100
++++ casacore-1.3.0/derivedmscal/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -14,8 +14,8 @@
+
+ install (TARGETS casa_derivedmscal
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/fits/CMakeLists.txt casacore-1.3.0/fits/CMakeLists.txt
+--- casacore-1.3.0.orig/fits/CMakeLists.txt 2011-05-17 06:03:05.000000000 +0100
++++ casacore-1.3.0/fits/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -34,8 +34,8 @@
+
+ install (TARGETS casa_fits
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/images/CMakeLists.txt casacore-1.3.0/images/CMakeLists.txt
+--- casacore-1.3.0.orig/images/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/images/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -71,8 +71,8 @@
+ install (
+ TARGETS casa_images
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/lattices/CMakeLists.txt casacore-1.3.0/lattices/CMakeLists.txt
+--- casacore-1.3.0.orig/lattices/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/lattices/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -67,8 +67,8 @@
+
+ install (TARGETS casa_lattices
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/measures/CMakeLists.txt casacore-1.3.0/measures/CMakeLists.txt
+--- casacore-1.3.0.orig/measures/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/measures/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -69,8 +69,8 @@
+ install (
+ TARGETS casa_measures
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/mirlib/CMakeLists.txt casacore-1.3.0/mirlib/CMakeLists.txt
+--- casacore-1.3.0.orig/mirlib/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/mirlib/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -22,8 +22,8 @@
+ install (
+ TARGETS casa_mirlib
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/ms/CMakeLists.txt casacore-1.3.0/ms/CMakeLists.txt
+--- casacore-1.3.0.orig/ms/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/ms/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -148,8 +148,8 @@
+
+ install (TARGETS casa_ms
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/msfits/CMakeLists.txt casacore-1.3.0/msfits/CMakeLists.txt
+--- casacore-1.3.0.orig/msfits/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/msfits/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -29,8 +29,8 @@
+
+ install (
+ TARGETS casa_msfits
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/scimath/CMakeLists.txt casacore-1.3.0/scimath/CMakeLists.txt
+--- casacore-1.3.0.orig/scimath/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/scimath/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -38,8 +38,8 @@
+
+ install (TARGETS casa_scimath
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_WRITE GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/scimath_f/CMakeLists.txt casacore-1.3.0/scimath_f/CMakeLists.txt
+--- casacore-1.3.0.orig/scimath_f/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/scimath_f/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -34,8 +34,8 @@
+
+ install (
+ TARGETS casa_scimath_f
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
+diff -Nur casacore-1.3.0.orig/tables/CMakeLists.txt casacore-1.3.0/tables/CMakeLists.txt
+--- casacore-1.3.0.orig/tables/CMakeLists.txt 2011-05-17 06:03:06.000000000 +0100
++++ casacore-1.3.0/tables/CMakeLists.txt 2011-05-17 06:27:00.000000000 +0100
+@@ -181,8 +181,8 @@
+
+ install (TARGETS casa_tables
+ RUNTIME DESTINATION bin
+-LIBRARY DESTINATION lib
+-ARCHIVE DESTINATION lib
++LIBRARY DESTINATION lib${LIB_SUFFIX}
++ARCHIVE DESTINATION lib${LIB_SUFFIX}
+ LIBRARY PERMISSIONS OWNER_READ OWNER_WRITE OWNER_EXECUTE GROUP_READ GROUP_EXECUTE WORLD_READ WORLD_EXECUTE
+ )
+
diff --git a/sci-astronomy/casacore/files/1.5.0-gcc47.patch b/sci-astronomy/casacore/files/1.5.0-gcc47.patch
new file mode 100644
index 000000000000..30295d8d0701
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.5.0-gcc47.patch
@@ -0,0 +1,22 @@
+diff -Nur casacore-1.5.0.orig/casa/Arrays/IPosition.h casacore-1.5.0/casa/Arrays/IPosition.h
+--- casacore-1.5.0.orig/casa/Arrays/IPosition.h 2012-03-14 14:30:48.000000000 +0000
++++ casacore-1.5.0/casa/Arrays/IPosition.h 2012-06-05 22:07:39.000000000 +0100
+@@ -34,6 +34,7 @@
+ #include <casa/BasicSL/String.h>
+ #include <vector>
+ #include <cstddef> // for ptrdiff_t
++#include <unistd.h> // for ssize_t
+
+ namespace casa { //# NAMESPACE CASA - BEGIN
+
+diff -Nur casacore-1.5.0.orig/casa/System/Casarc.cc casacore-1.5.0/casa/System/Casarc.cc
+--- casacore-1.5.0.orig/casa/System/Casarc.cc 2011-10-18 08:39:05.000000000 +0100
++++ casacore-1.5.0/casa/System/Casarc.cc 2012-06-05 22:11:31.000000000 +0100
+@@ -34,6 +34,7 @@
+ #include <fcntl.h>
+ #include <sys/mman.h>
+ #include <cstdio>
++#include <unistd.h>
+
+ #define USE_FLOCK 0
+ #define CASARC_DEBUG 0
diff --git a/sci-astronomy/casacore/files/1.5.0-gcc48.patch b/sci-astronomy/casacore/files/1.5.0-gcc48.patch
new file mode 100644
index 000000000000..dfbe074e8735
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.5.0-gcc48.patch
@@ -0,0 +1,11 @@
+--- casa/aipsdef.h.orig 2014-03-06 22:05:25.000000000 +0000
++++ casa/aipsdef.h 2014-03-06 22:06:09.000000000 +0000
+@@ -91,7 +91,7 @@
+ #else
+ #define WHATEVER_SUN_TYPEDEF(X)
+ #define WHATEVER_TYPENAME typename
+-#if defined(AIPS_CRAY_PGI)
++#if defined(AIPS_CRAY_PGI) || defined(AIPS_GCC4)
+ #define WHATEVER_SUN_EXCEPTSPEC(X) throw(X)
+ #else
+ #define WHATEVER_SUN_EXCEPTSPEC(X)
diff --git a/sci-astronomy/casacore/files/1.5.0-sysdep.patch b/sci-astronomy/casacore/files/1.5.0-sysdep.patch
new file mode 100644
index 000000000000..35eef56daf08
--- /dev/null
+++ b/sci-astronomy/casacore/files/1.5.0-sysdep.patch
@@ -0,0 +1,17 @@
+--- casacore-1.5.0/mirlib/sysdep.h.orig 2012-06-05 05:35:29.000000000 +0100
++++ casacore-1.5.0/mirlib/sysdep.h 2012-06-05 05:37:07.000000000 +0100
+@@ -28,7 +28,8 @@
+ * removed 'trace' clutter from the old multiflow
+ * pjt 24jun01 PPC/powerpc is a BIGENDIAN (linux) machine
+ */
+-
++#ifndef MIRIAD_SYSDEP_H
++#define MIRIAD_SYSDEP_H
+ #ifndef Null
+ #define Null '\0'
+ #endif
+@@ -133,3 +134,4 @@
+ # define unpack32_c(a,b,c) memcpy((char *)(b),(a),sizeof(int)*(c))
+ #endif
+ #endif
++#endif /* MIRIAD_SYSDEP_H */
diff --git a/sci-astronomy/casacore/metadata.xml b/sci-astronomy/casacore/metadata.xml
new file mode 100644
index 000000000000..3f17c8233202
--- /dev/null
+++ b/sci-astronomy/casacore/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-astronomy</herd>
+<longdescription lang="en">
+ A set of libraries for the the Common Astronomy Software
+ Applications for radioastronomy. This project contains C++ libraries
+ which were the code of the discontinued AIPS++ package.
+</longdescription>
+<upstream>
+ <remote-id type="google-code">casacore</remote-id>
+</upstream>
+<use>
+ <flag name="data">Installs measures and data (pulls <pkg>sci-astronomy/casa-data</pkg>)</flag>
+</use>
+</pkgmetadata>