summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/amos
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/amos')
-rw-r--r--sci-biology/amos/Manifest1
-rw-r--r--sci-biology/amos/amos-3.1.0-r1.ebuild37
-rw-r--r--sci-biology/amos/amos-3.1.0.ebuild29
-rw-r--r--sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch15
-rw-r--r--sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch25
-rw-r--r--sci-biology/amos/metadata.xml8
6 files changed, 115 insertions, 0 deletions
diff --git a/sci-biology/amos/Manifest b/sci-biology/amos/Manifest
new file mode 100644
index 000000000000..27ad50ff28ed
--- /dev/null
+++ b/sci-biology/amos/Manifest
@@ -0,0 +1 @@
+DIST amos-3.1.0.tar.gz 2094268 SHA256 2d9f50e39186ad3dde3d3b28cc265e8d632430657f40fc3978ce34ab1b3db43b SHA512 7a416b9a0438b47425355383b709491a58f38c8d834df29e43c942170e710c6ea7e3bc8c509a58421b1340ad6eece9ea2da357ce5cd1d41ce08375676ee30491 WHIRLPOOL df9b547fcc0b7bf0149641fd8df9e4558f61bb6c17ded0facfeecde25d3a6307b40414e7cb8b2f021fa8cc192ee956672c26e0fc287981f4733a393739e80b61
diff --git a/sci-biology/amos/amos-3.1.0-r1.ebuild b/sci-biology/amos/amos-3.1.0-r1.ebuild
new file mode 100644
index 000000000000..a4c860bdbe7f
--- /dev/null
+++ b/sci-biology/amos/amos-3.1.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-r1
+
+DESCRIPTION="A Modular, Open-Source whole genome assembler"
+HOMEPAGE="http://amos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="qt4"
+
+DEPEND="qt4? ( dev-qt/qtcore:4 )"
+RDEPEND="${DEPEND}
+ dev-perl/DBI
+ dev-perl/Statistics-Descriptive
+ sci-biology/mummer"
+
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch \
+ "${FILESDIR}"/${P}-goBambus2.py-indent-and-cleanup.patch
+}
+
+src_install() {
+ default
+ python_replicate_script "${ED}"/usr/bin/goBambus2
+}
diff --git a/sci-biology/amos/amos-3.1.0.ebuild b/sci-biology/amos/amos-3.1.0.ebuild
new file mode 100644
index 000000000000..945ec9f41b4c
--- /dev/null
+++ b/sci-biology/amos/amos-3.1.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="A Modular, Open-Source whole genome assembler"
+HOMEPAGE="http://amos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="qt4"
+
+DEPEND="qt4? ( dev-qt/qtcore:4 )"
+RDEPEND="${DEPEND}
+ dev-perl/DBI
+ dev-perl/Statistics-Descriptive
+ sci-biology/mummer"
+
+MAKEOPTS+=" -j1"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+}
diff --git a/sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch b/sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch
new file mode 100644
index 000000000000..de2a41184c52
--- /dev/null
+++ b/sci-biology/amos/files/amos-3.1.0-gcc-4.7.patch
@@ -0,0 +1,15 @@
+ src/Align/find-tandem.cc | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/src/Align/find-tandem.cc b/src/Align/find-tandem.cc
+index ddf1cab..a29e21e 100644
+--- a/src/Align/find-tandem.cc
++++ b/src/Align/find-tandem.cc
+@@ -7,6 +7,7 @@
+ #include <vector>
+ #include <ctime>
+ #include <sys/time.h>
++#include <unistd.h>
+ using namespace std;
+
+ const int OFFSET_TABLE_SIZE = 100;
diff --git a/sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch b/sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch
new file mode 100644
index 000000000000..97a8f59d0208
--- /dev/null
+++ b/sci-biology/amos/files/amos-3.1.0-goBambus2.py-indent-and-cleanup.patch
@@ -0,0 +1,25 @@
+--- amos-3.1.0/src/Pipeline/goBambus2.py.orig 2013-09-11 01:05:29.850090457 +0200
++++ amos-3.1.0/src/Pipeline/goBambus2.py 2013-09-11 01:07:03.250090701 +0200
+@@ -1,7 +1,7 @@
+ #pipeline script for assembly + Bambus 2
+ #contributed by Todd J Treangen
+
+-import string, sys, os, subprocess#, spincursor
++import sys, os, subprocess#, spincursor
+
+ RED = "\033[0;31m"
+ GREEN = "\033[0;32m"
+@@ -360,7 +360,7 @@
+ print "\t\t%s...failed%s"%(RED,NONE)
+ sys.exit(1)
+
+- p = subprocess.Popen(AMOSDIR+"OutputResults -b %s -prefix %s %s"%(amosbank, prefix+".scaff.linear"), shell=True, stdin=subprocess.PIPE, stdout=vtext, stderr=logfile)
++ p = subprocess.Popen(AMOSDIR+"OutputResults -b %s -prefix %s %s"%(amosbank, prefix+".scaff.linear"), shell=True, stdin=subprocess.PIPE, stdout=vtext, stderr=logfile)
+
+ if xopt_dict["verbose"] == 1:
+ print "10) running OutputResults"
+@@ -388,4 +388,3 @@
+ else:
+ print "\t\t%s...failed%s"%(RED,NONE)
+ sys.exit(1)
+-)
diff --git a/sci-biology/amos/metadata.xml b/sci-biology/amos/metadata.xml
new file mode 100644
index 000000000000..a73ee9189a98
--- /dev/null
+++ b/sci-biology/amos/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <upstream>
+ <remote-id type="sourceforge">amos</remote-id>
+ </upstream>
+</pkgmetadata>