summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/bedtools
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/bedtools')
-rw-r--r--sci-biology/bedtools/Manifest2
-rw-r--r--sci-biology/bedtools/bedtools-2.16.2.ebuild33
-rw-r--r--sci-biology/bedtools/bedtools-2.20.1.ebuild33
-rw-r--r--sci-biology/bedtools/metadata.xml17
4 files changed, 85 insertions, 0 deletions
diff --git a/sci-biology/bedtools/Manifest b/sci-biology/bedtools/Manifest
new file mode 100644
index 000000000000..e8ecdb88e2ea
--- /dev/null
+++ b/sci-biology/bedtools/Manifest
@@ -0,0 +1,2 @@
+DIST BEDTools.v2.16.2.tar.gz 978293 SHA256 f5f5c864eb3f465ac7fd5fa651e2e4dbc0cd8d9198367148c52f3be3f46c2772
+DIST bedtools-2.20.1.tar.gz 4213348 SHA256 b5401810f8b12b683575f0119521dda64ff2f0a59faa308357405c4ae4e328d3 SHA512 b5c27601365a2126c58492791a52a262c874073cc1626bb1e38545ccf6e3594d12d2d2116304374b3446a588611cfd410c8ff166170823071b33c444c9fd36a7 WHIRLPOOL b768a7e064444d5d0434aea5251e132d68fbeb580783034c8e327666eaace0307febc80e9d6d3eea2f0f648263ce0ac836fac7a676586a6e6a8ec4daf39e6a84
diff --git a/sci-biology/bedtools/bedtools-2.16.2.ebuild b/sci-biology/bedtools/bedtools-2.16.2.ebuild
new file mode 100644
index 000000000000..7de4f347c710
--- /dev/null
+++ b/sci-biology/bedtools/bedtools-2.16.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools for manipulation and analysis of BED, GFF/GTF, VCF, and SAM/BAM file formats"
+HOMEPAGE="http://code.google.com/p/bedtools/"
+SRC_URI="http://bedtools.googlecode.com/files/BEDTools.v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/BEDTools-Version-${PV}"
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ sed -i \
+ -e '/export CXXFLAGS/ d' \
+ -e '/export CXX/ d' \
+ Makefile || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README* RELEASE_HISTORY
+ insinto /usr/share/${PN}
+ doins -r genomes
+}
diff --git a/sci-biology/bedtools/bedtools-2.20.1.ebuild b/sci-biology/bedtools/bedtools-2.20.1.ebuild
new file mode 100644
index 000000000000..cdba954f6d27
--- /dev/null
+++ b/sci-biology/bedtools/bedtools-2.20.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic
+
+DESCRIPTION="Tools for manipulation and analysis of BED, GFF/GTF, VCF, and SAM/BAM file formats"
+HOMEPAGE="http://code.google.com/p/bedtools/"
+SRC_URI="https://github.com/arq5x/bedtools2/releases/download/v${PV}/bedtools-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+S="${WORKDIR}/bedtools2-${PV}"
+
+src_prepare() {
+ filter-ldflags -Wl,--as-needed
+ sed -i \
+ -e '/export CXXFLAGS/ d' \
+ -e '/export CXX/ d' \
+ Makefile || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc README* RELEASE_HISTORY
+ insinto /usr/share/${PN}
+ doins -r genomes
+}
diff --git a/sci-biology/bedtools/metadata.xml b/sci-biology/bedtools/metadata.xml
new file mode 100644
index 000000000000..6edffa4a6dc3
--- /dev/null
+++ b/sci-biology/bedtools/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>mmokrejs@gmail.com</email>
+ <name>Martin Mokrejs</name>
+ </maintainer>
+ <longdescription>
+ BEDTools: a flexible suite of utilities for comparing genomic features.
+ </longdescription>
+ <upstream>
+ <remote-id type="google-code">bedtools</remote-id>
+ <remote-id type="github">arq5x/bedtools2</remote-id>
+ </upstream>
+</pkgmetadata>