summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/mcl
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/mcl')
-rw-r--r--sci-biology/mcl/Manifest2
-rw-r--r--sci-biology/mcl/mcl-08.312.ebuild37
-rw-r--r--sci-biology/mcl/mcl-12.135.ebuild37
-rw-r--r--sci-biology/mcl/metadata.xml10
4 files changed, 86 insertions, 0 deletions
diff --git a/sci-biology/mcl/Manifest b/sci-biology/mcl/Manifest
new file mode 100644
index 000000000000..88b4aef28107
--- /dev/null
+++ b/sci-biology/mcl/Manifest
@@ -0,0 +1,2 @@
+DIST mcl-08-312.tar.gz 2749006 SHA256 0061da0661e99f783d97e6ae10149fe5ce11fa332b24cc8a4a491a072867bb6e SHA512 9f89f81af398710ebb9135c93653d892fc9daef360d70f3b890a3133d8a17dddffe568b110d3370602cead895562bc0dc5a71020834b3b3e9b6d2abf4bf64b0b WHIRLPOOL 6d00665c545edb55605fb0438cc79a412150e68b9c63ffc51c93f8f8c33b9bcd6e4e5e435b3be89a64407a0a8f6f1b8e77567f653e45c08f1675dbf2b9e0b59e
+DIST mcl-12-135.tar.gz 2970824 SHA256 3f5e0e7ad1074c7c4ef0139aa3318f92971fede7292dc3571eca2fd1da20a283 SHA512 97234e88f3430f223e1f303577b2b8853f40de6b204de415466719f691f529a795b17bf2fd48d4cc73d05900c87a10ba9afabbe54bce9367ee59215e7db0a8f5 WHIRLPOOL 1505643a460ba5bd6b834d070278a108fba57c9dc2a90a72a8e0726bd54a1b8fe3e4792a63397d58db62b036d22c325db2dd76f696a8692473987395c556a279
diff --git a/sci-biology/mcl/mcl-08.312.ebuild b/sci-biology/mcl/mcl-08.312.ebuild
new file mode 100644
index 000000000000..9a2aafb0c037
--- /dev/null
+++ b/sci-biology/mcl/mcl-08.312.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+MY_P="${PN}-${PV/./-}"
+
+DESCRIPTION="A Markov Cluster Algorithm implementation"
+HOMEPAGE="http://micans.org/mcl/"
+SRC_URI="http://micans.org/mcl/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blast"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ find \
+ -name Makefile.am \
+ -exec sed \
+ -e '/docdir/d' \
+ -e '/exampledir/s:doc::g' \
+ -i '{}' + || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( $(use_enable blast) )
+ autotools-utils_src_configure
+}
diff --git a/sci-biology/mcl/mcl-12.135.ebuild b/sci-biology/mcl/mcl-12.135.ebuild
new file mode 100644
index 000000000000..9a2aafb0c037
--- /dev/null
+++ b/sci-biology/mcl/mcl-12.135.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+MY_P="${PN}-${PV/./-}"
+
+DESCRIPTION="A Markov Cluster Algorithm implementation"
+HOMEPAGE="http://micans.org/mcl/"
+SRC_URI="http://micans.org/mcl/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blast"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ find \
+ -name Makefile.am \
+ -exec sed \
+ -e '/docdir/d' \
+ -e '/exampledir/s:doc::g' \
+ -i '{}' + || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( $(use_enable blast) )
+ autotools-utils_src_configure
+}
diff --git a/sci-biology/mcl/metadata.xml b/sci-biology/mcl/metadata.xml
new file mode 100644
index 000000000000..aa6527e1e839
--- /dev/null
+++ b/sci-biology/mcl/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <use>
+ <flag name="blast">
+ add support for NCBI BLAST data
+ </flag>
+ </use>
+</pkgmetadata>