summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/treeviewx
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/treeviewx')
-rw-r--r--sci-biology/treeviewx/Manifest1
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch77
-rw-r--r--sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch14
-rw-r--r--sci-biology/treeviewx/files/treeviewx-gcc-3.4.patch73
-rw-r--r--sci-biology/treeviewx/files/treeviewx-wxt.patch50
-rw-r--r--sci-biology/treeviewx/metadata.xml11
-rw-r--r--sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild32
7 files changed, 258 insertions, 0 deletions
diff --git a/sci-biology/treeviewx/Manifest b/sci-biology/treeviewx/Manifest
new file mode 100644
index 000000000000..024410ff1615
--- /dev/null
+++ b/sci-biology/treeviewx/Manifest
@@ -0,0 +1 @@
+DIST tv-0.5.1.tar.gz 426745 RMD160 27c92a0f43c59c8988fe2d1410adb6de429e94c9 SHA1 0b0887477ca0d9ded6d0ee8bef014b6208e1fc14 SHA256 118bdbefb3f21636b1ba9da92e1b2029cb4d7d9944f4d02d2deace4ebb14c2d1
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch
new file mode 100644
index 000000000000..33bd3b1741f6
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-gcc4.3.patch
@@ -0,0 +1,77 @@
+diff -Naur tv-0.5.1/TreeLib/Parse.cpp tv-0.5.1.new/TreeLib/Parse.cpp
+--- tv-0.5.1/TreeLib/Parse.cpp 2002-02-23 07:22:32.000000000 -0500
++++ tv-0.5.1.new/TreeLib/Parse.cpp 2008-06-17 06:08:24.000000000 -0400
+@@ -24,6 +24,11 @@
+ #include <ctype.h>
+ #include "Parse.h"
+
++
++
++
++#include <cstring>
++
+ // Return the next token in the string
+ tokentype Parser::NextToken ()
+ {
+diff -Naur tv-0.5.1/TreeLib/TreeLib.cpp tv-0.5.1.new/TreeLib/TreeLib.cpp
+--- tv-0.5.1/TreeLib/TreeLib.cpp 2004-05-13 08:22:11.000000000 -0400
++++ tv-0.5.1.new/TreeLib/TreeLib.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -24,6 +24,8 @@
+ #include "TreeLib.h"
+ #include "Parse.h"
+
++
++#include <cstdlib>
+ #include <vector>
+
+
+diff -Naur tv-0.5.1/TreeLib/treereader.cpp tv-0.5.1.new/TreeLib/treereader.cpp
+--- tv-0.5.1/TreeLib/treereader.cpp 2003-09-10 08:58:16.000000000 -0400
++++ tv-0.5.1.new/TreeLib/treereader.cpp 2008-06-17 06:07:15.000000000 -0400
+@@ -28,6 +28,9 @@
+ #include <stdlib.h>
+ #endif
+
++#include <cstring>
++#include <cstdlib>
++
+ //------------------------------------------------------------------------------
+ TreeReader::TreeReader (Tokeniser &p) : parser (p)
+ {
+diff -Naur tv-0.5.1/ncl-2.0/src/charactersblock.cpp tv-0.5.1.new/ncl-2.0/src/charactersblock.cpp
+--- tv-0.5.1/ncl-2.0/src/charactersblock.cpp 2002-12-10 06:35:49.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/charactersblock.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nexus.cpp tv-0.5.1.new/ncl-2.0/src/nexus.cpp
+--- tv-0.5.1/ncl-2.0/src/nexus.cpp 2002-12-10 06:35:50.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/nexus.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nexustoken.cpp tv-0.5.1.new/ncl-2.0/src/nexustoken.cpp
+--- tv-0.5.1/ncl-2.0/src/nexustoken.cpp 2005-04-29 10:28:17.000000000 -0400
++++ tv-0.5.1.new/ncl-2.0/src/nexustoken.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,5 @@
++
++#include <cstring>
+ #include "nexusdefs.h"
+ #include "xnexus.h"
+ #include "nexustoken.h"
+diff -Naur tv-0.5.1/ncl-2.0/src/nxsstring.cpp tv-0.5.1.new/ncl-2.0/src/nxsstring.cpp
+--- tv-0.5.1/ncl-2.0/src/nxsstring.cpp 2001-02-02 07:55:40.000000000 -0500
++++ tv-0.5.1.new/ncl-2.0/src/nxsstring.cpp 2008-06-17 05:58:17.000000000 -0400
+@@ -1,3 +1,6 @@
++
++#include <cstring>
++
+ #ifdef __BORLANDC__
+ // Undefine __MINMAX_DEFINED so that min and max are correctly defined
+ #ifdef __MINMAX_DEFINED
diff --git a/sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch b/sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch
new file mode 100644
index 000000000000..e3ba6b2fff50
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-0.5.1-wx28.patch
@@ -0,0 +1,14 @@
+Fix build w/ wxGTK-2.8
+http://bugs.debian.org/567238
+
+--- a/tview.cpp
++++ b/tview.cpp
+@@ -994,7 +994,7 @@ END_EVENT_TABLE()
+ MyCanvas::MyCanvas(wxView *v, wxMDIChildFrame *frame, const wxPoint& pos, const wxSize& size, long style):
+ wxScrolledWindow(frame, -1, pos, size, style)
+ {
+- SetBackgroundColour(wxColour("WHITE"));
++ SetBackgroundColour(wxColour(wxT("WHITE")));
+ view = v;
+ magnification = 1;
+ }
diff --git a/sci-biology/treeviewx/files/treeviewx-gcc-3.4.patch b/sci-biology/treeviewx/files/treeviewx-gcc-3.4.patch
new file mode 100644
index 000000000000..9d64fabb6a9b
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-gcc-3.4.patch
@@ -0,0 +1,73 @@
+--- TreeLib/nodeiterator.h.old 2002-02-24 15:37:17.000000000 -0500
++++ TreeLib/nodeiterator.h 2005-02-27 14:23:30.971981368 -0500
+@@ -128,34 +128,34 @@
+
+ template <class N> N *PreorderIterator<N>::begin ()
+ {
+- cur = root;
+- return cur;
++ this->cur = this->root;
++ return this->cur;
+ }
+
+ template <class N> N *PreorderIterator<N>::next ()
+ {
+- if (cur->GetChild())
++ if (this->cur->GetChild())
+ {
+- stk.push (cur);
+- N *p = (N *)(cur->GetChild());
+- cur = p;
++ this->stk.push (this->cur);
++ N *p = (N *)(this->cur->GetChild());
++ this->cur = p;
+ }
+ else
+ {
+- while (!stk.empty() && (cur->GetSibling() == NULL))
++ while (!this->stk.empty() && (this->cur->GetSibling() == NULL))
+ {
+- cur = stk.top();
+- stk.pop();
++ this->cur = this->stk.top();
++ this->stk.pop();
+ }
+- if (stk.empty())
+- cur = NULL;
++ if (this->stk.empty())
++ this->cur = NULL;
+ else
+ {
+- N *p = (N *)(cur->GetSibling());
+- cur = p;
++ N *p = (N *)(this->cur->GetSibling());
++ this->cur = p;
+ }
+ }
+- return cur;
++ return this->cur;
+ }
+
+
+--- TreeLib/profile.h.old 2002-12-10 06:37:57.000000000 -0500
++++ TreeLib/profile.h 2005-02-27 14:27:51.205419872 -0500
+@@ -77,7 +77,7 @@
+ #include <ctime>
+ #endif
+
+-
++using namespace std;
+
+ /**
+ *@typedef std::map <std::string, int, std::less<std::string> > LabelMap;
+--- TreeLib/treedrawer.cpp.old 2003-08-22 06:47:28.000000000 -0400
++++ TreeLib/treedrawer.cpp 2005-02-27 14:26:19.279394752 -0500
+@@ -406,7 +406,7 @@
+ if (q->IsLeaf())
+ {
+ double d = q->GetPathLength() - mMaxPathLength;
+- mUltrametric = (std::fabs(d) <= 0.0001);
++ mUltrametric = (fabs(d) <= 0.0001);
+ // cout << mMaxPathLength << ":" << q->GetPathLength() << " " << d << endl;
+ }
+ q = u.next();
diff --git a/sci-biology/treeviewx/files/treeviewx-wxt.patch b/sci-biology/treeviewx/files/treeviewx-wxt.patch
new file mode 100644
index 000000000000..b1c03bbb39f9
--- /dev/null
+++ b/sci-biology/treeviewx/files/treeviewx-wxt.patch
@@ -0,0 +1,50 @@
+--- tv.cpp~ 2005-10-01 16:47:35.000000000 -0400
++++ tv.cpp 2005-10-01 16:52:30.000000000 -0400
+@@ -312,11 +312,15 @@
+ {
+ #ifdef __WXMSW__
+ file_menu->AppendSeparator();
+- file_menu->Append(SAVEAS_PICTURE_CMD, "Save As Picture..."), wxT("Save picture of tree to metafile");
++ file_menu->Append(SAVEAS_PICTURE_CMD,
++ wxT("Save As Picture...")),
++ wxT("Save picture of tree to metafile");
+ #else
+ #ifdef USE_SVG
+ file_menu->AppendSeparator();
+- file_menu->Append(SAVEAS_PICTURE_CMD, "Save As Picture..."), wxT("Save picture of tree to SVG file");
++ file_menu->Append(SAVEAS_PICTURE_CMD,
++ wxT("Save As Picture...")),
++ wxT("Save picture of tree to SVG file");
+ #endif
+ #endif
+ file_menu->AppendSeparator();
+--- tview.cpp~ 2005-10-01 16:47:45.000000000 -0400
++++ tview.cpp 2005-10-01 16:50:42.000000000 -0400
+@@ -184,10 +184,10 @@
+ wxString pictureFileName = GetFrame()->GetTitle();
+ pictureFileName += wxT(".emf");
+ wxFrame *f = GetMainFrame();
+- wxFileDialog dialog((wxWindow *)f, "Save Picture as", "", pictureFileName,
+- "Enhanced metafile (*.emf)|*.emf",
+- wxSAVE|wxOVERWRITE_PROMPT);
+-
++ wxFileDialog dialog((wxWindow *)f, wxT("Save Picture as"), wxT(""),
++ pictureFileName, wxT("Enhanced metafile (*.emf)|*.emf"),
++ wxSAVE|wxOVERWRITE_PROMPT);
++
+ if (dialog.ShowModal() == wxID_OK)
+ {
+ wxMetafileDC pictureDC (dialog.GetPath(), 600, 650) ;
+@@ -204,9 +204,9 @@
+ #else
+ wxFrame *f = GetMainFrame();
+ #endif
+- wxFileDialog dialog((wxWindow *)f, "Save Picture as", "", pictureFileName,
+- "SVG vector picture files (*.svg)|*.svg",
+- wxSAVE|wxOVERWRITE_PROMPT);
++ wxFileDialog dialog((wxWindow *)f, wxT("Save Picture as"), wxT(""),
++ pictureFileName, wxT("SVG vector picture files (*.svg)|*.svg"),
++ wxSAVE|wxOVERWRITE_PROMPT);
+
+ if (dialog.ShowModal() == wxID_OK)
+ {
diff --git a/sci-biology/treeviewx/metadata.xml b/sci-biology/treeviewx/metadata.xml
new file mode 100644
index 000000000000..e351ff6c1fa9
--- /dev/null
+++ b/sci-biology/treeviewx/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+ <longdescription>
+ TreeView X is a program for displaying phylogenetic trees on Linux and
+ UNIX platforms. It can read and display NEXUS and Newick format tree
+ files (such as those output by PAUP*, ClustalX, TREE-PUZZLE, and other
+ programs).
+ </longdescription>
+</pkgmetadata>
diff --git a/sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild b/sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild
new file mode 100644
index 000000000000..4ff83ca1f34c
--- /dev/null
+++ b/sci-biology/treeviewx/treeviewx-0.5.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+WX_GTK_VER="2.8"
+inherit eutils wxwidgets
+
+DESCRIPTION="A phylogenetic tree viewer"
+HOMEPAGE="http://darwin.zoology.gla.ac.uk/~rpage/treeviewx/"
+SRC_URI="http://darwin.zoology.gla.ac.uk/~rpage/${PN}/download/0.5/tv-${PV}.tar.gz"
+LICENSE="GPL-2"
+
+KEYWORDS="amd64 x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="x11-libs/wxGTK:2.8[X]"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/tv-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-wxt.patch
+ epatch "${FILESDIR}"/${P}-gcc4.3.patch
+ epatch "${FILESDIR}"/${P}-wx28.patch
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "make install failed"
+}