summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-biology/trf
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-biology/trf')
-rw-r--r--sci-biology/trf/Manifest1
-rw-r--r--sci-biology/trf/metadata.xml5
-rw-r--r--sci-biology/trf/trf-4.04.ebuild37
3 files changed, 43 insertions, 0 deletions
diff --git a/sci-biology/trf/Manifest b/sci-biology/trf/Manifest
new file mode 100644
index 000000000000..621d293009ea
--- /dev/null
+++ b/sci-biology/trf/Manifest
@@ -0,0 +1 @@
+DIST trf404.linux 89853 SHA256 1b9e3917088684afc2287a078810858f7a8e50d90e7bad2d814d40dc24188058 SHA512 c1aa05e394d47ea153df3082258f9a089aa59976963e9ac5d5816ef9dcd95c47e2e46861d1b2aae52b5ea9950a823a2449dd0d8426b04f2b738f5552c319393e WHIRLPOOL 7817c7eeb2c452ece7f71c2b7548fd9cda8c6796d5e77b2de46911f50bb271290b1a9601545efc50b94574c718e0e5e65d4a4e27f5cfd66c3590e9d5b7c5856c
diff --git a/sci-biology/trf/metadata.xml b/sci-biology/trf/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/trf/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/trf/trf-4.04.ebuild b/sci-biology/trf/trf-4.04.ebuild
new file mode 100644
index 000000000000..81d540251f07
--- /dev/null
+++ b/sci-biology/trf/trf-4.04.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+MY_P="${PN}404"
+
+DESCRIPTION="Tandem Repeats Finder"
+HOMEPAGE="http://tandem.bu.edu/trf/trf.html"
+SRC_URI="http://tandem.bu.edu/trf/downloads/${MY_P}.linux"
+
+LICENSE="trf" # http://tandem.bu.edu/trf/trf.license.html
+SLOT="0"
+KEYWORDS="amd64 x86"
+RESTRICT="mirror bindist"
+
+S="${WORKDIR}"
+
+QA_PREBUILT="opt/${PN}/.*"
+
+src_unpack() {
+ cp "${DISTDIR}/${MY_P}.linux" "${S}/${MY_P}.linux.exe" || die
+}
+
+src_install() {
+ exeinto /opt/${PN}
+ doexe trf404.linux.exe
+ dosym /opt/${PN}/${MY_P}.linux.exe /opt/bin/trf
+ # GTK version (http://tandem.bu.edu/trf/downloads/trf400.linuxgtk.exe) has broken linking
+ #if use gtk; then
+ # doexe trf400.linuxgtk.exe || die
+ # make_desktop_entry /opt/${PN}/trf400.linuxgtk.exe "Tandem Repeats Finder" || die
+ #fi
+}