summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-03-03 17:08:26 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-03-03 18:44:08 +0100
commit86acc7ebf1e4ce5be9437507bed6e607a3bcfe6c (patch)
tree70bc82c9efa3c7f9fe994222df9f97bb9bd8c202 /sci-biology
parentapp-text/ps2pkm: stable 1.8_p20170524 for ppc, bug #624440 (diff)
downloadgentoo-86acc7ebf1e4ce5be9437507bed6e607a3bcfe6c.tar.gz
gentoo-86acc7ebf1e4ce5be9437507bed6e607a3bcfe6c.tar.bz2
gentoo-86acc7ebf1e4ce5be9437507bed6e607a3bcfe6c.zip
sci-biology/amos: Drop USE=qt4
Bug: https://bugs.gentoo.org/645140 Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'sci-biology')
-rw-r--r--sci-biology/amos/amos-3.1.0-r4.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-biology/amos/amos-3.1.0-r4.ebuild b/sci-biology/amos/amos-3.1.0-r4.ebuild
new file mode 100644
index 000000000000..0dbcaffd81da
--- /dev/null
+++ b/sci-biology/amos/amos-3.1.0-r4.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools flag-o-matic python-single-r1
+
+DESCRIPTION="A Modular, Open-Source whole genome assembler"
+HOMEPAGE="http://amos.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ https://dev.gentoo.org/~soap/distfiles/${PN}-3.1.0-fix-c++14.patch.bz2"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ ${PYTHON_DEPS}
+ dev-perl/DBI
+ dev-perl/Statistics-Descriptive
+ sci-biology/mummer"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ "${FILESDIR}"/${P}-goBambus2.py-indent-and-cleanup.patch
+ "${WORKDIR}"/${P}-fix-c++14.patch
+ "${FILESDIR}"/${P}-qa-Wformat.patch
+ "${FILESDIR}"/${P}-fix-build-system.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+
+ # prevent GCC 6 log pollution due
+ # to hash_map deprecation in C++11
+ append-cxxflags -Wno-cpp
+}
+
+src_configure() {
+ econf --with-qmake-qt4=no
+}
+
+src_install() {
+ default
+ python_fix_shebang "${ED%/}"/usr/bin/goBambus2
+}