summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-chemistry/aqua
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-chemistry/aqua')
-rw-r--r--sci-chemistry/aqua/Manifest2
-rw-r--r--sci-chemistry/aqua/aqua-3.2-r2.ebuild93
-rw-r--r--sci-chemistry/aqua/files/3.2-flags.patch84
-rw-r--r--sci-chemistry/aqua/metadata.xml8
4 files changed, 187 insertions, 0 deletions
diff --git a/sci-chemistry/aqua/Manifest b/sci-chemistry/aqua/Manifest
new file mode 100644
index 000000000000..7f6594d70fe4
--- /dev/null
+++ b/sci-chemistry/aqua/Manifest
@@ -0,0 +1,2 @@
+DIST aqua-3.2-nmr_manual.tar.gz 632031 SHA256 89bbc2501831e547fec2fe755bbc0081f672e5e2c7adb83618699e6825f73996
+DIST aqua3.2.tar.gz 688408 SHA256 895291b1771f4db5b4a010ce797400a8c4d84095bf34d660dd3405223419242f
diff --git a/sci-chemistry/aqua/aqua-3.2-r2.ebuild b/sci-chemistry/aqua/aqua-3.2-r2.ebuild
new file mode 100644
index 000000000000..74fccddc5dd2
--- /dev/null
+++ b/sci-chemistry/aqua/aqua-3.2-r2.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils fortran-2 toolchain-funcs
+
+DESCRIPTION="Program suite in this distribution calculates restraint violations"
+HOMEPAGE="http://www.biochem.ucl.ac.uk/~roman/procheck/procheck.html"
+SRC_URI="
+ ${PN}${PV}.tar.gz
+ doc? ( ${P}-nmr_manual.tar.gz )"
+
+SLOT="0"
+LICENSE="procheck"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="sci-chemistry/procheck"
+DEPEND=""
+
+RESTRICT="fetch"
+
+S="${WORKDIR}"/${PN}${PV}
+
+pkg_nofetch() {
+ elog "Please visit http://www.ebi.ac.uk/thornton-srv/software/PROCHECK/download.html"
+ elog "And follow the instruction for downloading ${PN}${PV}.tar.gz -> ${DISTDIR}/${PN}${PV}.tar.gz."
+ if use doc; then
+ elog "nmr_manual.tar.gz -> ${DISTDIR}/${P}-nmr_manual.tar.gz"
+ fi
+}
+
+src_prepare() {
+ sed \
+ -e 's:nawk:gawk:g' \
+ -e "s:/bin/gawk:${EPREFIX}/usr/bin/gawk:g" \
+ -e "s:/usr/local/bin/perl:${EPREFIX}/usr/bin/perl:g" \
+ -i $(find . -type f) || die
+ epatch "${FILESDIR}"/${PV}-flags.patch
+}
+
+src_compile() {
+ pushd src > /dev/null
+ emake \
+ MYROOT="${WORKDIR}" \
+ CC="$(tc-getCC)" \
+ FC="$(tc-getFC)" \
+ CFLAGS="${CFLAGS} -I../sub/lib" \
+ FFLAGS="${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}" \
+ exth
+ emake \
+ MYROOT="${WORKDIR}" \
+ CC="$(tc-getCC)" \
+ FC="$(tc-getFC)" \
+ CFLAGS="${CFLAGS} -I../sub/lib" \
+ FFLAGS="${FFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+ popd
+}
+
+src_install() {
+ rm -f scripts/conv* || die
+ dobin bin/* scripts/*
+ dosym AquaWhat /usr/bin/qwhat
+ dosym AquaHow /usr/bin/qhow
+ dosym AquaPseudo /usr/bin/qpseudo
+ dosym AquaDist /usr/bin/qdist
+ dosym AquaCalc /usr/bin/qcalc
+ dosym AquaAssign /usr/bin/qassign
+ dosym AquaRedun /usr/bin/qredun
+ dosym AquaCompl /usr/bin/qcompl
+
+ dodoc HISTORY HOW_TO_USE NEW README doc/*
+ dohtml html/*
+
+ insinto /usr/share/${PN}
+ doins data/*
+ if use examples; then
+ doins -r exmpls
+ fi
+
+ if use doc; then
+ dohtml -r manual
+ fi
+
+ cat >> "${T}"/34aqua <<- EOF
+ AQUADATADIR="${EPREFIX}/usr/share/${PN}"
+ EOF
+ doenvd "${T}"/34aqua
+}
diff --git a/sci-chemistry/aqua/files/3.2-flags.patch b/sci-chemistry/aqua/files/3.2-flags.patch
new file mode 100644
index 000000000000..cd12fbb9a324
--- /dev/null
+++ b/sci-chemistry/aqua/files/3.2-flags.patch
@@ -0,0 +1,84 @@
+diff --git a/src/makefile b/src/makefile
+index 3113471..dd7a320 100644
+--- a/src/makefile
++++ b/src/makefile
+@@ -176,47 +176,46 @@ nrutil.h:
+ # Executable files
+
+ $(BIN)/AquaWhat: AquaWhat.o $(OBJECTS) $(R_OBJECTS) $(RNG_OBJECTS)
+- $(CC) -o $(BIN)/AquaWhat AquaWhat.o $(OBJECTS) $(R_OBJECTS) $(RNG_OBJECTS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaWhat AquaWhat.o $(OBJECTS) $(R_OBJECTS) $(RNG_OBJECTS)
+
+ $(BIN)/AquaHow: AquaHow.o $(OBJECTS) $(R_OBJECTS) AquaFuncts_dr.o $(RNG_OBJECTS)
+- $(CC) -o $(BIN)/AquaHow AquaHow.o $(OBJECTS) $(R_OBJECTS) AquaFuncts_dr.o $(RNG_OBJECTS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaHow AquaHow.o $(OBJECTS) $(R_OBJECTS) AquaFuncts_dr.o $(RNG_OBJECTS)
+
+ $(BIN)/AquaPseudo: AquaPseudo.o $(OBJECTS) $(R_OBJECTS)
+- $(CC) -o $(BIN)/AquaPseudo AquaPseudo.o $(OBJECTS) $(R_OBJECTS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaPseudo AquaPseudo.o $(OBJECTS) $(R_OBJECTS)
+
+ $(BIN)/AquaDist: AquaDist.o $(OBJECTS)
+- $(CC) -o $(BIN)/AquaDist AquaDist.o $(OBJECTS) $(LDFLAGS) -lm
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaDist AquaDist.o $(OBJECTS) -lm
+
+ $(BIN)/AquaCalc: AquaCalc.o $(OBJECTS) $(RNG_OBJECTS)
+- $(CC) -o $(BIN)/AquaCalc AquaCalc.o $(OBJECTS) $(RNG_OBJECTS) $(LDFLAGS) -lm
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaCalc AquaCalc.o $(OBJECTS) $(RNG_OBJECTS) -lm
+
+ $(BIN)/AquaAssign: AquaAssign.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS)
+- $(CC) -o $(BIN)/AquaAssign AquaAssign.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaAssign AquaAssign.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS)
+
+ $(BIN)/AquaCompl: AquaCompl.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS)
+- $(CC) -o $(BIN)/AquaCompl AquaCompl.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS) $(LDFLAGS) -lm
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaCompl AquaCompl.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS) -lm
+
+ $(BIN)/AquaRedun: AquaRedun.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS)
+- $(CC) -o $(BIN)/AquaRedun AquaRedun.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaRedun AquaRedun.o AquaCommon.o $(OBJECTS) $(R_OBJECTS) nrutil.o AquaFuncts_dr.o $(RNG_OBJECTS)
+
+ $(BIN)/testnew: testnew.o $(OBJECTS)
+- $(CC) -o $(BIN)/testnew testnew.o $(OBJECTS) $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/testnew testnew.o $(OBJECTS)
+
+ $(BIN)/getproj: getproj.c
+- $(CC) -o $(BIN)/getproj -O getproj.c
++ $(CC) $(CFLAGS) $(LDFLAGS) -o $(BIN)/getproj getproj.c
+
+ $(BIN)/AquaPlot: AquaPlot.o $(LIB)/MenuFuncts.o $(LIB)/Functs.o
+- $(CC) -o $(BIN)/AquaPlot AquaPlot.o $(LIB)/MenuFuncts.o $(LIB)/Functs.o $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/AquaPlot AquaPlot.o $(LIB)/MenuFuncts.o $(LIB)/Functs.o
+
+ $(BIN)/Qext: Qext.o $(LIB)/MenuFuncts.o $(LIB)/Functs.o
+- $(CC) -o $(BIN)/Qext Qext.o $(LIB)/MenuFuncts.o $(LIB)/Functs.o $(LDFLAGS)
++ $(CC) $(LDFLAGS) -o $(BIN)/Qext Qext.o $(LIB)/MenuFuncts.o $(LIB)/Functs.o
+
+ $(BIN)/StarTest: StarTest.o
+- $(CC) -o $(BIN)/StarTest StarTest.o $(LDFLAGS) $(STARFLAGS) $(STARLIBS)
++ $(CC) $(LDFLAGS) -o $(BIN)/StarTest StarTest.o $(STARFLAGS) $(STARLIBS)
+
+ exth: exth.f
+- f77 -o exth -O2 exth.f
+- strip exth
++ $(FC) $(FFLAGS) -o exth -O2 exth.f
+
+
+ # Object files
+@@ -269,7 +268,7 @@ AquaCommon.o: AquaCommon.c AquaCommon.h nrutil.h \
+ $(CC) -c AquaCommon.c $(CFLAGS)
+
+ nrutil.o: nrutil.c nrutil.h
+- $(CC) -c nrutil.c -DANSI
++ $(CC) $(CFLAGS) -c nrutil.c -DANSI
+
+ AquaFuncts.o: AquaFuncts.c AquaFuncts.h AquaFuncts_cv.h AquaFuncts_io.h\
+ AquaStrucset.h AquaFiles.h\
+@@ -319,7 +318,7 @@ $(LIB)/MenuFuncts.o: $(LIB)/MenuFuncts.c $(LIB)/MenuTypes.h $(LIB)/MenuFuncts.h\
+ cd $(LIB); $(CC) -c MenuFuncts.c $(CFLAGS)
+
+ cv_subs.o: cv_subs.f
+- f77 -c cv_subs.f $(FFLAGS)
++ $(FC) -c cv_subs.f $(FFLAGS)
+
+ Qext.o: Qext.c Qext.h\
+ $(LIB)/MenuFuncts.h $(LIB)/Functs.h $(G_HEADERS)
diff --git a/sci-chemistry/aqua/metadata.xml b/sci-chemistry/aqua/metadata.xml
new file mode 100644
index 000000000000..1837bbc07a6e
--- /dev/null
+++ b/sci-chemistry/aqua/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>