summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2016-09-27 12:13:02 -0600
committerChristoph Junghans <ottxor@gentoo.org>2016-09-27 12:13:37 -0600
commit551afdbc2b2a72fff0dae392979b7df1c5ed5721 (patch)
tree4596b952b6d310d57b23f68dfe6dab5ba928ab48 /sci-chemistry/votca-xtp
parentsci-chemistry/votca-csgapps: version bump (diff)
downloadgentoo-551afdbc2b2a72fff0dae392979b7df1c5ed5721.tar.gz
gentoo-551afdbc2b2a72fff0dae392979b7df1c5ed5721.tar.bz2
gentoo-551afdbc2b2a72fff0dae392979b7df1c5ed5721.zip
sci-chemistry/votca-xtp: initial commit
Package-Manager: portage-2.3.0
Diffstat (limited to 'sci-chemistry/votca-xtp')
-rw-r--r--sci-chemistry/votca-xtp/Manifest2
-rw-r--r--sci-chemistry/votca-xtp/metadata.xml15
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-1.4_rc1.ebuild71
-rw-r--r--sci-chemistry/votca-xtp/votca-xtp-9999.ebuild71
4 files changed, 159 insertions, 0 deletions
diff --git a/sci-chemistry/votca-xtp/Manifest b/sci-chemistry/votca-xtp/Manifest
new file mode 100644
index 000000000000..ab1a26b55ca6
--- /dev/null
+++ b/sci-chemistry/votca-xtp/Manifest
@@ -0,0 +1,2 @@
+DIST votca-xtp-1.4_rc1.tar.gz 15210079 SHA256 b3c839b0cd372399a9de3e06a2d1aedb926ccde4d2df3b9600bc1470ddb0b7df SHA512 ae8d39471d87ba5caee7fd8f5f5c7562f1d5a2cb0952566e0412a7dd614af746e492d77409746ba1cd92cdc8836b902aa4d78a24f66d54904ee32cc371b7d399 WHIRLPOOL 251df4c041dad352cc2e28fc834b9c0fc1c073b4442ba5760b0df19c7addcc6d34d1ac203c4c002630c75ed24b73d8551045c82bbd1b36e55b694166c31cd32f
+DIST votca-xtp-manual-1.4_rc1.pdf 1064036 SHA256 641a0ee0f95a31f01cf8efccfecf00fea6b353206ded3b06bfd0147c1216df99 SHA512 c877535d09faab51bc023c0e3851327fa2cd5139df6291b764d7207605da339aedd883eaf356b6152532f76d803b408b0264efcabb3ba03dcf6d074028285c46 WHIRLPOOL a4f8f8e8b48a66e73b9ae48e4db0449232b025f6431522c6089b4e09dcc4d72aeeb9bd7c6625b1a00c6210dbbbb59c5d741b3db2c01bb752015e01f32428d772
diff --git a/sci-chemistry/votca-xtp/metadata.xml b/sci-chemistry/votca-xtp/metadata.xml
new file mode 100644
index 000000000000..9d258fe78def
--- /dev/null
+++ b/sci-chemistry/votca-xtp/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ottxor@gentoo.org</email>
+ <name>Christoph Junghans</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sci-chemistry@gentoo.org</email>
+ <name>Gentoo Chemistry Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">votca/xtp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sci-chemistry/votca-xtp/votca-xtp-1.4_rc1.ebuild b/sci-chemistry/votca-xtp/votca-xtp-1.4_rc1.ebuild
new file mode 100644
index 000000000000..d00cbee96223
--- /dev/null
+++ b/sci-chemistry/votca-xtp/votca-xtp-1.4_rc1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit bash-completion-r1 cmake-utils multilib
+
+IUSE="doc"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/${PN/-//}/releases/download/v${PV}/${PN}-manual-${PV}.pdf )"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca excitation and charge properties module"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =sci-chemistry/votca-csg-${PV}"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ dev-tex/pgf
+ )
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+DOCS=( README NOTICE CHANGELOG.md )
+
+src_configure() {
+ mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ if [[ ${PV} = *9999* ]]; then
+ cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" manual
+ newdoc "${S}"/manual/xtp-manual.pdf "${PN}-manual-${PV}.pdf"
+ else
+ dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ fi
+ cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
+ dodoc -r "${CMAKE_BUILD_DIR}"/share/doc/html
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-CTP, J. Chem. Theo. Comp. 7, 3335-3345 (2011)"
+ einfo "http://dx.doi.org/10.1021/ct200388s"
+ einfo
+}
diff --git a/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
new file mode 100644
index 000000000000..d00cbee96223
--- /dev/null
+++ b/sci-chemistry/votca-xtp/votca-xtp-9999.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+
+inherit bash-completion-r1 cmake-utils multilib
+
+IUSE="doc"
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="https://github.com/${PN/-//}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ doc? ( https://github.com/${PN/-//}/releases/download/v${PV}/${PN}-manual-${PV}.pdf )"
+ KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
+ S="${WORKDIR}/${P#votca-}"
+else
+ inherit git-r3
+ EGIT_REPO_URI="git://github.com/${PN/-//}.git https://github.com/${PN/-//}.git"
+ KEYWORDS=""
+fi
+
+DESCRIPTION="Votca excitation and charge properties module"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ =sci-chemistry/votca-csg-${PV}"
+
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen[dot]
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ dev-tex/pgf
+ )
+ >=app-text/txt2tags-2.5
+ virtual/pkgconfig"
+
+DOCS=( README NOTICE CHANGELOG.md )
+
+src_configure() {
+ mycmakeargs=(
+ -DLIB=$(get_libdir)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc; then
+ if [[ ${PV} = *9999* ]]; then
+ cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" manual
+ newdoc "${S}"/manual/xtp-manual.pdf "${PN}-manual-${PV}.pdf"
+ else
+ dodoc "${DISTDIR}/${PN}-manual-${PV}.pdf"
+ fi
+ cmake-utils_src_make -C "${CMAKE_BUILD_DIR}" html
+ dodoc -r "${CMAKE_BUILD_DIR}"/share/doc/html
+ fi
+}
+
+pkg_postinst() {
+ einfo
+ einfo "Please read and cite:"
+ einfo "VOTCA-CTP, J. Chem. Theo. Comp. 7, 3335-3345 (2011)"
+ einfo "http://dx.doi.org/10.1021/ct200388s"
+ einfo
+}