summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-07-20 19:52:06 +0200
committerPacho Ramos <pacho@gentoo.org>2018-07-20 19:52:06 +0200
commit184c4b36564a01a68162060f18649b7b8d7ce33d (patch)
tree8b358ad1686e3c6297b092d87ee608faa25ce6e7 /sci-chemistry
parentdev-python/sqlalchemy-1.2.7-r0: alpha stable (diff)
downloadgentoo-184c4b36564a01a68162060f18649b7b8d7ce33d.tar.gz
gentoo-184c4b36564a01a68162060f18649b7b8d7ce33d.tar.bz2
gentoo-184c4b36564a01a68162060f18649b7b8d7ce33d.zip
sci-chemistry/nmrdepaker: Introduce nmrdepaker software
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/nmrdepaker/Manifest1
-rw-r--r--sci-chemistry/nmrdepaker/metadata.xml7
-rw-r--r--sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild33
3 files changed, 41 insertions, 0 deletions
diff --git a/sci-chemistry/nmrdepaker/Manifest b/sci-chemistry/nmrdepaker/Manifest
new file mode 100644
index 000000000000..5954d0c0455d
--- /dev/null
+++ b/sci-chemistry/nmrdepaker/Manifest
@@ -0,0 +1 @@
+DIST nmrdepaker-1.0.tar.gz 2233765 BLAKE2B 9b638a36fc50d7c020d56833b6ca78d7079ad357f42431088c4c0735b7e9ce63a0e6318915ec751b42e6628c0da76b93ca16ffea1ffe6b311480e8d278ce1a1a SHA512 9d1a9048a85f85eacaeeb582c5550345efa673b1f517dad121e2b2e19125f93e71a26f2f8240ea9b8a06489814eb833e7b3653f882a46bad699b01fd1aa4299f
diff --git a/sci-chemistry/nmrdepaker/metadata.xml b/sci-chemistry/nmrdepaker/metadata.xml
new file mode 100644
index 000000000000..020b40648ee8
--- /dev/null
+++ b/sci-chemistry/nmrdepaker/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>pacho@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild b/sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild
new file mode 100644
index 000000000000..5ccd2c4508b6
--- /dev/null
+++ b/sci-chemistry/nmrdepaker/nmrdepaker-1.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DISTUTILS_SINGLE_IMPL="yes"
+PYTHON_COMPAT=( python2_7 )
+
+inherit desktop distutils-r1
+
+DESCRIPTION="Program to perform NMR spectra 'De-Pake-ing' and moment calculation"
+HOMEPAGE="https://launchpad.net/nmrdepaker"
+SRC_URI="https://launchpad.net/${PN}/${PV}/${PV}/+download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3+"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/matplotlib-0.98.5[gtk2,${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.2[${PYTHON_USEDEP}]
+ >=dev-python/pygtk-2.12:2[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/nmrdpaker-${PV}"
+
+src_install() {
+ distutils-r1_src_install
+
+ newicon lib/data/images/unused/nmrfriend-buddy.svg ${PN}.svg
+ make_desktop_entry ${PN}
+}