summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-geosciences/gdal-grass
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-geosciences/gdal-grass')
-rw-r--r--sci-geosciences/gdal-grass/Manifest1
-rw-r--r--sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch11
-rw-r--r--sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild41
-rw-r--r--sci-geosciences/gdal-grass/metadata.xml6
4 files changed, 59 insertions, 0 deletions
diff --git a/sci-geosciences/gdal-grass/Manifest b/sci-geosciences/gdal-grass/Manifest
new file mode 100644
index 000000000000..a33bc6aef446
--- /dev/null
+++ b/sci-geosciences/gdal-grass/Manifest
@@ -0,0 +1 @@
+DIST gdal-grass-1.4.3.tar.gz 47527 RMD160 60e3866a44d595cbf41368adb1b968387c7852b4 SHA1 63b87ad1688cc365dc6bd6c3ccc854d0e6aa637a SHA256 ea18d1e773e8875aaf3261a6ccd2a5fa22d998f064196399dfe73d991688f1dd
diff --git a/sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch b/sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch
new file mode 100644
index 000000000000..dcf5bc40065b
--- /dev/null
+++ b/sci-geosciences/gdal-grass/files/gdal-grass-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.in.orig 2009-07-12 00:09:33.000000000 +0200
++++ Makefile.in 2009-07-12 00:11:09.000000000 +0200
+@@ -26,7 +26,7 @@
+ install -d $(AUTOLOAD_DIR)
+ cp $(GLIBNAME) $(AUTOLOAD_DIR)
+ cp $(OLIBNAME) $(AUTOLOAD_DIR)
+- test -d ${GRASSTABLES_DIR} || mkdir ${GRASSTABLES_DIR}
++ test -d ${GRASSTABLES_DIR} || mkdir -p ${GRASSTABLES_DIR}
+ test -d ${GRASSTABLES_DIR}/etc || mkdir ${GRASSTABLES_DIR}/etc
+ cp @GRASS_GISBASE@/etc/ellipse.table ${GRASSTABLES_DIR}/etc
+ cp @GRASS_GISBASE@/etc/datum.table @GRASS_GISBASE@/etc/datumtransform.table ${GRASSTABLES_DIR}/etc
diff --git a/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
new file mode 100644
index 000000000000..c739c40629d3
--- /dev/null
+++ b/sci-geosciences/gdal-grass/gdal-grass-1.4.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="GDAL plugin to access GRASS data"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+
+IUSE=""
+
+RDEPEND="
+ sci-libs/gdal
+ >=sci-geosciences/grass-6.4.0_rc6
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_configure() {
+ econf \
+ --with-grass=$(pkg-config grass --variable grassdir) \
+ --with-gdal
+}
+
+src_install() {
+ #pass the right variables to 'make install' to prevent a sandbox access violation
+ emake DESTDIR="${D}" \
+ GRASSTABLES_DIR="${D}$(gdal-config --prefix)/share/gdal/grass" \
+ AUTOLOAD_DIR="${D}/usr/$(get_libdir)/gdalplugins" \
+ install
+}
diff --git a/sci-geosciences/gdal-grass/metadata.xml b/sci-geosciences/gdal-grass/metadata.xml
new file mode 100644
index 000000000000..0fcb66048e40
--- /dev/null
+++ b/sci-geosciences/gdal-grass/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-geosciences</herd>
+</pkgmetadata>
+