summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2015-12-28 20:53:48 +0100
committerAmy Winston <amynka@gentoo.org>2015-12-28 20:53:48 +0100
commit5509c0eecdd713de3c148e0eaae5e2b7e55ee42d (patch)
tree84ee15efadea5c9042b0d15c48cde8a19ef3961a /sci-geosciences
parentfixed patch lost #569976, #569628 (diff)
downloadgentoo-5509c0eecdd713de3c148e0eaae5e2b7e55ee42d.tar.gz
gentoo-5509c0eecdd713de3c148e0eaae5e2b7e55ee42d.tar.bz2
gentoo-5509c0eecdd713de3c148e0eaae5e2b7e55ee42d.zip
sci-geosciences/qgis: 2.12.1 version bump bug #485868.
Package-Manager: portage-2.2.24
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/qgis/Manifest1
-rw-r--r--sci-geosciences/qgis/metadata.xml2
-rw-r--r--sci-geosciences/qgis/qgis-2.12.1.ebuild153
3 files changed, 156 insertions, 0 deletions
diff --git a/sci-geosciences/qgis/Manifest b/sci-geosciences/qgis/Manifest
index 80f4f570b88d..c354b3e937b0 100644
--- a/sci-geosciences/qgis/Manifest
+++ b/sci-geosciences/qgis/Manifest
@@ -1,2 +1,3 @@
DIST qgis-1.8.0.tar.bz2 29997204 SHA256 700be4f81c4a6b6335a0217a6c476328c0ea02543d579a06dc1aaf60201303ab SHA512 475c2087164b325bd6efe49bdca9e5eb563645ea556c34f644cff00fd6bcc0585e9e39daa2e62f0a706db58bc1551af786fc2cb6c17ad90f5734ebea5044e57c WHIRLPOOL ef1fc2832bd20398afdee9eb4c1e81baa3c8c792acc76c0b609a74ae0d61301b00f105221fa27b74b26c68fd8b5d849ea7612e960a8684b885cb8f31d0c71a1c
+DIST qgis-2.12.1.tar.bz2 69088412 SHA256 96b9bb6ef62ec042b938e4b3112cc8e2e96caad36d6615b484ad757a65e80429 SHA512 647ad827f6b139a301a5fd1387333842d0187390db1906a37713b41a24bd97e37624ba2b1b500b473132d17e0d856efd0a033b2159930d005c9f74845547958e WHIRLPOOL 05895935df656937b3a1848a07eee8ee96692a8a34d30515d143b2f08cd652640b5116a81025e822497cc26d0e6f6347a6344657272a4c6c6de5d128792b98ad
DIST qgis_sample_data.tar.gz 13601736 SHA256 a31c54056776e8476e1f959870830f850423645cfb80d88811f3b365c29f2b4a SHA512 5847d7b32e5f75e771adf6b959847024f55b2360c307bd80e5628595fc53f5aaca18adf6cb00fa027a7e7b326c7f72bab58df16674daf20b77c676e163d93f78 WHIRLPOOL fe7746f8a72807742427c6fb70f1453e195be75322d5784adc484ac14b0eae55569dbded7468ea2ba0c34781fe14918e07a5a187dca82bff551c6117f941d7f5
diff --git a/sci-geosciences/qgis/metadata.xml b/sci-geosciences/qgis/metadata.xml
index 2d8595802e03..c7d2ce32745c 100644
--- a/sci-geosciences/qgis/metadata.xml
+++ b/sci-geosciences/qgis/metadata.xml
@@ -13,5 +13,7 @@
<use>
<flag name="bundled-libs">Use internal copy of <pkg>x11-libs/qwtpolar</pkg></flag>
<flag name="spatialite">Enable Spatial DBMS over sqlite <pkg>dev-db/spatialite</pkg></flag>
+ <flag name="grass">Add support for <pkg>sci-geosciences/grass</pkg></flag>
+ <flag name="mapserver">Determines whether mapserver should be built</flag>
</use>
</pkgmetadata>
diff --git a/sci-geosciences/qgis/qgis-2.12.1.ebuild b/sci-geosciences/qgis/qgis-2.12.1.ebuild
new file mode 100644
index 000000000000..119b1cd1a41a
--- /dev/null
+++ b/sci-geosciences/qgis/qgis-2.12.1.ebuild
@@ -0,0 +1,153 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit eutils multilib gnome2-utils cmake-utils python-single-r1
+
+DESCRIPTION="User friendly Geographic Information System"
+HOMEPAGE="http://www.qgis.org/"
+SRC_URI="
+ http://qgis.org/downloads/qgis-${PV}.tar.bz2
+ examples? ( http://download.osgeo.org/qgis/data/qgis_sample_data.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples grass gsl mapserver postgres python test"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+ mapserver? ( python )"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-libs/expat
+ sci-geosciences/gpsbabel
+ >=sci-libs/gdal-1.6.1[geos,python?,${PYTHON_USEDEP}]
+ sci-libs/geos
+ gsl? ( sci-libs/gsl )
+ sci-libs/libspatialindex
+ sci-libs/proj
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ dev-qt/qtsql:4
+ dev-qt/qtwebkit:4
+ dev-qt/designer:4
+ x11-libs/qscintilla
+ || (
+ ( || ( <x11-libs/qwt-6.1.2:6[svg] >=x11-libs/qwt-6.1.2:6[svg,qt4] ) >=x11-libs/qwtpolar-1 )
+ ( x11-libs/qwt:5[svg] <x11-libs/qwtpolar-1 )
+ )
+ grass? ( || ( >=sci-geosciences/grass-7.0.0 ) )
+ mapserver? ( dev-libs/fcgi )
+ postgres? ( dev-db/postgresql:* )
+ python? (
+ dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
+ dev-python/sip[${PYTHON_USEDEP}]
+ dev-python/qscintilla-python[${PYTHON_USEDEP}]
+ postgres? ( dev-python/psycopg:2[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ )
+ dev-db/sqlite:3
+ dev-db/spatialite
+ app-crypt/qca:2[qt4,openssl]
+"
+
+DEPEND="${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DQGIS_MANUAL_SUBDIR=/share/man/"
+ "-DBUILD_SHARED_LIBS=ON"
+ "-DQGIS_LIB_SUBDIR=$(get_libdir)"
+ "-DQGIS_PLUGIN_SUBDIR=$(get_libdir)/qgis"
+ "-DWITH_INTERNAL_QWTPOLAR=OFF"
+ "-DPEDANTIC=OFF"
+ "-DWITH_APIDOC=OFF"
+ "-DWITH_SPATIALITE=ON"
+ "-DWITH_INTERNAL_SPATIALITE=OFF"
+ $(cmake-utils_use_with postgres POSTGRESQL)
+ $(cmake-utils_use_with grass GRASS)
+ $(cmake-utils_use_with mapserver SERVER)
+ $(cmake-utils_use_with python BINDINGS)
+ $(cmake-utils_use python BINDINGS_GLOBAL_INSTALL)
+ $(cmake-utils_use_with python PYSPATIALITE)
+ $(cmake-utils_use_with gsl GSL)
+ $(cmake-utils_use_enable test TESTS)
+ $(usex grass "-DGRASS_PREFIX=/usr/" "")
+ )
+
+ if has_version '>=x11-libs/qwtpolar-1' && has_version 'x11-libs/qwt:5' ; then
+ elog "Both >=x11-libs/qwtpolar-1 and x11-libs/qwt:5 installed. Force build with qwt6"
+ if has_version '>=x11-libs/qwt-6.1.2' ; then
+ mycmakeargs+=(
+ "-DQWT_INCLUDE_DIR=/usr/include/qwt6"
+ "-DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6-qt4.so"
+ )
+ else
+ mycmakeargs+=(
+ "-DQWT_INCLUDE_DIR=/usr/include/qwt6"
+ "-DQWT_LIBRARY=/usr/$(get_libdir)/libqwt6.so"
+ )
+ fi
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc BUGS ChangeLog CODING
+
+ newicon -s 128 images/icons/qgis-icon.png qgis.png
+ make_desktop_entry qgis "QGIS " qgis
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r "${WORKDIR}"/qgis_sample_data/*
+ fi
+
+ python_optimize "${D}"/usr/share/qgis/python/plugins \
+ "${D}"/$(python_get_sitedir)/qgis
+
+ if use grass; then
+ python_fix_shebang "${D}"/usr/share/qgis/grass/scripts
+ python_optimize "${D}"/usr/share/qgis/grass/scripts
+ fi
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "If you don't intend to use an external PostGIS server"
+ elog "you should install:"
+ elog " dev-db/postgis"
+ else
+ if use python ; then
+ elog "Support of PostgreSQL is disabled."
+ elog "But some installed python-plugins needs import psycopg2 module."
+ elog "If you do not need this modules just disable them in main menu."
+ elog "Or you need to set USE=postgres"
+ fi
+ fi
+
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}