summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-11-11 14:51:01 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-11-11 14:51:58 +1100
commitc4bf5de43d820b612d9ca36eb5c010fa4265b71a (patch)
tree1bdb9c44bb2aa5546c5ca06343e04ba8e3743c5c /sci-libs
parentsys-kernel/gentoo-sources: Dropping due to missing patch (diff)
downloadgentoo-c4bf5de43d820b612d9ca36eb5c010fa4265b71a.tar.gz
gentoo-c4bf5de43d820b612d9ca36eb5c010fa4265b71a.tar.bz2
gentoo-c4bf5de43d820b612d9ca36eb5c010fa4265b71a.zip
sci-libs/libqalculate: version bump 2.8.1
Closes: https://bugs.gentoo.org/655002 Closes: https://bugs.gentoo.org/651272 Closes: https://bugs.gentoo.org/668480 Package-Manager: Portage-2.3.51, Repoman-2.3.12 Signed-off-by: Michael Palimaka <kensington@gentoo.org>
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libqalculate/Manifest1
-rw-r--r--sci-libs/libqalculate/libqalculate-2.8.1.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/sci-libs/libqalculate/Manifest b/sci-libs/libqalculate/Manifest
index 908cf204d652..e9ceef9c3169 100644
--- a/sci-libs/libqalculate/Manifest
+++ b/sci-libs/libqalculate/Manifest
@@ -1,2 +1,3 @@
DIST libqalculate-0.9.9.tar.gz 1509180 BLAKE2B 3f309add80ddb6b21730eab25d37c2d8fee163a79768a09ec5e7e5d329aa11ed9dafbf77f4ce194a96c2ac6a3b55a9c0d16755d5e106123cc2a5f931f6872d91 SHA512 c7692dcd91e0a7aea8184ca5366a3caf704b6e716c9e8552f4214ce7fc3157cf127daf7a063196383e4d5a99f8703486f2282c7fb01acafee5e1b3d8993de384
DIST libqalculate-2.2.0.tar.gz 1717207 BLAKE2B 020ca544683ff140ab5f8256a5a955c895a6ea09a581e9e75ab6c0a0657886c352a1ec2d34400057fe80004481d3198998613113ca40fb4feebfca010445dced SHA512 e6f3693e4dba2beffca300b673657b90037a6b7acc5bbd4e659863f4f5aec148d6d385fc3c666b16b2be713d0a8ad1b4d7fda557cef0e2be340ca2435f62aae7
+DIST libqalculate-2.8.1.tar.gz 1961535 BLAKE2B 074d83a44cbc6cb5d8afe5121e4c34cec46f2f6fecf046f6b4e67c6ebc612030ccbd0f42c303cc675267374502ecb3e831c9bbfca0f13d339e31fb8933a99b7a SHA512 a258bf4f67db70263626ac77822afc75fd7a9e5af2feb1930314daff219865b28c43e82fef6ceae4f3f23957447d6eaebdc709e606d28457bca0f47eefb9274a
diff --git a/sci-libs/libqalculate/libqalculate-2.8.1.ebuild b/sci-libs/libqalculate/libqalculate-2.8.1.ebuild
new file mode 100644
index 000000000000..a06b1b5b5e12
--- /dev/null
+++ b/sci-libs/libqalculate/libqalculate-2.8.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A modern multi-purpose calculator library"
+HOMEPAGE="https://qalculate.github.io/"
+SRC_URI="https://github.com/Qalculate/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/20"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl icu gnuplot readline static-libs"
+
+COMMON_DEPEND="
+ dev-libs/gmp:0=
+ dev-libs/libxml2:2
+ dev-libs/mpfr:0=
+ virtual/libiconv
+ curl? ( net-misc/curl )
+ icu? ( dev-libs/icu:= )
+ readline? ( sys-libs/readline:0= )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+RDEPEND="${COMMON_DEPEND}
+ gnuplot? ( >=sci-visualization/gnuplot-3.7 )"
+
+src_prepare() {
+ default
+
+ cat >po/POTFILES.skip <<-EOF
+ # Required by make check
+ data/currencies.xml.in
+ data/datasets.xml.in
+ data/elements.xml.in
+ data/functions.xml.in
+ data/planets.xml.in
+ data/units.xml.in
+ data/variables.xml.in
+ src/defs2doc.cc
+ EOF
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with curl libcurl) \
+ $(use_with icu) \
+ $(use_with readline)
+}
+
+src_install() {
+ # docs/reference/Makefile.am -> referencedir=
+ emake \
+ DESTDIR="${D}" \
+ referencedir="${EPREFIX}/usr/share/doc/${PF}/html" \
+ install
+
+ dodoc AUTHORS ChangeLog NEWS README* TODO
+
+ find "${ED}" -name '*.la' -delete || die
+}