summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sci-visualization/fig2sxd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sci-visualization/fig2sxd')
-rw-r--r--sci-visualization/fig2sxd/Manifest2
-rw-r--r--sci-visualization/fig2sxd/fig2sxd-0.21.ebuild38
-rw-r--r--sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch12
-rw-r--r--sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch9
-rw-r--r--sci-visualization/fig2sxd/metadata.xml12
5 files changed, 73 insertions, 0 deletions
diff --git a/sci-visualization/fig2sxd/Manifest b/sci-visualization/fig2sxd/Manifest
new file mode 100644
index 000000000000..e207a637c768
--- /dev/null
+++ b/sci-visualization/fig2sxd/Manifest
@@ -0,0 +1,2 @@
+DIST fig2sxd_0.21-2.diff.gz 2765 SHA256 b9dd3c562b81ea820276a8b5c4c2e0049c5c201624e9b02b6fa1faf106f6b28c SHA512 7b09a837fd2f59e27869dab788b8fd75f810eadf31f54ec1c7e4445ecc13093e68bb22cfc0b8163d65ae6e661cf8ad414c03172fa10367d3c14e2b0332eb1d2f WHIRLPOOL 3d718300ea0b1a21f3e5bc126d272239ea67225930014cd0205371a82cfbf5af3356dfcf1dfd1e258642e733f4a15404883da86084226e7ab4a329a7f94ab0b8
+DIST fig2sxd_0.21.orig.tar.gz 26083 SHA256 11a47f458c1d63f1c80dd49d8bb9dfc008cdb5d4d5c9a8611c258da3fdb8150a SHA512 666975716c56cdc9e8660e81f086887edd5d7e78e3d50c528130b264eec377cae0ba2ac17467a351d46c402f9f736c7b166c0b3849abe6d0d1187c7270b99152 WHIRLPOOL ec3818ab59d485a5dbbcd9e4d90b7bfcbfba9cbfdea80ae3d759f50af4c3923e97c3e0b22a93d7211a31449678e0a7b099c463a9d6c2007f5543e3276eba5895
diff --git a/sci-visualization/fig2sxd/fig2sxd-0.21.ebuild b/sci-visualization/fig2sxd/fig2sxd-0.21.ebuild
new file mode 100644
index 000000000000..c3a472c3d83f
--- /dev/null
+++ b/sci-visualization/fig2sxd/fig2sxd-0.21.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Utility to convert files in xfig format to OpenOffice.org Draw format"
+LICENSE="GPL-2"
+PVD=2
+
+HOMEPAGE="http://sourceforge.net/projects/fig2sxd"
+SRC_URI="mirror://sourceforge/${PN}/${PN}_${PV}.orig.tar.gz
+ mirror://sourceforge/${PN}/${PN}_${PV}-${PVD}.diff.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${WORKDIR}"/${PN}_${PV}-${PVD}.diff
+ epatch "${FILESDIR}"/${PN}-0.20-ldflags.patch
+ epatch "${FILESDIR}"/${PN}-0.20-phony-check.patch
+}
+
+src_compile() {
+ emake CXXFLAGS="${CXXFLAGS}" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ dodoc changelog
+}
diff --git a/sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch b/sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch
new file mode 100644
index 000000000000..a9bd521d3196
--- /dev/null
+++ b/sci-visualization/fig2sxd/files/fig2sxd-0.20-ldflags.patch
@@ -0,0 +1,12 @@
+diff -Naur fig2sxd-0.20/Makefile fig2sxd-0.20.new/Makefile
+--- fig2sxd-0.20/Makefile 2008-05-16 18:47:34.000000000 -0400
++++ fig2sxd-0.20.new/Makefile 2009-08-31 22:14:38.000000000 -0400
+@@ -51,7 +51,7 @@
+ LIBS = -lz
+
+ $(TARGET1): $(OBJECTS1)
+- $(CXX) -o $@ $^ $(LIBS)
++ $(CXX) $(LDFLAGS) $^ $(LIBS) -o $@
+
+ $(OBJECTS1): %.o: $(SRCDIR)%.cpp $(DEPEND)%.dep
+ $(CXX) $(CXXFLAGS) -o $@ -c $<
diff --git a/sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch b/sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch
new file mode 100644
index 000000000000..d9e76b8c9780
--- /dev/null
+++ b/sci-visualization/fig2sxd/files/fig2sxd-0.20-phony-check.patch
@@ -0,0 +1,9 @@
+diff -Naur fig2sxd-0.20/Makefile fig2sxd-0.20.new/Makefile
+--- fig2sxd-0.20/Makefile 2008-05-16 18:47:34.000000000 -0400
++++ fig2sxd-0.20.new/Makefile 2009-08-31 22:22:07.000000000 -0400
+@@ -75,4 +75,4 @@
+ tar czf `date +"../fig2sxd-%Y-%m-%d-%H-%M.tar.gz"` -C $(SRCDIR)../ \
+ $(ARCHFILES)
+
+-.PHONY: all clean
++.PHONY: all clean check
diff --git a/sci-visualization/fig2sxd/metadata.xml b/sci-visualization/fig2sxd/metadata.xml
new file mode 100644
index 000000000000..95ebf7ed3d76
--- /dev/null
+++ b/sci-visualization/fig2sxd/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <longdescription lang="en">
+ This program converts a file in XFig format into a .sxd file for
+ OpenOffice.org Draw.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">fig2sxd</remote-id>
+ </upstream>
+</pkgmetadata>