summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-apps/apmd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-apps/apmd')
-rw-r--r--sys-apps/apmd/Manifest2
-rw-r--r--sys-apps/apmd/apmd-3.2.2_p14.ebuild79
-rw-r--r--sys-apps/apmd/files/apmd.confd4
-rw-r--r--sys-apps/apmd/files/apmd.rc629
-rw-r--r--sys-apps/apmd/metadata.xml5
5 files changed, 119 insertions, 0 deletions
diff --git a/sys-apps/apmd/Manifest b/sys-apps/apmd/Manifest
new file mode 100644
index 000000000000..ccd5df8ac921
--- /dev/null
+++ b/sys-apps/apmd/Manifest
@@ -0,0 +1,2 @@
+DIST apmd_3.2.2-14.diff.gz 19195 SHA256 7905ff96be93d725544d0040e425c42f9c05580db3c272f11cff75b9aa89d430 SHA512 a3578d0c43950f832fb437a744f8a4c3058c731649decb90f7b42c901b06f4df5f9a75599b4278e15af1c8a30d8043b0d76eb7d2cb67b05bf6bb210d5912a16d WHIRLPOOL 300ef81d426fffa0c3ce944d523245745a9388013672f756d4f298f5e2d0b136d962b6d635d6fc787bdd2aa351097ac682ebe0b9ee41fc32e19c74b69601712b
+DIST apmd_3.2.2.orig.tar.gz 72757 SHA256 7f7d9f60b7766b852881d40b8ff91d8e39fccb0d1d913102a5c75a2dbb52332d SHA512 fdc74703e75a700397bb2c907986f0cf0792ee4128d7a7ae08adf090bff0ea595044ba7a935d34929745bb702eb8bfe232e0ee9156efd23a995dc087f1b20bf4 WHIRLPOOL 4fbb0f6d99215ce754686c2748b7ad7bcbe219ddafa190a05f9c345957f7bebd51b04e26e23ec4bdb8c49cba6e89fabbb3dbf631fd4342a5dc4bd1148e4b7b63
diff --git a/sys-apps/apmd/apmd-3.2.2_p14.ebuild b/sys-apps/apmd/apmd-3.2.2_p14.ebuild
new file mode 100644
index 000000000000..3313962ac015
--- /dev/null
+++ b/sys-apps/apmd/apmd-3.2.2_p14.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+MY_PV=${PV%_p*}
+MY_P=${PN}_${MY_PV}
+PATCHV=${PV#*_p}
+
+DESCRIPTION="Advanced Power Management Daemon"
+HOMEPAGE="http://packages.qa.debian.org/a/apmd.html"
+SRC_URI="mirror://debian/pool/main/a/apmd/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/a/apmd/${MY_P}-${PATCHV}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm ppc ppc64 x86"
+IUSE="nls X"
+
+RDEPEND=">=sys-apps/debianutils-1.16
+ >=sys-power/powermgmt-base-1.31
+ X? ( x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXmu
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libXt
+ x11-libs/libXext )"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+ virtual/os-headers"
+
+S=${WORKDIR}/${PN}-${MY_PV}.orig
+
+src_prepare() {
+ epatch "${WORKDIR}"/${MY_P}-${PATCHV}.diff
+
+ if ! use X; then
+ sed -i \
+ -e 's:\(EXES=.*\)xapm:\1:' \
+ -e 's:\(.*\)\$(LT_INSTALL).*xapm.*$:\1echo:' \
+ Makefile || die
+ fi
+
+ # use system headers and skip on_ac_power
+ rm -f on_ac_power*
+
+ sed -i \
+ -e '/on_ac_power/d' \
+ -e 's:-I/usr/src/linux/include -I/usr/X11R6/include::' \
+ -e 's:-L/usr/X11R6/lib::' \
+ Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ dodir /usr/sbin
+ emake DESTDIR="${D}" PREFIX=/usr LIBDIR=/usr/$(get_libdir) install
+
+ keepdir /etc/apm/{event.d,suspend.d,resume.d,other.d,scripts.d}
+ exeinto /etc/apm
+ doexe debian/apmd_proxy
+ dodoc AUTHORS {,apmsleep.}README debian/{changelog,README.Debian}
+
+ doman *.{1,8}
+
+ # note: apmd_proxy.conf is currently disabled and not used, thus
+ # not installed - liquidx (01 Mar 2004)
+
+ newconfd "${FILESDIR}"/apmd.confd apmd
+ newinitd "${FILESDIR}"/apmd.rc6 apmd
+
+ use nls || rm -rf "${D}"/usr/share/man/fr
+}
diff --git a/sys-apps/apmd/files/apmd.confd b/sys-apps/apmd/files/apmd.confd
new file mode 100644
index 000000000000..5f371d9083b8
--- /dev/null
+++ b/sys-apps/apmd/files/apmd.confd
@@ -0,0 +1,4 @@
+# /etc/init.d/apmd:
+# $Id$
+
+APMD_OPTS="-P /etc/apm/apmd_proxy"
diff --git a/sys-apps/apmd/files/apmd.rc6 b/sys-apps/apmd/files/apmd.rc6
new file mode 100644
index 000000000000..bb5e0091b773
--- /dev/null
+++ b/sys-apps/apmd/files/apmd.rc6
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ need localmount
+}
+
+checkconfig() {
+ if [ ! -e /proc/apm ] ; then
+ eerror "APM support has not been compiled into the kernel"
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting apmd"
+ start-stop-daemon --start --quiet --pidfile /var/run/apmd.pid \
+ --startas /usr/sbin/apmd -- ${APMD_OPTS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping apmd"
+ start-stop-daemon --stop --quiet --pidfile /var/run/apmd.pid
+ eend $?
+}
diff --git a/sys-apps/apmd/metadata.xml b/sys-apps/apmd/metadata.xml
new file mode 100644
index 000000000000..4538a68724a6
--- /dev/null
+++ b/sys-apps/apmd/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+</pkgmetadata>