summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2017-08-15 12:33:57 -0400
committerCraig Andrews <candrews@gentoo.org>2017-09-07 09:14:14 -0400
commit6f6c7207eb9bd0da8a2145667a1f8f8b543b121d (patch)
treee5fd0298a29826d76eebd18bd8fb9c1923186aa7 /sys-auth/google-authenticator/google-authenticator-9999.ebuild
parentsys-auth/google-authenticator: update metadata.xml to point to the correct gi... (diff)
downloadgentoo-6f6c7207eb9bd0da8a2145667a1f8f8b543b121d.tar.gz
gentoo-6f6c7207eb9bd0da8a2145667a1f8f8b543b121d.tar.bz2
gentoo-6f6c7207eb9bd0da8a2145667a1f8f8b543b121d.zip
sys-auth/google-authenticator: bump to 1.04, update -9999, EAPI=6
Gentoo-bug: 619346 Package-Manager: Portage-2.3.7, Repoman-2.3.3 Closes #5430
Diffstat (limited to 'sys-auth/google-authenticator/google-authenticator-9999.ebuild')
-rw-r--r--sys-auth/google-authenticator/google-authenticator-9999.ebuild37
1 files changed, 8 insertions, 29 deletions
diff --git a/sys-auth/google-authenticator/google-authenticator-9999.ebuild b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
index b637ffb38586..e3259cba968a 100644
--- a/sys-auth/google-authenticator/google-authenticator-9999.ebuild
+++ b/sys-auth/google-authenticator/google-authenticator-9999.ebuild
@@ -1,23 +1,21 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit multilib
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/google/${PN}.git"
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/google/google-authenticator-libpam.git"
inherit git-r3 autotools
- S="${WORKDIR}/${P}/libpam"
else
- MY_P=${P%_pre*}
- SRC_URI="mirror://gentoo/${P}.tar.xz"
+ SRC_URI="https://github.com/google/google-authenticator-libpam/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
- S="${WORKDIR}/${MY_P}"
+ S="${WORKDIR}/google-authenticator-libpam-${PV}"
fi
DESCRIPTION="PAM Module for two step verification via mobile platform"
-HOMEPAGE="https://github.com/google/google-authenticator"
+HOMEPAGE="https://github.com/google/google-authenticator-libpam"
LICENSE="Apache-2.0"
SLOT="0"
@@ -27,37 +25,18 @@ DEPEND="virtual/pam"
RDEPEND="${DEPEND}"
src_prepare() {
- if [[ ${PV} == "9999" ]] ; then
+ default
+ if [[ ${PV} == 9999 ]] ; then
eautoreconf
fi
}
-src_configure() {
- # We might want to use getpam_mod_dir from pam eclass,
- # but the build already appends "/security" for us.
- econf \
- --docdir="\$(datarootdir)/doc/${PF}" \
- --htmldir='$(docdir)/html' \
- --libdir="/$(get_libdir)"
-}
-
src_compile() {
default
-
- if [[ ${PV} == "9999" ]] ; then
- local stamp=$(date --date="$(git log -n1 --pretty=format:%ci master)" -u "+%Y%m%d%H%M%S")
- emake dist
-
- local otar=$(echo ${PN}-*.tar.gz)
- local ntar="${otar%.tar.gz}_pre${stamp}.tar.xz"
- zcat "${otar}" | xz > "${ntar}"
- fi
}
src_install() {
default
- # Punt the pam module libtool archive.
- find "${ED}" -name '*.la' -delete
}
pkg_postinst() {