summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVikraman Choudhury <vikraman@gentoo.org>2015-09-17 01:31:17 -0400
committerVikraman Choudhury <vikraman@gentoo.org>2015-09-17 01:31:17 -0400
commit3228822133e5f35922c0426418468d994aa02f89 (patch)
tree4371d0cb2615a62e0e481fbec85b806a96d49bc1 /sys-block/rts_pstor
parentsys-block/rts5229: Fix build with kernel 4.2.0 (diff)
downloadgentoo-3228822133e5f35922c0426418468d994aa02f89.tar.gz
gentoo-3228822133e5f35922c0426418468d994aa02f89.tar.bz2
gentoo-3228822133e5f35922c0426418468d994aa02f89.zip
sys-block/rts_pstor: Fix build with kernel 4.2.0
Gentoo-Bug: 559668 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-block/rts_pstor')
-rw-r--r--sys-block/rts_pstor/files/rts_pstor-vmalloc.patch44
-rw-r--r--sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild (renamed from sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild)1
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch b/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch
new file mode 100644
index 000000000000..3b3f4beb885d
--- /dev/null
+++ b/sys-block/rts_pstor/files/rts_pstor-vmalloc.patch
@@ -0,0 +1,44 @@
+diff -Naur rts_pstor.a/ms.c rts_pstor.b/ms.c
+--- rts_pstor.a/ms.c 2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/ms.c 2015-09-17 01:28:41.816067799 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts_pstor.a/rtsx_chip.c rts_pstor.b/rtsx_chip.c
+--- rts_pstor.a/rtsx_chip.c 2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/rtsx_chip.c 2015-09-17 01:28:13.680536901 -0400
+@@ -24,6 +24,7 @@
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
+ #include <linux/workqueue.h>
++#include <linux/vmalloc.h>
+
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts_pstor.a/rtsx_scsi.c rts_pstor.b/rtsx_scsi.c
+--- rts_pstor.a/rtsx_scsi.c 2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/rtsx_scsi.c 2015-09-17 01:28:42.688053259 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
+diff -Naur rts_pstor.a/xd.c rts_pstor.b/xd.c
+--- rts_pstor.a/xd.c 2011-01-11 04:11:07.000000000 -0500
++++ rts_pstor.b/xd.c 2015-09-17 01:28:42.689053242 -0400
+@@ -23,6 +23,7 @@
+ #include <linux/blkdev.h>
+ #include <linux/kthread.h>
+ #include <linux/sched.h>
++#include <linux/vmalloc.h>
+
+ #include "rtsx.h"
+ #include "rtsx_transport.h"
diff --git a/sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild b/sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild
index c24eb5850d42..91bcd74cdde6 100644
--- a/sys-block/rts_pstor/rts_pstor-1.10-r4.ebuild
+++ b/sys-block/rts_pstor/rts_pstor-1.10-r5.ebuild
@@ -30,6 +30,7 @@ src_prepare() {
&& epatch "${FILESDIR}/${PN}-linux-3.8.patch"
([ ${KV_MAJOR} -gt 3 ] || ([ ${KV_MAJOR} -eq 3 ] && [ ${KV_MINOR} -ge 10 ])) \
&& epatch "${FILESDIR}/${PN}-linux-3.10.patch"
+ epatch "${FILESDIR}/${PN}-vmalloc.patch"
}
pkg_setup() {