summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUltrabug <ultrabug@gentoo.org>2018-08-15 00:01:52 +0200
committerUltrabug <ultrabug@gentoo.org>2018-08-15 00:01:52 +0200
commit9d60b705cdfb4f0f1af9cb266e5fff56e476c68c (patch)
treeee5abdd4a5f089f881e1eac911414ed20875f8f7 /sys-cluster/crmsh
parentsys-cluster/pacemaker: version bump (diff)
downloadgentoo-9d60b705cdfb4f0f1af9cb266e5fff56e476c68c.tar.gz
gentoo-9d60b705cdfb4f0f1af9cb266e5fff56e476c68c.tar.bz2
gentoo-9d60b705cdfb4f0f1af9cb266e5fff56e476c68c.zip
sys-cluster/crmsh: version bump, fixes #612198
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'sys-cluster/crmsh')
-rw-r--r--sys-cluster/crmsh/Manifest1
-rw-r--r--sys-cluster/crmsh/crmsh-3.0.3.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/sys-cluster/crmsh/Manifest b/sys-cluster/crmsh/Manifest
index 40b85139d71c..eb3270395248 100644
--- a/sys-cluster/crmsh/Manifest
+++ b/sys-cluster/crmsh/Manifest
@@ -1 +1,2 @@
DIST crmsh-2.1.1.tar.gz 733302 BLAKE2B 6b6afdb1c3144eccf432e52a16910e7b427384458e720e042900e115d3e2986f2d08ec77acc9ad288e59070d55065e05c46770b0eeaad49a01b17bd93f593051 SHA512 556190e4e8da009d5f84f6356eeae2f5a18d8ca19d8c384c01d4d8526f7a20bb9545a08a6abe7cb6d9c33d9ae62ba0ea5df9ff0ae90341a53d9f7b201f5788ae
+DIST crmsh-3.0.3.tar.gz 948573 BLAKE2B b4acb4420a7f447f0d50115ba449d506d2017e6f29221bd0b1ba45eb790e6472eadc62ff5ac6af367f4d5f2631cae162e770c0a6735dea42367248f2302cdcb4 SHA512 9dcb9560f8e23791340454e20f4e1ccd090230337357b93c2029f58ff9754756bc1eca5991c00290b937eeb3b42554989b5d6cc85a2eef5107f250d7acf570d3
diff --git a/sys-cluster/crmsh/crmsh-3.0.3.ebuild b/sys-cluster/crmsh/crmsh-3.0.3.ebuild
new file mode 100644
index 000000000000..ba5fa913ffae
--- /dev/null
+++ b/sys-cluster/crmsh/crmsh-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+AUTOTOOLS_AUTORECONF=true
+KEYWORDS=""
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/crmsh/crmsh"
+ inherit git-2
+ S="${WORKDIR}/${PN}-${MY_TREE}"
+else
+ SRC_URI="https://github.com/crmsh/crmsh/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~hppa ~x86"
+fi
+
+inherit eutils python-r1
+
+DESCRIPTION="Pacemaker command line interface for management and configuration"
+HOMEPAGE="https://crmsh.github.io/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=sys-cluster/pacemaker-1.1.9"
+RDEPEND="${DEPEND}
+ dev-python/lxml[${PYTHON_USEDEP}]"
+
+src_configure() {
+ ./autogen.sh
+ econf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}