summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-cluster/projections
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-cluster/projections')
-rw-r--r--sys-cluster/projections/Manifest1
-rw-r--r--sys-cluster/projections/metadata.xml9
-rw-r--r--sys-cluster/projections/projections-6.2.1.ebuild30
3 files changed, 40 insertions, 0 deletions
diff --git a/sys-cluster/projections/Manifest b/sys-cluster/projections/Manifest
new file mode 100644
index 000000000000..fd66e12c7df5
--- /dev/null
+++ b/sys-cluster/projections/Manifest
@@ -0,0 +1 @@
+DIST projections_6.2.1.tar.gz 3713748 SHA256 8d47164f3765a1d7dae28bf35d2963dc87542f1f08025b6aa01d3952199deaa8 SHA512 2a6e4b787491066dec31de05d777243252c08b4504743577297da7e3ecd9c4c3b96db46c295c55c413a98ebe5e338e6b90c213346925a20d89b47bb0b77eeaf8 WHIRLPOOL 10a8a8ac6ec283d95c7485b02075d69eb37b9445b89db000ebcd4ffeec62dc74773807b564af9f89d2e488ec3965eb58f937fb53b889d54b72bfa5c2abc2dad1
diff --git a/sys-cluster/projections/metadata.xml b/sys-cluster/projections/metadata.xml
new file mode 100644
index 000000000000..6b1c94c9f6e6
--- /dev/null
+++ b/sys-cluster/projections/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci</herd>
+ <maintainer>
+ <email>nicolasbock@gentoo.org</email>
+ <name>Nicolas Bock</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/sys-cluster/projections/projections-6.2.1.ebuild b/sys-cluster/projections/projections-6.2.1.ebuild
new file mode 100644
index 000000000000..47f2b6f9d403
--- /dev/null
+++ b/sys-cluster/projections/projections-6.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit java-pkg-2
+
+DESCRIPTION="Projections Performance Analysis Framework for Charm++ Applications"
+HOMEPAGE="http://charm.cs.uiuc.edu/"
+SRC_URI="http://charm.cs.illinois.edu/distrib/binaries/projections/projections_${PV}.tar.gz"
+
+S="${WORKDIR}/${PN}_${PV}"
+
+LICENSE="charm"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="
+ >=virtual/jre-1.6
+ sys-cluster/charm[charmtracing]"
+
+src_install() {
+ java-pkg_newjar ${PN}.jar
+ java-pkg_dolauncher ${PN} \
+ --main projections.analysis.ProjMain \
+ --jar ${PN}.jar
+}