summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBertrand Néron <freeh4cker@gmail.com>2018-01-06 19:52:12 +0100
committerJustin Lecher <jlec@gentoo.org>2018-01-06 21:28:00 +0000
commitbae8b4030885dd66f48979f20f8a4cbd3b14deda (patch)
tree239b275b0ac5e6e5239eb5a74e2cc716173f1b5b /sys-cluster/singularity
parentmedia-libs/freeverb3: Address departure of Audacious 3.7 (diff)
downloadgentoo-bae8b4030885dd66f48979f20f8a4cbd3b14deda.tar.gz
gentoo-bae8b4030885dd66f48979f20f8a4cbd3b14deda.tar.bz2
gentoo-bae8b4030885dd66f48979f20f8a4cbd3b14deda.zip
sys-cluster/singularity: version bump to 2.4.2
Package-Manager: Portage-2.3.13, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6773 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'sys-cluster/singularity')
-rw-r--r--sys-cluster/singularity/Manifest1
-rw-r--r--sys-cluster/singularity/singularity-2.4.2.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-cluster/singularity/Manifest b/sys-cluster/singularity/Manifest
index c7ff31c71114..75ba6269d6f0 100644
--- a/sys-cluster/singularity/Manifest
+++ b/sys-cluster/singularity/Manifest
@@ -1,2 +1,3 @@
DIST singularity-2.3.1.tar.gz 643021 BLAKE2B 4c5648330005af22515435d5daf4a27e39b79cfa52de36bdc48b63877b703329f36c81f782c1e9d8394b6668e8503961ef682d5bd71f48f665b3691df8f70a93 SHA512 36c581e8dba57d133013c2fcfea26886b54a1a9a9165b011d2cebacb2a6249fe0f8e5aa91ed90f7a18855c658300682436c431a226629408f31422cc8a036600
+DIST singularity-2.4.2.tar.gz 691214 BLAKE2B c82f48d20d0a0b6e8086e275fa1621b0e3cae5ecd515719543d69f0ba286f3c09d9fc479e8be3b78921ef32014325dcb5482d2ce813e4388db683a408d27e3a7 SHA512 2c26af6cd092bc030113cdb2a79430d82d51b7438330a6cd0706e46438296feed4d86b08d57efff0b7df148ca0e08f706b8a214f03439bccd7d196714cd06dbc
DIST singularity-2.4.tar.gz 689760 BLAKE2B 03ec88405bb1316ae3098c8ec9620f7e0dac8417b10c7d20cf0411983f0089e8e32e58a4e2ca5c4c40aeebaf044cc3d45261d5635146de6b043f33f92871a227 SHA512 b445e73d9794f344ab72ce17d8f802390d0c0c153791b837f416254eadabf19365f1abd29f0b498be5486b600f32cd7fe53e5dc131eee3465ab890c9d6b171f4
diff --git a/sys-cluster/singularity/singularity-2.4.2.ebuild b/sys-cluster/singularity/singularity-2.4.2.ebuild
new file mode 100644
index 000000000000..458dfc186eb9
--- /dev/null
+++ b/sys-cluster/singularity/singularity-2.4.2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+
+inherit autotools eutils python-single-r1
+
+DESCRIPTION="Application containers for Linux"
+HOMEPAGE="http://singularity.lbl.gov/"
+SRC_URI="https://github.com/${PN}ware/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="cctbx-2.0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples static-libs +suid"
+
+RDEPEND="
+ sys-fs/squashfs-tools:0
+"
+
+src_prepare() {
+ default
+ # automake version hardcoding
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-userns \
+ $(usex suid "" "--disable-suid") \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ MAKEOPTS+=" -j1"
+ default
+ prune_libtool_files
+ dodoc README.md CONTRIBUTORS.md CONTRIBUTING.md
+ use examples && dodoc -r examples
+}