summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-firmware/iwl1000-ucode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-firmware/iwl1000-ucode')
-rw-r--r--sys-firmware/iwl1000-ucode/Manifest2
-rw-r--r--sys-firmware/iwl1000-ucode/iwl1000-ucode-128.50.3.1.ebuild23
-rw-r--r--sys-firmware/iwl1000-ucode/iwl1000-ucode-39.31.5.1.ebuild34
-rw-r--r--sys-firmware/iwl1000-ucode/metadata.xml11
4 files changed, 70 insertions, 0 deletions
diff --git a/sys-firmware/iwl1000-ucode/Manifest b/sys-firmware/iwl1000-ucode/Manifest
new file mode 100644
index 000000000000..d34a8a92c71d
--- /dev/null
+++ b/sys-firmware/iwl1000-ucode/Manifest
@@ -0,0 +1,2 @@
+DIST iwlwifi-1000-ucode-128.50.3.1.tgz 175772 SHA256 7e81ddad18acec19364c9df22496e8afae99a2e1490b2b178e420b52d443728d
+DIST iwlwifi-1000-ucode-39.31.5.1.tgz 180879 SHA256 ed0f1fbc2571c8da9a0cd9410fa8883494a9e1ac469d5000bc2c9dceaf83c970 SHA512 18f01b51f83e133bd6803567afb75606faba8cd96e3ed4faab8350d6f63e43c4c9397fdc17631efda1606fbef9e1a2b3065cbb58779de0f56223c95703474b06 WHIRLPOOL 389031f2bb6b9f36538ea2d4893d75f9eeffb5cd01c37514ca478a2af6db0f600d050101c774d1333fd31d57b9e35d127be10cb441cbeff70e476ad28f880e41
diff --git a/sys-firmware/iwl1000-ucode/iwl1000-ucode-128.50.3.1.ebuild b/sys-firmware/iwl1000-ucode/iwl1000-ucode-128.50.3.1.ebuild
new file mode 100644
index 000000000000..9a9b6577c9ea
--- /dev/null
+++ b/sys-firmware/iwl1000-ucode/iwl1000-ucode-128.50.3.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+MY_P="iwlwifi-1000-ucode-${PV}"
+
+DESCRIPTION="Intel (R) Wireless WiFi Link 1000BGN ucode"
+HOMEPAGE="http://intellinuxwireless.org/?p=iwlwifi"
+SRC_URI="http://intellinuxwireless.org/iwlwifi/downloads/${MY_P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="3"
+KEYWORDS=""
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+src_install() {
+ insinto /lib/firmware
+ doins iwlwifi-1000-3.ucode
+ dodoc README.iwlwifi-1000-ucode
+}
diff --git a/sys-firmware/iwl1000-ucode/iwl1000-ucode-39.31.5.1.ebuild b/sys-firmware/iwl1000-ucode/iwl1000-ucode-39.31.5.1.ebuild
new file mode 100644
index 000000000000..94420d7789c2
--- /dev/null
+++ b/sys-firmware/iwl1000-ucode/iwl1000-ucode-39.31.5.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit linux-info
+
+MY_P="iwlwifi-1000-ucode-${PV}"
+DESCRIPTION="Intel (R) Wireless WiFi Link 1000BGN ucode"
+HOMEPAGE="http://intellinuxwireless.org/?p=iwlwifi"
+SRC_URI="http://intellinuxwireless.org/iwlwifi/downloads/${MY_P}.tgz"
+
+LICENSE="ipw3945"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_pretend() {
+ if kernel_is lt 2 6 39; then
+ ewarn "Your kernel version is ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}."
+ ewarn "This microcode image requires a kernel >= 2.6.39."
+ ewarn "For kernel versions < 2.6.39, you may unmask and install"
+ ewarn "${CATEGORY}/${PN}-128.50.3.1 instead."
+ fi
+}
+
+src_install() {
+ insinto /lib/firmware
+ doins iwlwifi-1000-5.ucode
+ dodoc README.iwlwifi-1000-ucode
+}
diff --git a/sys-firmware/iwl1000-ucode/metadata.xml b/sys-firmware/iwl1000-ucode/metadata.xml
new file mode 100644
index 000000000000..ca777a25adf2
--- /dev/null
+++ b/sys-firmware/iwl1000-ucode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>ulm@gentoo.org</email>
+ <name>Ulrich Mueller</name>
+</maintainer>
+<longdescription lang="en">
+ Firmware image for Intel WiFi Link 1000 series network cards
+</longdescription>
+</pkgmetadata>