summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-06-30 07:13:49 -0400
committerMike Pagano <mpagano@gentoo.org>2019-06-30 07:13:59 -0400
commit3de9b5fd09b280b9734ee1c8176ec88c1baac69a (patch)
tree4ff48eae5bd26e6f11e5f7cd94b9937a2b5b1ccb /sys-kernel/git-sources
parentmedia-libs/mlt: Fix multiple swig options enabled (diff)
downloadgentoo-3de9b5fd09b280b9734ee1c8176ec88c1baac69a.tar.gz
gentoo-3de9b5fd09b280b9734ee1c8176ec88c1baac69a.tar.bz2
gentoo-3de9b5fd09b280b9734ee1c8176ec88c1baac69a.zip
sys-kernel/git-sources: Linux patch 5.2-rc7
Signed-off-by: Mike Pagano <mpagano@gentoo.org> Package-Manager: Portage-2.3.66, Repoman-2.3.11
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.2_rc7.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 1e5de9689f6e..d54f0c4d21b7 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -5,3 +5,4 @@ DIST patch-5.2-rc3.patch 56859377 BLAKE2B 15f2fab5ef83a06efbe1a40fc1423d7c4fbd72
DIST patch-5.2-rc4.patch 60202893 BLAKE2B 0b87ff128da720388b11243143bb15daaa27db66f363a5c89034b92b0cf5eb9dcdc7f4a6fa78bde409e389600f0361ab6574e2d3eb5318dd91cec6271ff507da SHA512 ae5d8cf7ae969dc5fa30faa0b0f29c783071b45f07fa9e73768095da896a5cea7d91f5545986ea7ce659a5cd09ce861f68df75264565a10f87abde6490fc4a46
DIST patch-5.2-rc5.patch 60381150 BLAKE2B b3c86b5feadb357354ad89c24e322bd13b47d0bfe75395312115ba7f8f2edafb3d7bca3b527c63fdf9e9f40d28900900a8861536737655521f450416487c007a SHA512 6cb7282c7f715fcf1c8042ff0e4f33cda5baf69f635fdce49bc6271b7b07dce9e63a7104e44be91402955b20da5617ef0c979907a1007e1fbc4b492f15c93690
DIST patch-5.2-rc6.patch 64104387 BLAKE2B 67e56b7074e355b795fb0b1453f1b8d0835737fb08022e755a407253fd4cec4aa5b395920983aa6c59258a11aa5fead544570a48a48b24378fccd81e51754bbd SHA512 6c5c5a7d40a41919dde7d518feadfb9d2af49ec82013135e64b4d767839c31e9da3a570469a1293b75eb0dcbda31906f5087bfaf9145018b706b34fd9e89c70c
+DIST patch-5.2-rc7.patch 64215113 BLAKE2B 85c33f7e2e5dbf7071288486d87df9bcbffea3413925f18ba60666548ba2fbb4caf7f2531194819098888875397f17ca38c5d4394cb25798e25347d93351923f SHA512 e51f223becfdbd22ea9aa4a06ddd09d14e1e7898d7e4858bcf5cc1ffa46346ac9b07f9b3c45118aa282f56a9ae9d6668fc3a740f927dd3126c3e54a08e9962d3
diff --git a/sys-kernel/git-sources/git-sources-5.2_rc7.ebuild b/sys-kernel/git-sources/git-sources-5.2_rc7.ebuild
new file mode 100644
index 000000000000..8509b233b0a2
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.2_rc7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.1"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}