summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2019-08-18 18:04:40 -0400
committerMike Pagano <mpagano@gentoo.org>2019-08-18 18:04:52 -0400
commit43259e1ba3815be6a130d0e33a22155384a28ba0 (patch)
treed6ff39f216e1da6a3b000ad1be78b987f010708f /sys-kernel/git-sources
parentsys-apps/hwids: bump to 20190818 (diff)
downloadgentoo-43259e1ba3815be6a130d0e33a22155384a28ba0.tar.gz
gentoo-43259e1ba3815be6a130d0e33a22155384a28ba0.tar.bz2
gentoo-43259e1ba3815be6a130d0e33a22155384a28ba0.zip
sys-kernel/git-sources: Linux patch 5.3-rc5
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'sys-kernel/git-sources')
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.3_rc5.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index f6a38e521db7..695777528d78 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -3,3 +3,4 @@ DIST patch-5.3-rc1.patch 92211979 BLAKE2B 984990a073e8c2fed14078f10b97143d387af8
DIST patch-5.3-rc2.patch 94028243 BLAKE2B 872fbe722cdc38f2a7799ea56cfa7916095d921cec841df4420b1409c2e0447e44e00cd0613e695605fd56eae24cec901b526270cf1d2616c49b937a803110cd SHA512 d3ec6cc0d4062a448a0e7470e86910d6d114b262d8dc8fa88d4e010e9a2ed6a4b1342afe49c5851121577a1b2ce83344f511157d09f339de8b3f96caaf7d2ec5
DIST patch-5.3-rc3.patch 94324876 BLAKE2B e68fbf8b24b1c8b0a0b5c751ef1b13eedd338db0dcb1060a155e09888ec6f3a60a8a64259bfe6888dc09e818bd12e4559447f8b00d6d9d94681a05ea9bae9dff SHA512 b9e3ac03827d9cc1b0c63ecf29c94f34494fae4f2a2cb6f77dfda04aa0798b2ee3b8d5251bdd95e7fa7665755dc3f7950f31009ddb4f085b4642cb8074c91c36
DIST patch-5.3-rc4.patch 94800817 BLAKE2B 3998bbc5c0147cb759920052e60b391e53cf73ca1d3e3dc1abe541b630fca18cc0b768b777beb5f8fe53b537464ef109a6e58a85291930fa16b3b1569b16181d SHA512 a9cb59ecb1b2f8e622c8debfeb1073127d2891e7f6790aa902e4c20de0cad9ac5a09ce652364d8792249c69b41be0ba8d0bdd7141ea0175e9c76e62a3acaba7f
+DIST patch-5.3-rc5.patch 94949483 BLAKE2B 656d9c20de02f6203ba1d5b011f6cbfdca8a953905880287e1d645da1cb5851fd7422c7f9ed00c6487b03b578fa1ef08f9745771b8436ce06710a54e7e2375e9 SHA512 2736a8228ecda89948ac4df91eb3b930f76da442ae14ff72155048d9db048d7a4a0b3b25a5f83f06cd8d1b87abdd82cce5f3e6d5c575db6d9df72a029c7c3b3b
diff --git a/sys-kernel/git-sources/git-sources-5.3_rc5.ebuild b/sys-kernel/git-sources/git-sources-5.3_rc5.ebuild
new file mode 100644
index 000000000000..71a45a3201b9
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.3_rc5.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.2"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.5"
+
+pkg_postinst() {
+ postinst_sources
+}