summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-11-14 20:50:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-14 20:50:47 +0200
commit4817001e4cddf6224d5c850840f4dee672d6d8b5 (patch)
tree21f4d9373c9c4c3e41d9c549369e24a315151eb2 /sys-kernel/pf-sources
parentkde-frameworks/extra-cmake-modules: Fix tests (diff)
downloadgentoo-4817001e4cddf6224d5c850840f4dee672d6d8b5.tar.gz
gentoo-4817001e4cddf6224d5c850840f4dee672d6d8b5.tar.bz2
gentoo-4817001e4cddf6224d5c850840f4dee672d6d8b5.zip
sys-kernel/pf-sources: bump to 5.3-pf8
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.3_p8.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index acefbdc9bfce..f3fafe7b08a5 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -15,3 +15,4 @@ DIST pf-sources-5.3_p3.patch 980797 BLAKE2B 96bd53791737fcb1d1503b719a8654a90bd9
DIST pf-sources-5.3_p4.patch 1340441 BLAKE2B fe979e8511d6bfa481749e50d8f4f2edc8016477de4edc644cd57015b0568c9948e7643871642ce67a5a9250294e3981951b87a3f60161ceec6232c206031349 SHA512 879991193cd6fd77f17f5fafbfd6172528837c57014a6d220d37cc57cd9bd51ebae9d7687762eb972cea16c37f7e48d440d9d55e7f4532ec09f218cf7a2cac4c
DIST pf-sources-5.3_p5.patch 1596810 BLAKE2B ba0229daedb6e883192fc3de569601bc2284dfdb012c4a46b7367772aec07570b826e9fb23725b68deac2a35613c44c83ae587dfb2d4787ef5bba39b995535b5 SHA512 7524528d02f4d593eae506c055c414f28875ee3f32334cf420ad4357e41fb8dbd0b3801d98676ca624566351145fde032c1ff8a25f762aa058c9558ffdf014cd
DIST pf-sources-5.3_p6.patch 2032026 BLAKE2B 5384f2196b3799861e79ab223a1370f4049b86f0cc201d2ab09d31127e08fff3de0b2403693046b5f7a5f73750e12f027f30a5897ca6e457f0fac760bf0b8c6f SHA512 31b5e1d7bfe934a7733f81b663f8022b3c292acda3cef982ca4e56fee0a1df151e58c4a8e3af3d9a85927cac773add4492f5be369526308f665c3bafb629e936
+DIST pf-sources-5.3_p8.patch 2445607 BLAKE2B d1aa017f43219f661d16e82f9f36ef5b526aad8492f0bb758abda6c1d2caf2d07ed98fd444819dbcc64718c41f0e90b4f18969cafcf02737f1893d92514a49d5 SHA512 033d92493b54fa8bb231f168357cf3b65a7b858e75e04c24a6e97d0dbced7baa8b49cdaec11e4e4b3f2eb44de80a33780511785827dab0893dc1721d47085483
diff --git a/sys-kernel/pf-sources/pf-sources-5.3_p8.ebuild b/sys-kernel/pf-sources/pf-sources-5.3_p8.ebuild
new file mode 100644
index 000000000000..82d79915f607
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.3_p8.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+ETYPE="sources"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${PF_URI}
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+ "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}