summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-10-01 22:09:57 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-10-01 22:11:26 +0300
commit5aefba7cf065eb19211241b95e82a5e68a798fa0 (patch)
tree6d267631f44e7ac0525193fa39d7187d3bb32e68 /sys-kernel/pf-sources
parentdev-php/pecl-apcu: Drop old (diff)
downloadgentoo-5aefba7cf065eb19211241b95e82a5e68a798fa0.tar.gz
gentoo-5aefba7cf065eb19211241b95e82a5e68a798fa0.tar.bz2
gentoo-5aefba7cf065eb19211241b95e82a5e68a798fa0.zip
sys-kernel/pf-sources: bump to 5.3-pf2
Package-Manager: Portage-2.3.76, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.3_p2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 4e0fce0425d5..0e80047233bc 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -17,3 +17,4 @@ DIST pf-sources-5.2_p6.patch 1777289 BLAKE2B 11a913546dcd8a4ad39b4b924aa085bdf0b
DIST pf-sources-5.2_p7.patch 2142830 BLAKE2B 000e4f464b8d81e0ec767b6cfde56f001f51ed39c90d4dcb3c962460bf0fc184334cd631e9c05e26a0e49814665aad88df066f87f04cc3dee3f42a806d405d7d SHA512 2532cf8d6278321a6b757fca4e5405164ff3fe9349059f5f0983bcf302de2ea0a46a4c70c5cc2af185083050cb086a85be5fffb6104fb2df8f396af822dc841b
DIST pf-sources-5.2_p8.patch 2328455 BLAKE2B 425b0a04800db70b060c8b18ae4f8e99a7af12cf8053604361b34b0c6c759cefcad6d1ba4d241729fbbb12ef5fa4c034d904c14219bd3c7a18dc9e616f148f43 SHA512 4f021b1051391a9a582e86ab898f1fbdf867b8573d6861f25932e5bef2baae4234be5caac93cfc87656bc5c4fc2bf179906b7ce12e0c267245e5efeaa63605bd
DIST pf-sources-5.3_p1.patch 253654 BLAKE2B f1d4cd4a1d2ad78a918a540c79ec2a7c15c35788c654829d98d5fcfdd9fa13656dcc83dd0f1d34d03f1aa8e0fc6ad1c55d50faf290705bc0d7d296a1ce12ce08 SHA512 951a3bf95962c4e22adb5f59c21a7f367ed734e4d2c1140cee6c9daabd396c0ea322ca6da364fb9682188a3e7eba1f9cbd62523a863399ab8e441f390e9597fb
+DIST pf-sources-5.3_p2.patch 317339 BLAKE2B 7e5f8c3a2cd7f2fae4b038c8178c1d0943b1224fd4898aab6a546fadf7b091177c6d3ce99ffe6bcf298405d9354064aca78695f608c6d695bbb287752e8e9f4b SHA512 8c0c4dabb6925ab6fa1a9379035fcbac9587737be938e13bf0059fa5e55f79ef7f8800f1568dd1192e63e377e832ad628127b239ffc96b06699ee413d7a884f8
diff --git a/sys-kernel/pf-sources/pf-sources-5.3_p2.ebuild b/sys-kernel/pf-sources/pf-sources-5.3_p2.ebuild
new file mode 100644
index 000000000000..82d79915f607
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.3_p2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+ETYPE="sources"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${PF_URI}
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+ "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}