summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-09-01 14:18:02 +0300
committerJoonas Niilola <juippis@gentoo.org>2019-09-01 14:18:56 +0300
commit8f5bedf05782eea8fbf0ee4aab3afdc298367e18 (patch)
treec55cc34614217d433db3cc8ea0bfbcd9643a9795 /sys-kernel/pf-sources
parentnet-dns/bind: use relative paths for symlinks (diff)
downloadgentoo-8f5bedf05782eea8fbf0ee4aab3afdc298367e18.tar.gz
gentoo-8f5bedf05782eea8fbf0ee4aab3afdc298367e18.tar.bz2
gentoo-8f5bedf05782eea8fbf0ee4aab3afdc298367e18.zip
sys-kernel/pf-sources: bump to 5.2-pf7
Package-Manager: Portage-2.3.74, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-kernel/pf-sources')
-rw-r--r--sys-kernel/pf-sources/Manifest1
-rw-r--r--sys-kernel/pf-sources/pf-sources-5.2_p7.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/sys-kernel/pf-sources/Manifest b/sys-kernel/pf-sources/Manifest
index 13396b8726fa..0bb076cd08d5 100644
--- a/sys-kernel/pf-sources/Manifest
+++ b/sys-kernel/pf-sources/Manifest
@@ -11,3 +11,4 @@ DIST pf-sources-5.2_p3.patch 1101135 BLAKE2B f56ff7a269e48513ac2d8360531eef0b60b
DIST pf-sources-5.2_p4.patch 1370761 BLAKE2B 54a489784bdfa42879931eb5f05d4ee91bccb9b8b755bc4a3a1221259f5d16df12b1bb240518f8ee86b93383f8ec2f5eb29541548c5d4ca6d4d3aa41b1b92dc2 SHA512 4489218cd370cb38cda5c79b05d26e7150ac8ce97eaf0a03013743f9507fff82cd1024e0f95e226bd5d1f3c4741a5ab8934002e4a0c0e13fc2666513b41b6491
DIST pf-sources-5.2_p5.patch 1632051 BLAKE2B 71fe6365e1e8fee65480bc3b6081f410516dcd6cecdffe0ad03b95c63b8aa2f59dc7357190aa49d9c10637ef7ae5516588c27140afe594eaa1282f565ea4bf70 SHA512 27eff105625ce917e009d5e29ba991682731bb6b7e77ae16948456b820a78271ca666634ee30ef6ebf7d8d1dd13aa9999dfc68acead55eaecca4081746cbba5f
DIST pf-sources-5.2_p6.patch 1777289 BLAKE2B 11a913546dcd8a4ad39b4b924aa085bdf0b711cfe8f8697efe3983a09afe4ce377e6ab61730be115617645e0c32be3970b2c4c60de3beb1e2580c560da9561d4 SHA512 5af6631d86c59e076ba9d48bd866b8aaa1903b9d29b4e478ca328cc6352bc0b4f8b0d41f54f750f2ba03bc6a0cf6a9925a795965e051f4ef77fafba2da18bf8d
+DIST pf-sources-5.2_p7.patch 2142830 BLAKE2B 000e4f464b8d81e0ec767b6cfde56f001f51ed39c90d4dcb3c962460bf0fc184334cd631e9c05e26a0e49814665aad88df066f87f04cc3dee3f42a806d405d7d SHA512 2532cf8d6278321a6b757fca4e5405164ff3fe9349059f5f0983bcf302de2ea0a46a4c70c5cc2af185083050cb086a85be5fffb6104fb2df8f396af822dc841b
diff --git a/sys-kernel/pf-sources/pf-sources-5.2_p7.ebuild b/sys-kernel/pf-sources/pf-sources-5.2_p7.ebuild
new file mode 100644
index 000000000000..82d79915f607
--- /dev/null
+++ b/sys-kernel/pf-sources/pf-sources-5.2_p7.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+ETYPE="sources"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+HOMEPAGE="https://gitlab.com/post-factum/pf-kernel/wikis/README
+ https://dev.gentoo.org/~mpagano/genpatches/"
+
+IUSE=""
+
+# No 'experimental' USE flag provided, but we still want to use genpatches
+K_EXP_GENPATCHES_NOUSE="1"
+
+# No reason to bump this number unless something new gets included in genpatches,
+# in that case we can manually remove the linux kernel patches from genpatches.
+K_GENPATCHES_VER="1"
+
+K_NOSETEXTRAVERSION="1"
+
+# Not supported by the Gentoo security crew
+K_SECURITY_UNSUPPORTED="1"
+
+K_USEPV="yes"
+
+# We want the very basic patches from gentoo-sources, experimental patch
+# is already included in pf-sources
+K_WANT_GENPATCHES="base extras"
+
+UNIPATCH_STRICTORDER="yes"
+
+inherit eutils kernel-2
+detect_version
+
+DESCRIPTION="Linux kernel fork that includes the pf-kernel patchset and Gentoo's genpatches"
+
+PF_URI="https://github.com/pfactum/pf-kernel/compare/v${PV/_p*/}...v${PV/_p*/}-pf${PV/*_p/}.diff -> ${P}.patch"
+SRC_URI="
+ ${KERNEL_URI}
+ ${PF_URI}
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.base.tar.xz
+ https://dev.gentoo.org/~mpagano/genpatches/tarballs/genpatches-${PV/_p*/}-${K_GENPATCHES_VER}.extras.tar.xz
+"
+
+KV_FULL="${PVR}-pf"
+S="${WORKDIR}/linux-${KV_FULL}"
+
+PATCHES=(
+ "${DISTDIR}/${P}.patch"
+)
+
+K_EXTRAEINFO="For more info on pf-sources and details on how to report problems,
+see: ${HOMEPAGE}."
+
+pkg_setup(){
+ ewarn
+ ewarn "${PN} is *not* supported by the Gentoo Kernel Project in any way."
+ ewarn "If you need support, please contact the pf developers directly."
+ ewarn "Do *not* open bugs in Gentoo's bugzilla unless you have issues with"
+ ewarn "the ebuilds. Thank you."
+ ewarn
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ kernel-2_pkg_postinst
+ optfeature "Userspace KSM helper" sys-process/uksmd
+}