summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorYixun Lan <dlan@gentoo.org>2024-08-23 11:57:22 +0000
committerYixun Lan <dlan@gentoo.org>2024-08-23 12:01:03 +0000
commit19f0705c6e86b660f36609753f3565c17953af26 (patch)
treef7ddaf466601495398d0468561478ce3ff2ab7b5 /sys-power
parentapp-emulation/virtualbox-extpack-oracle: add 7.1.0_beta2, drop 7.1.0_beta1 (diff)
downloadgentoo-19f0705c6e86b660f36609753f3565c17953af26.tar.gz
gentoo-19f0705c6e86b660f36609753f3565c17953af26.tar.bz2
gentoo-19f0705c6e86b660f36609753f3565c17953af26.zip
sys-power/thermald: add 2.5.8
Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/thermald/Manifest1
-rw-r--r--sys-power/thermald/thermald-2.5.8.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/sys-power/thermald/Manifest b/sys-power/thermald/Manifest
index 45a3e78fd27a..d7fe303aa967 100644
--- a/sys-power/thermald/Manifest
+++ b/sys-power/thermald/Manifest
@@ -1 +1,2 @@
DIST thermald-2.5.7.tar.gz 182761 BLAKE2B d812e1a7e0b55dd5d06ff491183ad0061acb79d2c80a6a248456821676bd3728e28a5d6b23d8fe2565ca8424830f095de8595e85bdfc514f17418af50d7e7284 SHA512 49699eb2a3f3d1197e680a39ecba767a1f11a5d4209671d30152f1e126f7c48b650909c4dd90c496a7857b0fa9ad6fc8c5a849413a8e544b3d5f62d8acfc8268
+DIST thermald-2.5.8.tar.gz 179188 BLAKE2B a00844e0147fdb104881624ba1ecbaa565155e4554b218b04b0edd4434f552e2bcc047e6eaada30b0e63b702a75318392ef8c39a8013003377c3e9ee80e694ab SHA512 d74d487e0fa0b51289b4cda2d9094eef6467993a8ca9ba5e2ac8af2fb8e7b9283116ca0647e604ab4d3c445657b31869201287d5ceace0221f7717b0a2cd244d
diff --git a/sys-power/thermald/thermald-2.5.8.ebuild b/sys-power/thermald/thermald-2.5.8.ebuild
new file mode 100644
index 000000000000..6f4162a4d8a5
--- /dev/null
+++ b/sys-power/thermald/thermald-2.5.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info out-of-source systemd
+
+DESCRIPTION="Thermal daemon for Intel architectures"
+HOMEPAGE="https://github.com/intel/thermal_daemon"
+SRC_URI="https://github.com/intel/thermal_daemon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/thermal_daemon-${PV}
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/glib:=
+ dev-libs/libxml2:=
+ dev-libs/libevdev
+ sys-power/upower
+ sys-apps/dbus:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc
+ dev-util/glib-utils"
+
+DOCS=( thermal_daemon_usage.txt README.txt )
+
+CONFIG_CHECK="~PERF_EVENTS_INTEL_RAPL ~X86_INTEL_PSTATE ~INTEL_POWERCLAMP ~INT340X_THERMAL ~ACPI_THERMAL_REL ~INT3406_THERMAL"
+
+src_prepare() {
+ sed -i -e '/tdrundir/s@\$localstatedir/run@\$runstatedir@' \
+ configure.ac || die
+
+ sed -i -e 's@\$(AM_V_GEN) glib-compile-resources@cd \$(top_srcdir) \&\& &@' \
+ Makefile.am || die
+
+ default
+ eautoreconf
+}
+
+my_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-werror \
+ --runstatedir="${EPREFIX}"/run \
+ --with-dbus-power-group=wheel \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)"
+}
+
+my_src_install_all() {
+ einstalldocs
+
+ rm -rf "${ED}"/etc/init || die
+ doinitd "${FILESDIR}"/thermald
+}