summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-04-15 16:41:21 +0200
committerJohannes Huber <johu@gentoo.org>2018-04-15 16:42:58 +0200
commit0971097e3628246b11917f77bde950f2ecf22722 (patch)
tree45bf3910a5d5011fc2b9417a3a8aafe12a252536 /www-apache
parentx11-libs/qscintilla: stable 2.10.3 for ppc, bug #652648 (diff)
downloadgentoo-0971097e3628246b11917f77bde950f2ecf22722.tar.gz
gentoo-0971097e3628246b11917f77bde950f2ecf22722.tar.bz2
gentoo-0971097e3628246b11917f77bde950f2ecf22722.zip
www-apache/mod_fastcgi_handler: Revision bump, EAPI 6
Bug: https://bugs.gentoo.org/652788 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r1.ebuild b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r1.ebuild
new file mode 100644
index 000000000000..1da963f79758
--- /dev/null
+++ b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+GITHUB_AUTHOR="hollow"
+GITHUB_PROJECT="mod_fastcgi_handler"
+GITHUB_COMMIT="c5e075b"
+inherit apache-module
+
+DESCRIPTION="A simple FastCGI handler module"
+HOMEPAGE="https://github.com/hollow/mod_fastcgi_handler"
+SRC_URI="https://nodeload.github.com/${GITHUB_AUTHOR}/${GITHUB_PROJECT}/tarball/v${PV} -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+S="${WORKDIR}"/${GITHUB_AUTHOR}-${GITHUB_PROJECT}-${GITHUB_COMMIT}
+
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="FASTCGI_HANDLER"
+
+APXS2_ARGS="-o ${PN}.so -c *.c"
+
+need_apache2