summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-09-06 10:42:31 -0400
committerCraig Andrews <candrews@gentoo.org>2019-09-06 10:43:06 -0400
commitc96c2de5113e1c6d4741c4c1f9df4256e7210bc2 (patch)
tree2e0eb74514ab1d8405d850c6264a5824f88fa78f /www-apache
parentmail-client/thunderbird: adjust media-libs/libvpx version constraint (diff)
downloadgentoo-c96c2de5113e1c6d4741c4c1f9df4256e7210bc2.tar.gz
gentoo-c96c2de5113e1c6d4741c4c1f9df4256e7210bc2.tar.bz2
gentoo-c96c2de5113e1c6d4741c4c1f9df4256e7210bc2.zip
www-apache/mod_authz_unixgroup: An Apache2 authorization DSO using unix groups
Closes: https://bugs.gentoo.org/693592 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_authz_unixgroup/Manifest1
-rw-r--r--www-apache/mod_authz_unixgroup/files/10_mod_authz_unixgroup.conf11
-rw-r--r--www-apache/mod_authz_unixgroup/metadata.xml11
-rw-r--r--www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0.ebuild32
-rw-r--r--www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild32
5 files changed, 87 insertions, 0 deletions
diff --git a/www-apache/mod_authz_unixgroup/Manifest b/www-apache/mod_authz_unixgroup/Manifest
new file mode 100644
index 000000000000..286d71e1270e
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/Manifest
@@ -0,0 +1 @@
+DIST mod_authz_unixgroup-1.1.0.tar.gz 10085 BLAKE2B d7948cf046d58bcf27dfd4310a69ea61395d75f67c782fdbeb3f96015b7df8abebb7c59a244efe37a20e42ed72b501cd757346812144cd66a1cae8dabbd62a42 SHA512 83c767b2eb903964e688658bc4ae4384afd14c99f714c9aafb8c5bdddc855511e0b81f3499411b401865e42028b587dbba4ea2eb5123fe32ac91899327d6bbb8
diff --git a/www-apache/mod_authz_unixgroup/files/10_mod_authz_unixgroup.conf b/www-apache/mod_authz_unixgroup/files/10_mod_authz_unixgroup.conf
new file mode 100644
index 000000000000..dd942a8dd791
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/files/10_mod_authz_unixgroup.conf
@@ -0,0 +1,11 @@
+<IfDefine AUTHZ_UNIXGROUP>
+LoadModule authz_unixgroup_module modules/mod_authz_unixgroup.so
+
+# For UNIX group check
+# Require unix-group staff admin
+# This would allow only access to accounts in the 'staff' or 'admin' unix groups.
+# You can alternately specify groups by their gid numbers instead of their names.
+</IfDefine>
+
+# vim: ts=4 filetype=apache
+
diff --git a/www-apache/mod_authz_unixgroup/metadata.xml b/www-apache/mod_authz_unixgroup/metadata.xml
new file mode 100644
index 000000000000..38b26aa08657
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>candrews@gentoo.org</email>
+ <name>Craig Andrews</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phokz/mod-auth-external</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0.ebuild b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0.ebuild
new file mode 100644
index 000000000000..7c9081bf3575
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-1.1.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit apache-module
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/phokz/mod-auth-external.git"
+ inherit git-r3
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/phokz/mod-auth-external/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/mod-auth-external-${P}"
+fi
+
+DESCRIPTION="An Apache2 authorization DSO using unix groups"
+HOMEPAGE="https://github.com/phokz/mod-auth-external"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+need_apache2_4
+
+DOCFILES="CHANGES INSTALL README NOTICE"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHZ_UNIXGROUP"
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}
diff --git a/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild
new file mode 100644
index 000000000000..7c9081bf3575
--- /dev/null
+++ b/www-apache/mod_authz_unixgroup/mod_authz_unixgroup-9999.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit apache-module
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/phokz/mod-auth-external.git"
+ inherit git-r3
+ S="${WORKDIR}/${P}/${PN}"
+else
+ SRC_URI="https://github.com/phokz/mod-auth-external/archive/${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/mod-auth-external-${P}"
+fi
+
+DESCRIPTION="An Apache2 authorization DSO using unix groups"
+HOMEPAGE="https://github.com/phokz/mod-auth-external"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+need_apache2_4
+
+DOCFILES="CHANGES INSTALL README NOTICE"
+
+APACHE2_MOD_CONF="10_${PN}"
+APACHE2_MOD_DEFINE="AUTHZ_UNIXGROUP"
+
+pkg_setup() {
+ _init_apache2
+ _init_apache2_late
+}