summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-12-19 16:41:50 -0500
committerCraig Andrews <candrews@gentoo.org>2019-12-19 16:43:13 -0500
commitf0f1140529be96b85ff7d0023b32ad1afc84f416 (patch)
tree07b080c583c9de137a4e2a8338fc3f9740588294 /www-apache
parentdev-python/sphinx/sphinx-2.0.1: python 3.8 support added. (diff)
downloadgentoo-f0f1140529be96b85ff7d0023b32ad1afc84f416.tar.gz
gentoo-f0f1140529be96b85ff7d0023b32ad1afc84f416.tar.bz2
gentoo-f0f1140529be96b85ff7d0023b32ad1afc84f416.zip
www-apache/mod_h2: 1.15.5 version bump
Package-Manager: Portage-2.3.82, Repoman-2.3.20 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'www-apache')
-rw-r--r--www-apache/mod_h2/Manifest1
-rw-r--r--www-apache/mod_h2/mod_h2-1.15.5.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/www-apache/mod_h2/Manifest b/www-apache/mod_h2/Manifest
index 8756f60f578f..674929e81b0b 100644
--- a/www-apache/mod_h2/Manifest
+++ b/www-apache/mod_h2/Manifest
@@ -11,3 +11,4 @@ DIST mod_http2-1.15.1.tar.gz 1026120 BLAKE2B 724d09bfafc2fe6a288eeebd7fbdcbe2c3d
DIST mod_http2-1.15.2.tar.gz 1037495 BLAKE2B a6e1afcea50034affc2d505445f0227688a448ef1979de19df42db2e277ba0b1904f249bc55a114901039ce503d164bde92d70d69e70ddf03e3708ee5dd96233 SHA512 c919e9cd2a959d3ccde697424dc40580d52a2620ee476fc675b9f30a030044c2f9872b282e4ab08d4d576c0c7ee08ca2baad5a1d9a456dbd6c007cfef9fca6b3
DIST mod_http2-1.15.3.tar.gz 1039368 BLAKE2B 79016846a66b27698343621a9cde23746b5408e1c328c578562f0ad300337d7eedc9b1fbcd680be671c6b428aded48969c688df9a6fde7856546c8ab198584cc SHA512 e6d4051a7fd6f27202951ac6a3c0ecd282e0bc3a086d319463effd031f4acff32599a8b0958ed75d31299585b90fe227ac5cbbf28ded0bf93175d8a1cefbdd00
DIST mod_http2-1.15.4.tar.gz 1041291 BLAKE2B e59157b91551864f4934601373c494485cc202e077acfd51fb2efb8c7afffef4bb1b36097ae9ad1ed069fcac07cdd7116488743910cfc6a756982857dd7b0161 SHA512 c5d8fc4f8d869bff349c9de2101054aebb0eda7698ccee6e8125ec87b10a0663e5d2dd142d689c2487065b3fd0a1d166b9dc8295b35e39f5801fb330f8e7dff0
+DIST mod_http2-1.15.5.tar.gz 1041643 BLAKE2B 59591d919451a96595c8e75155f84e63876e95b13940af5473fe4cf0a29ac91f57d3df22911397de213482c5a81d093ce81ce3835136ace50de0d4f70f2a936a SHA512 6255a46a22e5df6f8fed9ce65079979a3c613cccf1a95559ff0832ab2efe5fb98d51abfe83c006b9a3c7452bb4e78e3e67e94d7c14618fa312c7236a34e6b280
diff --git a/www-apache/mod_h2/mod_h2-1.15.5.ebuild b/www-apache/mod_h2/mod_h2-1.15.5.ebuild
new file mode 100644
index 000000000000..3e6d435d3f82
--- /dev/null
+++ b/www-apache/mod_h2/mod_h2-1.15.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+ inherit git-r3
+else
+ S="${WORKDIR}/${MY_P}"
+ SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+ >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_compile() {
+ default
+}
+
+src_install() {
+ default
+
+ APACHE2_MOD_DEFINE="HTTP2"
+ insinto "${APACHE_MODULES_CONFDIR}"
+ newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}