summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-11-12 19:00:50 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2018-11-12 19:01:14 -0100
commitf2ba9a020ff077a8d9abc6de7cacebc6db636181 (patch)
tree0dc3666b2041736521ddb3a904f1a155a7eb066b /www-apps
parentsys-apps/util-linux: 2.33 Fix copyright for compliance with glep 76 (diff)
downloadgentoo-f2ba9a020ff077a8d9abc6de7cacebc6db636181.tar.gz
gentoo-f2ba9a020ff077a8d9abc6de7cacebc6db636181.tar.bz2
gentoo-f2ba9a020ff077a8d9abc6de7cacebc6db636181.zip
www-apps/drupal: Bump to 7.61 release.
Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org> Package-Manager: Portage-2.3.50, Repoman-2.3.11
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-7.61.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index 6f0dc8faf57e..4377b1f428e6 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -1,3 +1,4 @@
DIST drupal-7.60.tar.gz 3283058 BLAKE2B 2c29c089e0e13ce52c5d7a0bbf72c79596fbdc1a370a60b33d617ab29f2aaec86e36545ced7620832f333de66bb775178f7eeeca80976d6e2616553b766c07b3 SHA512 fee59cf303a6c44e3fa3cbeda4912f7d61ffe8294282f9ad0416a6536cc6ea65cf114a6a801dd1f68572185c2b1e300f58f907f9bd61f96beaba3706c527d512
+DIST drupal-7.61.tar.gz 3287629 BLAKE2B 635fca54063bf3030cd3699f2395c64a4949719b38ad51e1ae67de928a0177bb8c049f383245ecd1ebf1d8dfe4dc1be012c0d83bd50eada8b05a959fd160d4ac SHA512 8f0bdd5b7ef33e62d09698b3889726fab1edb14df6263635bca65c9bbe0400df618dbf02ef298eeee169d48ab554d3b58d867bd4ce0d429b4b9167979917db51
DIST drupal-8.6.2.tar.gz 16240694 BLAKE2B 122ff2464af6376256d96db8b470cf5f83beeba80a5c63e549e7eb0cfc875629d0b2d4ed46b130294e2145ea5a428b15cfa0edfcd31596660188df769b68bcd2 SHA512 8cdcd31f3a112a577e622cca0fb7957580b5691102421344c6f6bfc3096f33aae3a68d7d8eb9062ad14761bac14b68c2967973b1b1ef367dcbd79b972493b7c5
DIST drupal-8.6.3.tar.gz 16372220 BLAKE2B b9bbf18e25292bfa87f23e2aa2329f86dfe714a265188c35998059b0075f31ceb6d0d6a23ed576615b1a6a6aef6b935a495e70b22aed0e649b41b79994bc9123 SHA512 93284235c9620ed235bfe0100317846694095ca96b1da7ac402c415e9f5f0819887c4da516655dabb49b4bbdba58935d7f78712c525c803125ec27d6a5692cea
diff --git a/www-apps/drupal/drupal-7.61.ebuild b/www-apps/drupal/drupal-7.61.ebuild
new file mode 100644
index 000000000000..6f40a8c2e6ea
--- /dev/null
+++ b/www-apps/drupal/drupal-7.61.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+IUSE="+accelerator +mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash,pdo,postgres?,simplexml,xml]
+ virtual/httpd-php
+ accelerator? ( ||
+ (
+ dev-php/xcache
+ (
+ >=dev-lang/php-5.5[opcache]
+ dev-php/pecl-apcu
+ )
+ )
+ )
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+ mysql? (
+ || (
+ dev-lang/php[mysql]
+ dev-lang/php[mysqli]
+ )
+ )
+ sqlite? ( dev-lang/php[sqlite] )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}