summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-02-09 13:34:59 +0100
committerJeroen Roovers <jer@gentoo.org>2020-02-09 13:37:06 +0100
commitc151c61dd8ed40011226b5470eaeb87273192103 (patch)
tree87df89a78147216c45e10b40c39d2364931e350e /www-client/dillo
parentx11-themes/gtk-engines: drop to ~hppa (diff)
downloadgentoo-c151c61dd8ed40011226b5470eaeb87273192103.tar.gz
gentoo-c151c61dd8ed40011226b5470eaeb87273192103.tar.bz2
gentoo-c151c61dd8ed40011226b5470eaeb87273192103.zip
www-client/dillo: Version 3.1_p20181005
Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'www-client/dillo')
-rw-r--r--www-client/dillo/Manifest1
-rw-r--r--www-client/dillo/dillo-3.1_p20181005.ebuild66
-rw-r--r--www-client/dillo/metadata.xml3
3 files changed, 70 insertions, 0 deletions
diff --git a/www-client/dillo/Manifest b/www-client/dillo/Manifest
index 2f5ad7a39c15..120e924472d4 100644
--- a/www-client/dillo/Manifest
+++ b/www-client/dillo/Manifest
@@ -1,2 +1,3 @@
DIST dillo-3.0.5.tar.bz2 734472 BLAKE2B c8a7ac3a875740d2d64269b0d368e6f9395c89a56737dda9d6dcb013f5d46631e4f6f68e251f7104c0ec9bbb14bcc10b67a7f519558f857743d7cf15976f197c SHA512 d0e86f57e50da762debf592b6deb94de5ee58f84e0cae1159890262540a463aea8143d2b99c634021c1f273f91c2fe0918f30d72c3eaf91fdb541e741469b155
+DIST dillo-3.1_p20181005.tar.xz 907520 BLAKE2B 1349ca1de53b294b5c31088ce36b3f9a86c3e628cfce41fa4fcfa30a3b4d9ed05b0be836fbc2ea2f2c37fce3ff28b17766d0717949d1ec66430149049751fa50 SHA512 1accbf200bd17a04d3b758037e11b0c21924c93d7857fa5c880af471cf180d45d5c772c6d800b4b899cf5b43bde640d28b37ce82fcf6b916c9adee5800e57d29
DIST dillo.png 6135 BLAKE2B 63aa76000934123420d0704317309639bf5dcd22c61b09406a7ec67018b17044a417209954d67f22e2000b0871d315a25388bacffab9599230fc9615877a2f08 SHA512 cfc9bcf1bfd0fff7fc625c7d288c92d0f33418b963a4e344844fd2bcb33823b3215a8a1a86162dcd1c614eea2323bb361c11bd8bd15859b771c63943c1b40833
diff --git a/www-client/dillo/dillo-3.1_p20181005.ebuild b/www-client/dillo/dillo-3.1_p20181005.ebuild
new file mode 100644
index 000000000000..80b643685578
--- /dev/null
+++ b/www-client/dillo/dillo-3.1_p20181005.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools desktop toolchain-funcs
+
+DESCRIPTION="Lean FLTK based web browser"
+HOMEPAGE="https://www.dillo.org/"
+SRC_URI="
+ https://dev.gentoo.org/~jer/${P}.tar.xz
+ mirror://gentoo/${PN}.png
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc +gif ipv6 +jpeg +png ssl +xembed"
+
+RDEPEND="
+ >=x11-libs/fltk-1.3
+ sys-libs/zlib
+ jpeg? ( virtual/jpeg:0 )
+ png? ( >=media-libs/libpng-1.2:0 )
+ ssl? ( net-libs/mbedtls:= )
+"
+DEPEND="
+ ${RDEPEND}
+ doc? ( app-doc/doxygen )
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}2-inbuf.patch
+ "${FILESDIR}"/${PN}-3.0.5-fno-common.patch
+)
+DOCS="AUTHORS ChangeLog README NEWS doc/*.txt doc/README"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable gif) \
+ $(use_enable ipv6) \
+ $(use_enable jpeg) \
+ $(use_enable png) \
+ $(use_enable ssl) \
+ $(use_enable xembed) \
+ --docdir="/usr/share/doc/${PF}"
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ default
+
+ use doc && dodoc -r html
+
+ doicon "${DISTDIR}"/${PN}.png
+ make_desktop_entry ${PN} Dillo
+}
diff --git a/www-client/dillo/metadata.xml b/www-client/dillo/metadata.xml
index bc1b97e1eb76..44685422a58c 100644
--- a/www-client/dillo/metadata.xml
+++ b/www-client/dillo/metadata.xml
@@ -5,4 +5,7 @@
<email>desktop-misc@gentoo.org</email>
<name>Gentoo Desktop Miscellaneous Project</name>
</maintainer>
+<use>
+<flag name='xembed'>Enable X11 XEmbed support</flag>
+</use>
</pkgmetadata>