summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-02-27 16:57:43 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2018-02-27 17:13:31 +0100
commit3b79c05ef4716e7bfbb973e55bcee573685545c5 (patch)
tree0f40d713516dfea143c4b1807f670b3a90bd475c /www-client/falkon
parentmedia-video/tsmuxer: Drop old (diff)
downloadgentoo-3b79c05ef4716e7bfbb973e55bcee573685545c5.tar.gz
gentoo-3b79c05ef4716e7bfbb973e55bcee573685545c5.tar.bz2
gentoo-3b79c05ef4716e7bfbb973e55bcee573685545c5.zip
www-client/falkon: New package
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'www-client/falkon')
-rw-r--r--www-client/falkon/Manifest1
-rw-r--r--www-client/falkon/falkon-3.0.0.ebuild58
-rw-r--r--www-client/falkon/metadata.xml11
3 files changed, 70 insertions, 0 deletions
diff --git a/www-client/falkon/Manifest b/www-client/falkon/Manifest
new file mode 100644
index 000000000000..bbd80e7362d2
--- /dev/null
+++ b/www-client/falkon/Manifest
@@ -0,0 +1 @@
+DIST falkon-3.0.0.tar.xz 1985800 BLAKE2B 8505e2c91600d265c28f70c37bf9e8f669ecd907dd9263371a4a4c10b854d32415ec1a3fd6ac163b297d0a9f42c542d4691a6cd417ed81864585f0c66b769e34 SHA512 1d99ecd47022986570dd6bb9b57484abe30838bf52daf669c977e1d2a9381efdd60912fd72b97e0b43b6102159f4343c4d1589d4f6442d0ed62c24f1482a8d97
diff --git a/www-client/falkon/falkon-3.0.0.ebuild b/www-client/falkon/falkon-3.0.0.ebuild
new file mode 100644
index 000000000000..53da752ba8f5
--- /dev/null
+++ b/www-client/falkon/falkon-3.0.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_TEST="true"
+QT_MINIMAL="5.9.2"
+inherit kde5
+
+DESCRIPTION="Cross-platform web browser using QtWebEngine"
+HOMEPAGE="https://www.qupzilla.com/"
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV%.0}/src/${P}.tar.xz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus gnome-keyring kwallet libressl +X"
+
+COMMON_DEPEND="
+ $(add_qt_dep qtdeclarative 'widgets')
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork 'ssl')
+ $(add_qt_dep qtprintsupport)
+ $(add_qt_dep qtsql 'sqlite')
+ $(add_qt_dep qtwebchannel)
+ $(add_qt_dep qtwebengine 'widgets')
+ $(add_qt_dep qtwidgets)
+ dbus? ( $(add_qt_dep qtdbus) )
+ gnome-keyring? ( gnome-base/gnome-keyring )
+ kwallet? ( $(add_frameworks_dep kwallet) )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:0= )
+ X? (
+ $(add_qt_dep qtx11extras)
+ x11-libs/libxcb:=
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_qt_dep linguist-tools)
+ $(add_qt_dep qtconcurrent)
+ gnome-keyring? ( virtual/pkgconfig )
+"
+RDEPEND="${COMMON_DEPEND}
+ !www-client/qupzilla
+ $(add_qt_dep qtsvg)
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_DBUS=$(usex !dbus)
+ -DBUILD_KEYRING=$(usex gnome-keyring)
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ -DNO_X11=$(usex !X)
+ )
+ kde5_src_configure
+}
diff --git a/www-client/falkon/metadata.xml b/www-client/falkon/metadata.xml
new file mode 100644
index 000000000000..007c58ff2baa
--- /dev/null
+++ b/www-client/falkon/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <use>
+ <flag name="kwallet">Enable encrypted storage of passwords with <pkg>kde-frameworks/kwallet</pkg></flag>
+ </use>
+</pkgmetadata>