summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2021-03-17 16:17:04 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-03-18 13:07:46 +0200
commit1860b3b3e2c71a36d66c6e63ff376372dc4a1885 (patch)
tree7e3fa2a85245cf000c18023af49f1e70ebe2dbed /www-client/surf
parentapp-misc/nnn: Version bump (v3.6) (diff)
downloadgentoo-1860b3b3e2c71a36d66c6e63ff376372dc4a1885.tar.gz
gentoo-1860b3b3e2c71a36d66c6e63ff376372dc4a1885.tar.bz2
gentoo-1860b3b3e2c71a36d66c6e63ff376372dc4a1885.zip
www-client/surf: Introduce tabbed use flag
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/surf')
-rw-r--r--www-client/surf/metadata.xml1
-rw-r--r--www-client/surf/surf-9999.ebuild8
2 files changed, 8 insertions, 1 deletions
diff --git a/www-client/surf/metadata.xml b/www-client/surf/metadata.xml
index 5e4c14c17c06..9abaaa711477 100644
--- a/www-client/surf/metadata.xml
+++ b/www-client/surf/metadata.xml
@@ -4,5 +4,6 @@
<!-- maintainer-needed -->
<use>
<flag name="savedconfig">Without a saved config.h, this package depends on <pkg>net-misc/curl</pkg> and <pkg>x11-terms/st</pkg> for a default download mechanism</flag>
+<flag name="tabbed">Install surf-open.sh script for running surf in <pkg>x11-misc/tabbed</pkg></flag>
</use>
</pkgmetadata>
diff --git a/www-client/surf/surf-9999.ebuild b/www-client/surf/surf-9999.ebuild
index 8670c83e868f..d6b737a623dc 100644
--- a/www-client/surf/surf-9999.ebuild
+++ b/www-client/surf/surf-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,6 +12,7 @@ EGIT_BRANCH="surf-webkit2"
LICENSE="MIT"
SLOT="0"
KEYWORDS=""
+IUSE="tabbed"
COMMON_DEPEND="
app-crypt/gcr[gtk]
@@ -33,6 +34,7 @@ RDEPEND="
x11-apps/xprop
x11-terms/st
)
+ tabbed? ( x11-misc/tabbed )
"
PATCHES=(
"${FILESDIR}"/${PN}-9999-gentoo.patch
@@ -62,5 +64,9 @@ src_prepare() {
src_install() {
default
+ if use tabbed; then
+ dobin surf-open.sh
+ fi
+
save_config config.h
}