summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2019-09-04 09:03:37 +0200
committerLars Wendler <polynomial-c@gentoo.org>2019-09-04 09:16:39 +0200
commitc6c5718a40db2adb0084150bf5fb30b4d29e53d5 (patch)
tree3ffd842aab1587ee8f7bf02b03e103f2dd496ac4 /www-servers/apache
parentnet-analyzer/ndsad: Drop ULOG support (diff)
downloadgentoo-c6c5718a40db2adb0084150bf5fb30b4d29e53d5.tar.gz
gentoo-c6c5718a40db2adb0084150bf5fb30b4d29e53d5.tar.bz2
gentoo-c6c5718a40db2adb0084150bf5fb30b4d29e53d5.zip
www-servers/apache: Added libressl patch
Thanks-to: Stefan Strogin <steils@gentoo.org> Closes: https://bugs.gentoo.org/668060 Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'www-servers/apache')
-rw-r--r--www-servers/apache/apache-2.4.41.ebuild4
-rw-r--r--www-servers/apache/files/apache-2.4.41-libressl.patch27
2 files changed, 31 insertions, 0 deletions
diff --git a/www-servers/apache/apache-2.4.41.ebuild b/www-servers/apache/apache-2.4.41.ebuild
index 08d40edf1cc4..36acc74b4126 100644
--- a/www-servers/apache/apache-2.4.41.ebuild
+++ b/www-servers/apache/apache-2.4.41.ebuild
@@ -160,6 +160,10 @@ RDEPEND+="${CDEPEND}"
REQUIRED_USE="apache2_modules_http2? ( ssl )
apache2_modules_md? ( ssl )"
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4.41-libressl.patch" #668060
+)
+
pkg_setup() {
# dependend critical modules which are not allowed in global scope due
# to USE flag conditionals (bug #499260)
diff --git a/www-servers/apache/files/apache-2.4.41-libressl.patch b/www-servers/apache/files/apache-2.4.41-libressl.patch
new file mode 100644
index 000000000000..86a1a7d02361
--- /dev/null
+++ b/www-servers/apache/files/apache-2.4.41-libressl.patch
@@ -0,0 +1,27 @@
+From d446b977f28ec79fffc2d2b45c671e037b709f19 Mon Sep 17 00:00:00 2001
+From: Stefan Strogin <steils@gentoo.org>
+Date: Wed, 28 Aug 2019 02:15:42 +0300
+Subject: [PATCH] mod_ssl: fix compilation with LibreSSL
+
+Upstream-Status: Submitted [https://github.com/apache/httpd/pull/64]
+Signed-off-by: Stefan Strogin <steils@gentoo.org>
+---
+ modules/ssl/ssl_engine_init.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/modules/ssl/ssl_engine_init.c b/modules/ssl/ssl_engine_init.c
+index f54c922fc7..646c903fea 100644
+--- a/modules/ssl/ssl_engine_init.c
++++ b/modules/ssl/ssl_engine_init.c
+@@ -1512,7 +1512,7 @@ static apr_status_t ssl_init_proxy_certs(server_rec *s,
+ X509_STORE_CTX *sctx;
+ X509_STORE *store = SSL_CTX_get_cert_store(mctx->ssl_ctx);
+
+-#if OPENSSL_VERSION_NUMBER >= 0x1010100fL
++#if OPENSSL_VERSION_NUMBER >= 0x1010100fL && !defined(LIBRESSL_VERSION_NUMBER)
+ /* For OpenSSL >=1.1.1, turn on client cert support which is
+ * otherwise turned off by default (by design).
+ * https://github.com/openssl/openssl/issues/6933 */
+--
+2.23.0
+