summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRalph Seichter <github@seichter.de>2019-09-20 18:50:14 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-09-20 21:17:51 +0300
commit8256a8f8b4907649a543ae9f0ac56b48181639b7 (patch)
tree3cc192ca5d388fd9d1b1b65f9f6f3a735576e517 /www-servers/nginx-unit
parentnet-wireless/nanovna-saver: initial commit (diff)
downloadgentoo-8256a8f8b4907649a543ae9f0ac56b48181639b7.tar.gz
gentoo-8256a8f8b4907649a543ae9f0ac56b48181639b7.tar.bz2
gentoo-8256a8f8b4907649a543ae9f0ac56b48181639b7.zip
www-servers/nginx-unit: Upstream release 1.11.0
Package-Manager: Portage-2.3.69, Repoman-2.3.16 Signed-off-by: Ralph Seichter <gentoo@seichter.de> Closes: https://github.com/gentoo/gentoo/pull/12980 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-servers/nginx-unit')
-rw-r--r--www-servers/nginx-unit/Manifest1
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.11.0.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/www-servers/nginx-unit/Manifest b/www-servers/nginx-unit/Manifest
index defa0ceaf858..2ee21d3c14f4 100644
--- a/www-servers/nginx-unit/Manifest
+++ b/www-servers/nginx-unit/Manifest
@@ -1,2 +1,3 @@
DIST nginx-unit-1.10.0.tar.gz 564348 BLAKE2B 82339422b4b3b696ff4bbb216d6c0d54f046531aa56f6e0f5602a9bbe18db878b6bc9c9e9b1513be0cee3197f288549d8a6f826bf69ffbb91fc35757775bde4d SHA512 da2b248ba22e5d46fa1c8c21041a875655fad0e1a09683c58cb5bb33ed0a671a921c7a13f99269f0574da02d0efaeff0233abc901e4e333f3f7ac9383334c781
+DIST nginx-unit-1.11.0.tar.gz 681333 BLAKE2B 4e727f1b0bd5a593ea360b4125173bc6b3694b953fa2c775ce4f7112bd9f2df131d4bfd4e01cb653c08a9cdacc560a6961b8926c797ea2ce7d6c32a7e4f7f7e2 SHA512 894093385137bc188c50b86540182007bac1740a063359f494c1984687352eccb879f7d6b7b6623d5702cce3c793f12c60a2dfab94bcf9cb817b80a1577409d9
DIST nginx-unit-1.8.0.tar.gz 511226 BLAKE2B e396b27954840a5f1ad3a4cd9501a5e5fe769a754c51043da784a2c4596e6acc33089f495bf412a0db086e5c715a51292c7dece004a6512564421a431b6c339e SHA512 1d0ad05343ff70aff4c6e221a36c20df95fa2e2262ae5c69963a9bcb9ef883151e8a2fa9fef29f43ac5489aa5cbb3e9dfd10cf5e7f6d7a98742b490ebf3a0413
diff --git a/www-servers/nginx-unit/nginx-unit-1.11.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.11.0.ebuild
new file mode 100644
index 000000000000..72e543d89536
--- /dev/null
+++ b/www-servers/nginx-unit/nginx-unit-1.11.0.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python2_7 python3_{5,6,7})
+
+inherit python-single-r1
+
+MY_P="unit-${PV}"
+DESCRIPTION="A dynamic web and application server"
+HOMEPAGE="https://unit.nginx.org"
+SRC_URI="https://unit.nginx.org/download/${MY_P}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+MY_USE="perl python ruby"
+MY_USE_PHP="php5-6 php7-1 php7-2 php7-3"
+IUSE="${MY_USE} ${MY_USE_PHP}"
+REQUIRED_USE="|| ( ${IUSE} )
+ python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="perl? ( dev-lang/perl:= )
+ php5-6? ( dev-lang/php:5.6[embed] )
+ php7-1? ( dev-lang/php:7.1[embed] )
+ php7-2? ( dev-lang/php:7.2[embed] )
+ php7-3? ( dev-lang/php:7.3[embed] )
+ python? ( ${PYTHON_DEPS} )
+ ruby? ( dev-lang/ruby:= )"
+RDEPEND="${DEPEND}"
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ ./configure \
+ --control=unix:/run/${PN}.sock \
+ --ld-opt="${LDFLAGS}" \
+ --log=/var/log/${PN} \
+ --modules=$(get_libdir)/${PN} \
+ --pid=/run/${PN}.pid \
+ --prefix=/usr \
+ --state=/var/lib/${PN} || die "Core configuration failed"
+ for flag in ${MY_USE} ; do
+ if use ${flag} ; then
+ ./configure ${flag} || die "Module configuration failed: ${flag}"
+ fi
+ done
+ for flag in ${MY_USE_PHP} ; do
+ if use ${flag} ; then
+ local php_slot="/usr/$(get_libdir)/${flag/-/.}"
+ ./configure php \
+ --module=${flag} \
+ --config=${php_slot}/bin/php-config \
+ --lib-path=${php_slot}/$(get_libdir) || die "Module configuration failed: ${flag}"
+ fi
+ done
+}
+
+src_install() {
+ default
+ diropts -m 0770
+ keepdir /var/lib/${PN}
+ newinitd "${FILESDIR}/${PN}.initd" ${PN}
+}