summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2020-02-29 07:10:30 +0100
committerHans de Graaff <graaff@gentoo.org>2020-02-29 07:57:24 +0100
commitcc4baf2d7281a98d9016e598b7784766da4529ea (patch)
treef9da1ea02fe91fc4d647cb6299d257acc9d9e54e /www-servers
parentapp-crypt/scute: remove retired maintainer (diff)
downloadgentoo-cc4baf2d7281a98d9016e598b7784766da4529ea.tar.gz
gentoo-cc4baf2d7281a98d9016e598b7784766da4529ea.tar.bz2
gentoo-cc4baf2d7281a98d9016e598b7784766da4529ea.zip
www-servers/puma: add 3.12.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'www-servers')
-rw-r--r--www-servers/puma/Manifest1
-rw-r--r--www-servers/puma/puma-3.12.4.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/www-servers/puma/Manifest b/www-servers/puma/Manifest
index 7bdebcca3378..9fa6a1d7d504 100644
--- a/www-servers/puma/Manifest
+++ b/www-servers/puma/Manifest
@@ -1,4 +1,5 @@
DIST puma-3.12.2.tar.gz 218109 BLAKE2B 82224c3a9c1b2c8e903e5f02a8b43effab820581abbaea5bea9c537eb36e39deb34d6f7d62d9fc42e1e5a6f3c153583d8e009c73864a9e57c39e2d31387b2813 SHA512 b0721dc9b380f1932a60a8ac2e1f0ef3869c735359e9a9e1e37bb118ebc3f550a24bd3e544142513ebeb1ee37ae01a41ec67e71e1d182faec0bb6ed4a60bafcf
DIST puma-3.12.3.tar.gz 218918 BLAKE2B 41bf89c63ddf6f3e1975f45db049150c6f362e028113fd1790cad30a512468e63785f892d9db7bc2bbf4232c87bb3ebf48f8f9f8d777faab93f8f5219c320508 SHA512 f3d1aac689f42f520feea39de0d56f68d58dc5dccacd412b110afc74edfc29aeefe2b06b22dc97f287accc89e55f8488b5bd9cc6e787e945d85a8e61ae1f0118
+DIST puma-3.12.4.tar.gz 219148 BLAKE2B d9fcef62474a1522c29f13fb2572c99bd6d4217bc94febb9c4fe6e699808ad0002fcd88dfd16884a5a9c7296e4d6dd08bc50ce7278f41608678feb18e3a034b4 SHA512 302505512b04c68f9794461b0e7693cd3ff4dfb325b18e50f0f659649c7f504f55765437382557c65bce45d32a1710ab16a875d1fc6d143d4ca297d2b2333108
DIST puma-4.3.1.tar.gz 239800 BLAKE2B 123dcb71dd310a960555fe801530586a39ef6876d9019549eb66590195ab1f450999d5365cf9ebbf2f057f2c641739f3fcdf743f5de076d7e637b0b17210410c SHA512 cbb5fc187d3aebfa255d3d0f2d897e109f50e18feadedbf02b73a350555dcbcfbfd91c0a810c11d6d3ac2ec26103479a53eed3fae77c96f1ae6cc2814960de46
DIST puma-4.3.2.tar.gz 240942 BLAKE2B d02a6b5894199607905fb0d1364719f61ea189ba5c04a06863ad5c448dd6dd3ba96e8557a9ae9f3562322b9c8cbdf1189d89b7a4f344da0245ba4abfbdacaeee SHA512 a295a8fbfd03519cd87c44737783cd893d486dd8e8b63c1b07d4ea4aa706b12c36d210d9e56daf5490d0205ea7ddd2a77dc28159c90d2edafbbf3ce1ae8c24e0
diff --git a/www-servers/puma/puma-3.12.4.ebuild b/www-servers/puma/puma-3.12.4.ebuild
new file mode 100644
index 000000000000..6d43e6fb3a09
--- /dev/null
+++ b/www-servers/puma/puma-3.12.4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="a simple, fast, threaded, and highly concurrent HTTP 1.1 server for Ruby/Rack"
+HOMEPAGE="https://puma.io/"
+SRC_URI="https://github.com/puma/puma/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="3"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/openssl:0 test? ( net-misc/curl )"
+RDEPEND+=" dev-libs/openssl:0"
+
+ruby_add_bdepend "virtual/ruby-ssl
+ test? ( dev-ruby/rack >=dev-ruby/minitest-5.9:5 >=dev-ruby/test-unit-3.0:2 )"
+
+all_ruby_prepare() {
+ eapply "${FILESDIR}/${PN}-3.12.1-ruby26-waitpid.patch"
+
+ sed -i -e '/bundler/ s:^:#:' test/helper.rb || die
+
+ # Avoid test failing inconsistently
+ sed -i -e '/phased_restart_via_pumactl/,/^ end/ s:^:#:' test/test_integration.rb || die
+
+ # Avoid test that trigger a bug in ruby very easily and lead to
+ # failure. This affects all current puma versions in combination
+ # with the latest ruby versions, so we add this new version anyway
+ # while allowing these tests to fail.
+ # https://github.com/puma/puma/pull/1345
+ rm -f test/test_puma_server_ssl.rb || die
+
+ # Use correct ruby version
+ sed -i -e 's/ruby -rrubygems/#{Gem.ruby} -rrubygems/' test/shell/t{1,3}.rb || die
+}
+
+each_ruby_prepare() {
+ sed -i -e 's:ruby -rubygems:'${RUBY}' -rubygems:' \
+ -e 's/localhost/127.0.0.1/' test/shell/* || die
+ sed -i -e '1ilog_requests' test/shell/t{1,2}_conf.rb || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/puma_http11 extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/puma_http11
+ cp ext/puma_http11/puma_http11$(get_modname) lib/puma/ || die
+}
+
+each_ruby_test() {
+ einfo "Running test suite"
+ ${RUBY} -Ilib:.:test -e "gem 'minitest', '~>5.9'; gem 'test-unit', '~>3.0'; require 'minitest/autorun'; Dir['test/**/*test_*.rb'].each{|f| require f}" || die
+
+ einfo "Running integration tests"
+ pushd test/shell
+ #sh run.sh || die
+ popd
+}