summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-apps/xclock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-apps/xclock')
-rw-r--r--x11-apps/xclock/Manifest2
-rw-r--r--x11-apps/xclock/metadata.xml5
-rw-r--r--x11-apps/xclock/xclock-1.0.6.ebuild20
-rw-r--r--x11-apps/xclock/xclock-1.0.7.ebuild20
4 files changed, 47 insertions, 0 deletions
diff --git a/x11-apps/xclock/Manifest b/x11-apps/xclock/Manifest
new file mode 100644
index 000000000000..ba0076b3a8e3
--- /dev/null
+++ b/x11-apps/xclock/Manifest
@@ -0,0 +1,2 @@
+DIST xclock-1.0.6.tar.bz2 156817 SHA256 21bb6f57b0a158c05a47558302321c4764a8d2e1b8e5d4ad23e3809b4cee3fd0 SHA512 78431bc38b15f395a69b672c618bf4126e73727f4df5e8a2744a258d0b856ab4c0f918ef4ff16994cc48f3ce61b291c632e150f19ee9b3dc9ffeb470c7cdae3a WHIRLPOOL c1ef3001c0a86026d7de6130d1765d0bc9fd9462dbc6927c6c50981db3685c5f6e84f421919fd709a26c061beb321776d7d6c302301b835a3ca68ceba2c63ddf
+DIST xclock-1.0.7.tar.bz2 164035 SHA256 23ceeca94e3e20a6c26a703ac7f789066d4517f8d2cb717ae7cb28a617d97dd0 SHA512 56689bdae6c83e9e1da5c4c48cf1136ca8b4f45b177f27bc1deeb24758e2c180035b639e8df72e3ebf32dc301bceb59118309fcce2ffab54e5abe9bfa645e607 WHIRLPOOL ebcc870b133d6ae03e39f3bc8f8eb65775ab9dda60fafa91d8609a002e0e797c2dda0879bd5a8c36fb5e2dbcc921defb2a35633fd902700c773a6c402baf7355
diff --git a/x11-apps/xclock/metadata.xml b/x11-apps/xclock/metadata.xml
new file mode 100644
index 000000000000..01c4c004e735
--- /dev/null
+++ b/x11-apps/xclock/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>x11</herd>
+</pkgmetadata>
diff --git a/x11-apps/xclock/xclock-1.0.6.ebuild b/x11-apps/xclock/xclock-1.0.6.ebuild
new file mode 100644
index 000000000000..afa34cb37dbc
--- /dev/null
+++ b/x11-apps/xclock/xclock-1.0.6.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit xorg-2
+
+DESCRIPTION="analog / digital clock for X"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"
diff --git a/x11-apps/xclock/xclock-1.0.7.ebuild b/x11-apps/xclock/xclock-1.0.7.ebuild
new file mode 100644
index 000000000000..f66fac90c4ec
--- /dev/null
+++ b/x11-apps/xclock/xclock-1.0.7.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit xorg-2
+
+DESCRIPTION="analog / digital clock for X"
+
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXaw"
+DEPEND="${RDEPEND}"