summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2017-01-20 10:08:49 -0800
committerMatt Turner <mattst88@gentoo.org>2017-01-20 10:09:45 -0800
commitb4380da432e0da79850700d44e08ac983cc0f8d6 (patch)
tree453dac80e4d4c072e8659bb0f04824db65816692 /x11-libs/libICE
parentdev-python/sphinx: Depend on dev-python/alabaster-0.7.9 at least (diff)
downloadgentoo-b4380da432e0da79850700d44e08ac983cc0f8d6.tar.gz
gentoo-b4380da432e0da79850700d44e08ac983cc0f8d6.tar.bz2
gentoo-b4380da432e0da79850700d44e08ac983cc0f8d6.zip
x11-libs/libICE: Require libbsd unconditionally.
Bug: https://bugs.gentoo.org/540742
Diffstat (limited to 'x11-libs/libICE')
-rw-r--r--x11-libs/libICE/libICE-1.0.9-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-libs/libICE/libICE-1.0.9-r1.ebuild b/x11-libs/libICE/libICE-1.0.9-r1.ebuild
new file mode 100644
index 000000000000..2621d20785ba
--- /dev/null
+++ b/x11-libs/libICE/libICE-1.0.9-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+inherit xorg-2
+
+DESCRIPTION="X.Org Inter-Client Exchange library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~hppa-hpux ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="ipv6"
+
+RDEPEND="dev-libs/libbsd
+ x11-libs/xtrans
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ xorg-2_pkg_setup
+
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc docs)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+}