summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2016-10-24 20:49:26 -0700
committerMatt Turner <mattst88@gentoo.org>2016-10-24 20:52:18 -0700
commitf2cfed7a4bc36e58ebcf5a4edff9aa2facf5be43 (patch)
tree4321f11de223a50b4aa7174ec421314b65e38a7d /x11-libs/libXfont2
parentx11-libs/libXi: Version bump to 1.7.8. (diff)
downloadgentoo-f2cfed7a4bc36e58ebcf5a4edff9aa2facf5be43.tar.gz
gentoo-f2cfed7a4bc36e58ebcf5a4edff9aa2facf5be43.tar.bz2
gentoo-f2cfed7a4bc36e58ebcf5a4edff9aa2facf5be43.zip
x11-libs/libXfont2: Add 9999 ebuild.
Bug: https://bugs.gentoo.org/594296
Diffstat (limited to 'x11-libs/libXfont2')
-rw-r--r--x11-libs/libXfont2/libXfont2-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-libs/libXfont2/libXfont2-9999.ebuild b/x11-libs/libXfont2/libXfont2-9999.ebuild
new file mode 100644
index 000000000000..d2124d1c2601
--- /dev/null
+++ b/x11-libs/libXfont2/libXfont2-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+XORG_DOC=doc
+EGIT_REPO_URI="git://anongit.freedesktop.org/xorg/lib/libXfont"
+inherit xorg-2
+
+DESCRIPTION="X.Org Xfont library"
+
+KEYWORDS=""
+IUSE="bzip2 ipv6 truetype"
+
+RDEPEND="x11-libs/xtrans
+ x11-libs/libfontenc
+ truetype? ( >=media-libs/freetype-2 )
+ bzip2? ( app-arch/bzip2 )
+ x11-proto/xproto
+ >=x11-proto/fontsproto-2.1.3"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS=(
+ $(use_enable ipv6)
+ $(use_enable doc devel-docs)
+ $(use_with doc xmlto)
+ $(use_with bzip2)
+ $(use_enable truetype freetype)
+ --without-fop
+ )
+ xorg-2_src_configure
+}